summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
-rwxr-xr-xfind-deps.py48
3 files changed, 22 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdcfd5528861..bec1cb92be2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vlc-nightly
pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot
- pkgver = 4.0.0v20190706
+ pkgver = 4.0.0v20200328
pkgrel = 1
url = https://nightlies.videolan.org/
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = vlc-nightly
makedepends = libavc1394
makedepends = libcaca
makedepends = gtk3
+ makedepends = lua
makedepends = librsvg
makedepends = libgme
makedepends = xosd
@@ -23,15 +24,17 @@ pkgbase = vlc-nightly
makedepends = avahi
makedepends = libsystemd
makedepends = libmtp
- makedepends = libmicrodns
makedepends = libdvdcss
makedepends = smbclient
+ makedepends = flex
+ makedepends = bison
makedepends = vcdimager
makedepends = libssh2
makedepends = mesa
makedepends = protobuf
makedepends = libnfs
makedepends = mpg123
+ makedepends = srt
makedepends = libdvdread
makedepends = libdvdnav
makedepends = libogg
@@ -126,7 +129,6 @@ pkgbase = vlc-nightly
optdepends = libnfs: NFS access
optdepends = mpg123: mpg123 codec
optdepends = protobuf: chromecast streaming
- optdepends = libmicrodns: mDNS services discovery (chromecast etc)
optdepends = lua-socket: http interface
optdepends = live-media: RTSP input
optdepends = libdvdread: DVD input module
@@ -174,14 +176,12 @@ pkgbase = vlc-nightly
conflicts = vlc
replaces = vlc-plugin
options = !emptydirs
- source = http://nightlies.videolan.org/build/source/vlc-4.0.0-20190706-0230-dev.tar.xz
+ source = http://nightlies.videolan.org/build/source/vlc-4.0.0-20200328-0231-dev.tar.xz
source = update-vlc-plugin-cache.hook
source = 0001-lua-Fix-build-using-lua-5.3.patch
- source = find-deps.py
- sha256sums = a2c23b668a73e832867b459f7e8fad74b17f3cd0bc15a2e6a330c8aca09593b4
+ sha256sums = 984d90b4985028f6d87e18a007ea43eb938c339541d9c6d2ac9e1c1f39d6f446
sha256sums = c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a
sha256sums = 3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf
- sha256sums = 90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7
pkgname = vlc-nightly
diff --git a/PKGBUILD b/PKGBUILD
index c855308a5c8c..dec7eed87ac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=4.0.0v20190706
+pkgver=4.0.0v20200328
_pkgver=4.0.0
-_snapshot_=20190706
-_snapver_=0230
+_snapshot_=20200328
+_snapver_=0231
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
@@ -25,10 +25,10 @@ depends=('qt5-graphicaleffects' 'qt5-quickcontrols2' 'a52dec' 'libdvbpsi'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
'wayland-protocols' 'aribb24' 'libfdk-aac')
makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
- 'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
+ 'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3' 'lua'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
- 'libmtp' 'libmicrodns' 'libdvdcss' 'smbclient'
- 'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123'
+ 'libmtp' 'libdvdcss' 'smbclient' 'flex' 'bison'
+ 'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123' 'srt'
'libdvdread' 'libdvdnav' 'libogg' 'libshout' 'libmodplug' 'libvpx'
'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
@@ -59,7 +59,7 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libnfs: NFS access'
'mpg123: mpg123 codec'
'protobuf: chromecast streaming'
- 'libmicrodns: mDNS services discovery (chromecast etc)'
+ # 'libmicrodns: mDNS services discovery (chromecast etc)'
'lua-socket: http interface'
'live-media: RTSP input'
'libdvdread: DVD input module'
@@ -111,8 +111,7 @@ replaces=("${_appname_}-plugin")
options=('!emptydirs')
source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-${_suffix_}.tar.xz"
'update-vlc-plugin-cache.hook'
- '0001-lua-Fix-build-using-lua-5.3.patch'
- 'find-deps.py')
+ '0001-lua-Fix-build-using-lua-5.3.patch')
pkgver() {
printf ${_pkgver}v$_snapshot_
@@ -126,6 +125,7 @@ prepare() {
patch -Np1 -i "${srcdir}/0001-lua-Fix-build-using-lua-5.3.patch"
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
+ sed -e 's|-Werror-implicit-function-declaration||g' -i configure
sed 's|whoami|echo builduser|g' -i configure
sed 's|hostname -f|echo arch|g' -i configure
@@ -138,7 +138,7 @@ build() {
export CPPFLAGS+=" -I/usr/include/samba-4.0"
export CXXFLAGS+=" -std=c++11"
export LUAC=/usr/bin/luac
- export LUA_LIBS="`pkg-config --libs lua`"
+ export LUA_LIBS="$(pkg-config --libs lua)"
export RCC=/usr/bin/rcc-qt5
# export CC=clang
# export CXX=clang++
@@ -219,7 +219,7 @@ build() {
--enable-avahi \
--enable-mtp \
--enable-upnp \
- --enable-microdns \
+ --disable-microdns \
--enable-libxml2 \
--enable-libgcrypt \
--enable-gnutls \
@@ -236,7 +236,7 @@ build() {
--disable-daala \
--enable-fdkaac \
--disable-decklink \
- --disable-skins2 \
+ --enable-skins2 \
--disable-medialibrary
# note: removing --enable-daala for now because it is currently broken
# change --enable-fdkaac to --disable-fdkaac if you want to redistribute the binary
@@ -251,22 +251,15 @@ package() {
make -i DESTDIR="${pkgdir}" install
- for res in 16 32 48 128; do
+ for res in 16 32 48 128 256; do
install -D -m644 "${srcdir}/${_appname_}-${_pkgver}-${_suffix_}/share/icons/${res}x${res}/${_appname_}.png" \
"${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${_appname_}.png"
done
install -Dm644 "$srcdir"/update-vlc-plugin-cache.hook "$pkgdir"/usr/share/libalpm/hooks/update-vlc-plugin-cache.hook
- # Update dependencies automatically based on dynamic libraries
- # _detected_depends=($(find "$pkgdir"/usr -name "*.so" | xargs python "$srcdir"/find-deps.py))
-
- # msg 'Auto-detected dependencies:'
- # echo "${_detected_depends[@]}" | fold -s -w 79 | sed 's/^/ /'
- # depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
-sha256sums=('a2c23b668a73e832867b459f7e8fad74b17f3cd0bc15a2e6a330c8aca09593b4'
+sha256sums=('984d90b4985028f6d87e18a007ea43eb938c339541d9c6d2ac9e1c1f39d6f446'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
- '3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf'
- '90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')
+ '3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf')
diff --git a/find-deps.py b/find-deps.py
deleted file mode 100755
index 92095f934cfd..000000000000
--- a/find-deps.py
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/usr/bin/env python3
-
-"""
-Usage: find-deps.py <binary> [<binary> ...]
-
-Finds (pacman/ALPM) dependencies for a binary or set of binaries based
-on dynamically linked libraries.
-
-"""
-
-import sys
-import os
-import subprocess
-import re
-
-def subprocess_get_lines(args, fail_okay=False):
- try:
- output = subprocess.check_output(args)
- except subprocess.CalledProcessError as e:
- if fail_okay:
- output = e.output
- else:
- raise
- return output.decode().splitlines()
-
-# Get the filenames of the libs we need
-#del os.environ['LD_PRELOAD'] # otherwise fakeroot will interfere
-ldd_output = subprocess_get_lines(['ldd'] + sys.argv[1:])
-regex = re.compile(r' => (.*) \(0x[0-9a-f]+\)$')
-libs = set(match.group(1) for match in map(regex.search, ldd_output) if match)
-
-# Figure out which packages own them
-deps = set(subprocess_get_lines(
- ['pacman', '--query', '--owns', '--quiet'] + list(libs),
- fail_okay=True
-))
-
-# Remove redundant dependencies
-needed = set(deps)
-for pkg in deps:
- if pkg not in needed:
- continue # this subtree has already been pruned
- redundant = subprocess_get_lines(
- ['pactree', '--unique', pkg]
- )[1:] # first line is pkg itself
- needed.difference_update(redundant)
-
-print(' '.join(sorted(needed)))