summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--0001-lua-Fix-build-using-lua-5.3.patch (renamed from 0001-lua-fix-build-using-lua-5.3.patch)9
-rw-r--r--PKGBUILD53
-rwxr-xr-xupdate.sh16
4 files changed, 58 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa129321d1b9..4dc202e0c4ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = vlc-nightly
pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot
- pkgver = 4.0.0v20181007
+ pkgver = 4.0.0v20190127
pkgrel = 1
url = https://nightlies.videolan.org/
arch = x86_64
license = LGPL2.1
license = GPL2
- makedepends = aribb24
makedepends = gst-plugins-base-libs
makedepends = live-media
makedepends = libnotify
- makedepends = glibc
makedepends = libbluray
makedepends = flac
makedepends = libdc1394
@@ -62,21 +60,18 @@ pkgbase = vlc-nightly
makedepends = libgoom2
makedepends = projectm
makedepends = chromaprint
- makedepends = libfdk-aac
+ makedepends = fluidsynth
makedepends = portaudio
makedepends = sidplay2-libs
makedepends = sndio
- depends = aribb25
- depends = libmfx
+ makedepends = vulkan-headers
depends = a52dec
- depends = libidn
depends = libdvbpsi
depends = libxpm
depends = libdca
depends = libproxy
- depends = glibc
- depends = libtiger
depends = lua
+ depends = libidn
depends = libmatroska
depends = taglib
depends = libmpcdec
@@ -86,10 +81,8 @@ pkgbase = vlc-nightly
depends = libmad
depends = libmpeg2
depends = xcb-util-keysyms
- depends = mesa
depends = libtar
depends = libxinerama
- depends = libxkbcommon
depends = libsecret
depends = libarchive
depends = qt5-base
@@ -103,6 +96,7 @@ pkgbase = vlc-nightly
depends = gnutls
depends = libplacebo
depends = wayland-protocols
+ depends = aribb24
optdepends = avahi: service discovery using bonjour protocol
optdepends = gst-plugins-base-libs: for libgst plugins
optdepends = libdvdcss: decoding encrypted DVDs
@@ -145,7 +139,6 @@ pkgbase = vlc-nightly
optdepends = libx264: H264 encoding
optdepends = x265: HEVC/H.265 encoder
optdepends = zvbi: VBI/Teletext decoding
- optdepends = aribb24: ARIB subtitles
optdepends = libass: Subtitle support
optdepends = libkate: Kate codec
optdepends = libtiger: Tiger rendering for Kate streams
@@ -164,7 +157,7 @@ pkgbase = vlc-nightly
optdepends = ncurses: ncurses interface
optdepends = libnotify: notification plugin
optdepends = gtk3: notification plugin
- optdepends = libfdk-aac: FDK AAC codec
+ optdepends = fluidsynth: FluidSynth plugin for MIDI playback
optdepends = portaudio: portaudio support
optdepends = vcdimager: navigate VCD with libvcdinfo
optdepends = schroedinger: schroedinger codec support
@@ -175,13 +168,13 @@ pkgbase = vlc-nightly
conflicts = vlc
replaces = vlc-plugin
options = !emptydirs
- source = http://nightlies.videolan.org/build/source/vlc-4.0.0-20181007-0231-dev.tar.xz
+ source = http://nightlies.videolan.org/build/source/vlc-4.0.0-20190127-0231-dev.tar.xz
source = update-vlc-plugin-cache.hook
- source = 0001-lua-fix-build-using-lua-5.3.patch
+ source = 0001-lua-Fix-build-using-lua-5.3.patch
source = find-deps.py
- sha256sums = 875078ec8a3912a51225701cb29ca7fb75d66a48adf2546ad63930c58569ec5e
+ sha256sums = 479f8e90d2ff300047eddda33a5c63bcfedc54d6fdd5e1fc46fc548fa065a6c7
sha256sums = c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a
- sha256sums = 75ad8802bad1a79754e40fd107f5a6922c54f7467dadef8b439b49d410c8f7d2
+ sha256sums = 3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf
sha256sums = 90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7
pkgname = vlc-nightly
diff --git a/0001-lua-fix-build-using-lua-5.3.patch b/0001-lua-Fix-build-using-lua-5.3.patch
index 0acbb211f71e..2be304288ff7 100644
--- a/0001-lua-fix-build-using-lua-5.3.patch
+++ b/0001-lua-Fix-build-using-lua-5.3.patch
@@ -1,14 +1,14 @@
-From 5824efb5fbb8aa00773aa2ff891645d17e68efc8 Mon Sep 17 00:00:00 2001
+From 8dc6dcc3c79aef64cc6aa50cbcd769503d9e5b1b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 24 Feb 2018 01:32:40 +0100
-Subject: [PATCH] lua: fix build using lua 5.3
+Subject: [PATCH 1/3] lua: Fix build using lua 5.3
---
modules/lua/vlc.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
-index 71f381d334a..b46b5f67a1b 100644
+index 71f381d334..b46b5f67a1 100644
--- a/modules/lua/vlc.h
+++ b/modules/lua/vlc.h
@@ -38,6 +38,7 @@
@@ -19,3 +19,6 @@ index 71f381d334a..b46b5f67a1b 100644
#define LUA_COMPAT_MODULE
#include <lua.h> /* Low level lua C API */
#include <lauxlib.h> /* Higher level C API */
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index a9d3b0252dff..2efd522d1e4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=4.0.0v20181007
+pkgver=4.0.0v20190127
_pkgver=4.0.0
-_snapshot_=20181007
+_snapshot_=20190127
_snapver_=0231
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
@@ -16,25 +16,24 @@ pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot'
url='https://nightlies.videolan.org/'
arch=('x86_64')
license=('LGPL2.1' 'GPL2')
-depends=('aribb25' 'libmfx' 'a52dec' 'libidn' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'glibc' 'libtiger' 'lua'
+depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'lua' 'libidn'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp' 'libmad'
- 'libmpeg2' 'xcb-util-keysyms' 'mesa' 'libtar' 'libxinerama' 'libxkbcommon' 'libsecret'
+ 'libmpeg2' 'xcb-util-keysyms' 'libtar' 'libxinerama' 'libsecret'
'libarchive' 'qt5-base' 'qt5-x11extras' 'qt5-svg' 'freetype2'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
- 'wayland-protocols')
-makedepends=('aribb24' 'gst-plugins-base-libs' 'live-media' 'libnotify' 'glibc' 'libbluray'
+ 'wayland-protocols' 'aribb24')
+makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
'libmtp' 'libmicrodns' 'libdvdcss' 'smbclient'
'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123'
'libdvdread' 'libdvdnav' 'libogg' 'libshout' 'libmodplug' 'libvpx'
- 'libvorbis' 'speex' 'opus' 'libtheora' 'libpng'
- 'libjpeg-turbo' 'libx265.so' 'libx264.so' 'zvbi' 'libass'
- 'libkate' 'libtiger' 'sdl_image' 'libpulse' 'alsa-lib' 'jack'
- 'libsamplerate' 'libsoxr' 'lirc' 'libgoom2' 'projectm'
- 'chromaprint'
+ 'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
+ 'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
+ 'sdl_image' 'libpulse' 'alsa-lib' 'jack' 'libsamplerate' 'libsoxr'
+ 'lirc' 'libgoom2' 'projectm' 'chromaprint'
- 'libfdk-aac' 'portaudio' 'sidplay2-libs' 'sndio')
+ 'fluidsynth' 'portaudio' 'sidplay2-libs' 'sndio' 'vulkan-headers')
optdepends=('avahi: service discovery using bonjour protocol'
'gst-plugins-base-libs: for libgst plugins'
'libdvdcss: decoding encrypted DVDs'
@@ -77,7 +76,6 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libx264: H264 encoding'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext decoding'
- 'aribb24: ARIB subtitles'
'libass: Subtitle support'
'libkate: Kate codec'
'libtiger: Tiger rendering for Kate streams'
@@ -96,19 +94,22 @@ optdepends=('avahi: service discovery using bonjour protocol'
'ncurses: ncurses interface'
'libnotify: notification plugin'
'gtk3: notification plugin'
- 'libfdk-aac: FDK AAC codec'
+
+ 'fluidsynth: FluidSynth plugin for MIDI playback'
'portaudio: portaudio support'
'vcdimager: navigate VCD with libvcdinfo'
'schroedinger: schroedinger codec support'
'sidplay2-libs: for C64 sid demuxer'
'sndio: for OpenBSD sndio audio output')
+# note: removing 'daala-git: for Daala video support' because it is currently broken
+# removing 'libfdk-aac: FDK AAC codec' because it is currently broken
conflicts=("${_appname_}-plugin" "${_appname_}")
provides=("${_appname_}")
replaces=("${_appname_}-plugin")
options=('!emptydirs')
source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-${_suffix_}.tar.xz"
'update-vlc-plugin-cache.hook'
- '0001-lua-fix-build-using-lua-5.3.patch'
+ '0001-lua-Fix-build-using-lua-5.3.patch'
'find-deps.py')
pkgver() {
@@ -120,27 +121,30 @@ prepare() {
./bootstrap
- patch -Np1 -i "${srcdir}/0001-lua-fix-build-using-lua-5.3.patch"
+ patch -Np1 -i "${srcdir}/0001-lua-Fix-build-using-lua-5.3.patch"
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
sed 's|whoami|echo builduser|g' -i configure
sed 's|hostname -f|echo arch|g' -i configure
+
+ # libplacebo 0.6 API
+ sed 's|pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);|pl_shader_alloc(tc->pl_ctx, NULL, 0);|' -i modules/video_output/opengl/vout_helper.c
}
build() {
cd "${_appname_}-${_pkgver}-${_suffix_}"
- export CFLAGS+=" -I/usr/include/samba-4.0"
+ export CFLAGS+=" -I/usr/include/samba-4.0"
export CPPFLAGS+=" -I/usr/include/samba-4.0"
export CXXFLAGS+=" -std=c++11"
export LUAC=/usr/bin/luac
export LUA_LIBS="`pkg-config --libs lua`"
- export LDFLAGS+=" `pkg-config --libs xkbcommon` "
export RCC=/usr/bin/rcc-qt5
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
+ --with-kde-solid=/usr/share/solid/actions/ \
--enable-nls \
--enable-archive \
--enable-live555 \
@@ -227,12 +231,13 @@ build() {
--enable-notify \
--enable-libplacebo \
--enable-vlc \
+ --enable-aribsub \
\
--libexecdir=/usr/lib \
- --disable-daala \
- --enable-fdkaac \
- --with-kde-solid=/usr/share/solid/actions/ \
- --enable-aribsub
+ --disable-daala \
+ --disable-fdkaac
+ # note: removing --enable-daala for now because it is currently broken
+ # removing --enable-fdkaac for now because it is currently broken
make V=1
}
@@ -256,7 +261,7 @@ package() {
# depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
-sha256sums=('875078ec8a3912a51225701cb29ca7fb75d66a48adf2546ad63930c58569ec5e'
+sha256sums=('479f8e90d2ff300047eddda33a5c63bcfedc54d6fdd5e1fc46fc548fa065a6c7'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
- '75ad8802bad1a79754e40fd107f5a6922c54f7467dadef8b439b49d410c8f7d2'
+ '3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf'
'90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')
diff --git a/update.sh b/update.sh
index f6148abd78de..5c91c597e0fe 100755
--- a/update.sh
+++ b/update.sh
@@ -1,9 +1,19 @@
-#!/usr/bin/bash
+#!/bin/bash
set -e
shopt -s nocasematch
-source '/usr/share/makepkg/util.sh'
-[[ -t 2 ]] && colorize
+
+if [[ -f '/usr/share/makepkg/util.sh' ]]; then
+ source '/usr/share/makepkg/util.sh'
+ [[ -t 2 ]] && colorize
+else
+ function msg() {
+ echo '=>' "$@"
+ }
+ function msg2() {
+ echo ' ' "$@"
+ }
+fi
msg 'Query list of nightly sources'
srcurl='http://nightlies.videolan.org/build/source/'