summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
-rw-r--r--vlc30
3 files changed, 18 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40724c149438..957eba412f39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jul 14 04:39:57 UTC 2017
+# Mon Oct 16 15:28:36 UTC 2017
pkgbase = vlc-nightly
pkgdesc = A multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot
- pkgver = 3.0.0v20170713
+ pkgver = 3.0.0v20171016
pkgrel = 1
url = http://www.videolan.org/vlc/
arch = i686
@@ -99,14 +99,12 @@ pkgbase = vlc-nightly
conflicts = vlc-plugin
conflicts = vlc
replaces = vlc-plugin
- options = !libtool
options = !emptydirs
- options = !debug
- source = http://nightlies.videolan.org/build/source/vlc-3.0.0-20170713-0242-git.tar.xz
+ source = http://nightlies.videolan.org/build/source/vlc-3.0.0-20171016-0238-git.tar.xz
source = update-vlc-plugin-cache.hook
source = https://git.archlinux.org/svntogit/packages.git/plain/trunk/lua53_compat.patch?h=packages/vlc
source = find-deps.py
- sha256sums = f5310f5c2afe7651480517a3a1c288f6cb440ba2ddafdd7faefa71201332d7b0
+ sha256sums = 82abfbd64cd6606afaf1c938f5b7cb8e29484d258719ee674d1a769bfce94431
sha256sums = c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a
sha256sums = d1cb88a1037120ea83ef75b2a13039a16825516b776d71597d0e2eae5df2d8fa
sha256sums = 90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7
diff --git a/PKGBUILD b/PKGBUILD
index 7110ba0def8b..b5f3becdc0d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=3.0.0v20170713
+pkgver=3.0.0v20171016
_pkgver=3.0.0
-_snapshot_=20170713
-_snapver_=0242
+_snapshot_=20171016
+_snapver_=0238
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot"
@@ -58,7 +58,7 @@ optdepends=('aalib: for ASCII art plugin'
conflicts=("${_appname_}-plugin" "${_appname_}")
provides=("${_appname_}")
replaces=("${_appname_}-plugin")
-options=("!libtool" "!emptydirs" "!debug")
+options=("!emptydirs")
source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-git.tar.xz"
"update-vlc-plugin-cache.hook"
"https://git.archlinux.org/svntogit/packages.git/plain/trunk/lua53_compat.patch?h=packages/vlc"
@@ -76,8 +76,14 @@ build() {
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
# Config
- [ ${CARCH} = 'x86_64' ] && CXXFLAGS="$CXXFLAGS -fPIC"
- CFLAGS+=" -I/usr/include/samba-4.0" CPPFLAGS+=" -I/usr/include/samba-4.0" CXXFLAGS+=" -std=gnu++11" \
+ export CFLAGS+=" -I/usr/include/samba-4.0"
+ export CPPFLAGS+=" -I/usr/include/samba-4.0"
+ export CXXFLAGS+=" -std=gnu++11"
+ export LUAC=/usr/bin/luac
+ export LUA_LIBS="`pkg-config --libs lua`"
+ export RCC=/usr/bin/rcc-qt5
+ export PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig"
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
@@ -93,9 +99,7 @@ build() {
--enable-fdkaac \
--enable-archive \
--enable-bluray \
- --enable-daala
- LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
- RCC=/usr/bin/rcc-qt5
+ --enable-daala
./compile
}
@@ -119,7 +123,7 @@ package() {
# depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
-sha256sums=('f5310f5c2afe7651480517a3a1c288f6cb440ba2ddafdd7faefa71201332d7b0'
+sha256sums=('82abfbd64cd6606afaf1c938f5b7cb8e29484d258719ee674d1a769bfce94431'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
'd1cb88a1037120ea83ef75b2a13039a16825516b776d71597d0e2eae5df2d8fa'
'90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')
diff --git a/vlc b/vlc
deleted file mode 100644
index aeff7b2fd778..000000000000
--- a/vlc
+++ /dev/null
@@ -1,30 +0,0 @@
-commit 41caaa08cde60c4fec4bf2e5f9610e2a1b9e6a23
-Author: Vinson Lee <vlee@freedesktop.org>
-Date: Thu Feb 5 14:48:53 2015 -0800
-
- lua: Define LUA_COMPAT_APIINTCASTS for Lua >= 5.3.0 compatibility.
-
- In Lua 5.3.0, luaL_checkint was deprecated.
-
- This patch fixes this build error with Lua 5.3.0.
-
- lua/demux.c: In function ‘vlclua_demux_peek’:
- lua/demux.c:55:5: error: implicit declaration of function ‘luaL_checkint’ [-Werror=implicit-function-declaration]
- int n = luaL_checkint( L, 1 );
- ^
-
- Signed-off-by: Vinson Lee <vlee@freedesktop.org>
- Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
-
-diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
-index efd94f1..85c7fc1 100644
---- a/modules/lua/vlc.h
-+++ b/modules/lua/vlc.h
-@@ -38,6 +38,7 @@
- #include <vlc_stream.h>
- #include <vlc_demux.h>
-
-+#define LUA_COMPAT_APIINTCASTS
- #define LUA_COMPAT_MODULE
- #include <lua.h> /* Low level lua C API */
- #include <lauxlib.h> /* Higher level C API */