summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f926027ff84c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vmd-stride
+ pkgdesc = Used by VMD to compute the secondary structure given the protein 3D coordinates
+ pkgver = 19950628
+ pkgrel = 1
+ url = http://www.ks.uiuc.edu/Research/vmd/doxygen/extprogs.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://www.ks.uiuc.edu/Research/vmd/extsrcs/Stride_src.tar.Z
+ sha256sums = c40f7de64947ebab7ec49511c0d264b08bc0fcbc703014bdc85d83a7389be230
+
+pkgname = vmd-stride
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6000dc166238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+
+pkgname=vmd-stride
+pkgver=19950628
+pkgrel=1
+pkgdesc="Used by VMD to compute the secondary structure given the protein 3D coordinates"
+url="http://www.ks.uiuc.edu/Research/vmd/doxygen/extprogs.html"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('glibc')
+source=('http://www.ks.uiuc.edu/Research/vmd/extsrcs/Stride_src.tar.Z')
+sha256sums=('c40f7de64947ebab7ec49511c0d264b08bc0fcbc703014bdc85d83a7389be230')
+
+build() {
+ cd "${srcdir}"
+ make stride
+}
+
+package() {
+ cd "${srcdir}"
+ install -D -m 755 stride "${pkgdir}/usr/bin/stride"
+ # Is all of the STRIDE code under this license, or only part of it?
+ head -n 73 nsc.h > LICENSE
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}