summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD94
-rw-r--r--python_3_syntax.patch35
-rw-r--r--python_version.patch69
4 files changed, 111 insertions, 130 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5050457b0c1e..c276f40b4ac9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
pkgbase = vmdebootstrap
- pkgdesc = debootstrap installs a basic Debian system into a directory, for use with chroot(8). vmdeboostrap is a wrapper around it to install Debian into a disk image, which can be used with a virtual machine (such as KVM).
- pkgver = 1.6
- pkgrel = 2
- url = http://liw.fi/vmdebootstrap/
- arch = i686
- arch = x86_64
+ pkgdesc = Bootstrap Debian into a (virtual machine) disk image
+ pkgver = 1.11
+ pkgrel = 1
+ url = http://git.liw.fi/vmdebootstrap/
+ arch = any
license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-sphinx
+ makedepends = python-wheel
depends = debootstrap
- depends = syslinux
- depends = qemu
- depends = parted
- depends = multipath-tools
- depends = python2
- depends = python2-cliapp
depends = distro-info
- source = http://git.liw.fi/cgi-bin/cgit/cgit.cgi/vmdebootstrap/snapshot/vmdebootstrap-1.6.tar.gz
- source = python_version.patch
+ depends = multipath-tools
+ depends = parted
+ depends = python
+ depends = python-cliapp-fiw
+ depends = qemu
+ depends = syslinux
+ options = !strip
+ source = http://git.liw.fi/cgi-bin/cgit/cgit.cgi/vmdebootstrap/snapshot/vmdebootstrap-1.11.tar.gz
source = default_arch.patch
source = fix_path.patch
- md5sums = 90dd5a8aff602273c76644dda166e3e7
- md5sums = 9ec42862d167c76139f453ed9651dd8e
- md5sums = 3c3d9df067faa0d742011ad0943427e9
- md5sums = 806fd64966193e9ae0fb4ab56ab7f3f9
+ source = 0001-Don-t-enforce-U-EFI-on-arm64.patch
+ source = python_3_syntax.patch
+ sha512sums = d5e0d1c19487e7ec03377eab4aa82631f37dc0ef0366dbf512a41c5a7feb4880dc0ed8ad8731f0a0fcb147bdb7dd2b3248039bbdaf4ddf38e05abd5ff6f39aa8
+ sha512sums = f4d553b0364275809fd19f1597a149f7f8c6d4b53a654011700b2bb44b12a7bce08370488a36b359d56bfe90329b727f3f018d5670aac8c6aa3635ee26313fe7
+ sha512sums = 64e32ecf6ac9089433da632b6406f3ef6da242d2443574af5a6f7d2ecdc4cb2fa3e0e366c47f890123266650dd3ccdafb797f675c96d5035aa4bd40472a7ed3c
+ sha512sums = c023215ca973d198e9067c4126252f9f9402235d22ae9d033df43fe0bc995df033620301b6ab0790964e0cd24d0d3f9bf88b2e806c0c85216dd27cf1b51775d4
+ sha512sums = 1458c0c0f915ca31f6e5c4cd4e103c831ee44d82bbecdee6e6116316dd780fef2232d4160478b8f33a14afd9ccf27c36b1a2cfaf6f46da93023f8b6c5973affe
pkgname = vmdebootstrap
-
diff --git a/PKGBUILD b/PKGBUILD
index 70b22e65a697..5f61a569d8a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,75 @@
# Maintainer: Andreas Grapentin <andreas@grapentin.org>
+# Contributor: Claudia Pellegrino <aur ät cpellegrino.de>
+
pkgname=vmdebootstrap
pkgver=1.11
pkgrel=1
-pkgdesc="debootstrap installs a basic Debian system into a directory, for use with chroot(8). vmdeboostrap is a wrapper around it to install Debian into a disk image, which can be used with a virtual machine (such as KVM)."
-arch=('i686' 'x86_64')
-
-url="http://liw.fi/vmdebootstrap/"
+pkgdesc='Bootstrap Debian into a (virtual machine) disk image'
+arch=('any')
+url='http://git.liw.fi/vmdebootstrap/'
license=('GPL3')
+depends=(
+ 'debootstrap'
+ 'distro-info'
+ 'multipath-tools'
+ 'parted'
+ 'python'
+ 'python-cliapp-fiw'
+ 'qemu'
+ 'syslinux'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-wheel'
+)
+options=('!strip')
-depends=('debootstrap'
- 'syslinux'
- 'qemu'
- 'parted'
- 'multipath-tools'
- 'python2'
- 'python2-cliapp'
- 'distro-info')
-
-makedepends=('python-sphinx')
-
-source=("http://git.liw.fi/cgi-bin/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.gz"
- 'python_version.patch'
- 'default_arch.patch'
- 'fix_path.patch'
- '0001-Don-t-enforce-U-EFI-on-arm64.patch')
-
-sha256sums=('4a1b32e1ceb68a87a38c64b226cd2b827fafdec5e2c0135b50f83f7a455e5582'
- '10ef6c58c24d52ff3b66498eac23526623b881871ce1d3d2138e358ef9580f41'
- 'a9971329a87e08f3de371647fe60b0ffab99ecd7925c55a00fdb1f2ef70781f0'
- 'e8d3a250dc8bf11aafa707602c9ca6d496b3c3c3183dcf9f04a50de6a3b26b75'
- 'ca5bfcddcbdfe25a2cc0b5c1adab57ed647074e38964b014f2a028afa0091d86')
+source=(
+ "http://git.liw.fi/cgi-bin/cgit/cgit.cgi/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz"
+ 'default_arch.patch'
+ 'fix_path.patch'
+ '0001-Don-t-enforce-U-EFI-on-arm64.patch'
+ 'python_3_syntax.patch'
+)
+sha512sums=(
+ 'd5e0d1c19487e7ec03377eab4aa82631f37dc0ef0366dbf512a41c5a7feb4880dc0ed8ad8731f0a0fcb147bdb7dd2b3248039bbdaf4ddf38e05abd5ff6f39aa8'
+ 'f4d553b0364275809fd19f1597a149f7f8c6d4b53a654011700b2bb44b12a7bce08370488a36b359d56bfe90329b727f3f018d5670aac8c6aa3635ee26313fe7'
+ '64e32ecf6ac9089433da632b6406f3ef6da242d2443574af5a6f7d2ecdc4cb2fa3e0e366c47f890123266650dd3ccdafb797f675c96d5035aa4bd40472a7ed3c'
+ 'c023215ca973d198e9067c4126252f9f9402235d22ae9d033df43fe0bc995df033620301b6ab0790964e0cd24d0d3f9bf88b2e806c0c85216dd27cf1b51775d4'
+ '1458c0c0f915ca31f6e5c4cd4e103c831ee44d82bbecdee6e6116316dd780fef2232d4160478b8f33a14afd9ccf27c36b1a2cfaf6f46da93023f8b6c5973affe'
+)
prepare() {
- cd "$pkgname-$pkgver"
-
- patch -p1 < ../python_version.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < ../default_arch.patch
patch -p1 < ../fix_path.patch
patch -p1 < ../0001-Don-t-enforce-U-EFI-on-arm64.patch
+ patch -p1 < ../python_3_syntax.patch
}
build() {
- cd "$pkgname-$pkgver"
-
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
make -C man man
}
package() {
- cd "$pkgname-$pkgver"
-
- python2 setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python -I -m installer --destdir="${pkgdir}" dist/*.whl
- mkdir -p ${pkgdir}/usr/share/man/man8/
- cp man/_build/man/vmdebootstrap.8 ${pkgdir}/usr/share/man/man8/
+ echo >&2 'Packaging the license'
+ install -D -m 644 COPYING \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
- mkdir -p ${pkgdir}/usr/share/doc/$pkgname
- cp COPYING ${pkgdir}/usr/share/doc/$pkgname
- cp README ${pkgdir}/usr/share/doc/$pkgname
+ echo >&2 'Packaging the README'
+ install -D -m 644 README \
+ "${pkgdir}"/usr/share/doc/${pkgname}/README
- mkdir -p ${pkgdir}/usr/share/licenses/$pkgname
- cd ${pkgdir}/usr/share/licenses/$pkgname
- ln -s ../../doc/$pkgname/COPING COPYING
+ echo >&2 'Packaging the manual'
+ install -D -m 644 -t "${pkgdir}/usr/share/man/man8" \
+ man/_build/man/${pkgname}.8
}
diff --git a/python_3_syntax.patch b/python_3_syntax.patch
new file mode 100644
index 000000000000..9b087dcaf84d
--- /dev/null
+++ b/python_3_syntax.patch
@@ -0,0 +1,35 @@
+diff --git a/bin/vmdebootstrap b/bin/vmdebootstrap
+index d9a697d..c59da3f 100755
+--- a/bin/vmdebootstrap
++++ b/bin/vmdebootstrap
+@@ -418,7 +418,7 @@ class VmDebootstrap(cliapp.Application): # pylint: disable=too-many-public-meth
+
+ # /boot partitioning offset calculation
+ # returns partoffset
+- if self.settings['bootoffset'] and self.settings['bootoffset'] is not '0':
++ if self.settings['bootoffset'] and self.settings['bootoffset'] != '0':
+ # turn v.small offsets into something at least possible to create.
+ if self.settings['bootoffset'] < 1048576:
+ partoffset = 1
+@@ -433,7 +433,7 @@ class VmDebootstrap(cliapp.Application): # pylint: disable=too-many-public-meth
+
+ # /boot creation - move into base but keep the check
+ # needs extent, partoffset, bootsize: no return
+- if self.settings['bootsize'] and self.settings['bootsize'] is not '0%':
++ if self.settings['bootsize'] and self.settings['bootsize'] != '0%':
+ boot_fs_type = 'ext2'
+ if self.settings['boottype'] in ('vfat', 'msdos'):
+ boot_fs_type = 'fat16'
+diff --git a/vmdebootstrap/filesystem.py b/vmdebootstrap/filesystem.py
+index b911c05..d068b0d 100644
+--- a/vmdebootstrap/filesystem.py
++++ b/vmdebootstrap/filesystem.py
+@@ -126,7 +126,7 @@ class Filesystem(Base):
+ raise cliapp.AppException(msg)
+ root = '/dev/mapper/%s' % devices[rootindex]
+ if self.settings['bootsize'] or self.settings['use-uefi']:
+- boot = '/dev/mapper/%s' % devices[bootindex].decode('utf-8')
++ boot = '/dev/mapper/%s' % devices[bootindex]
+ if self.settings['swap'] > 0:
+ swap = '/dev/mapper/%s' % devices[swapindex]
+ self.devices['rootdev'] = root
diff --git a/python_version.patch b/python_version.patch
deleted file mode 100644
index 70d1e4b3a3e5..000000000000
--- a/python_version.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-diff -rupN vmdebootstrap-1.6/bin/vmdebootstrap vmdebootstrap-1.6.new/bin/vmdebootstrap
---- vmdebootstrap-1.6/bin/vmdebootstrap 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/bin/vmdebootstrap 2016-08-23 12:34:23.979524142 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#! /usr/bin/python2
- # Copyright 2011-2013 Lars Wirzenius
- # Copyright 2012 Codethink Limited
- # Copyright 2014-2015 Neil Williams <codehelp@debian.org>
-diff -rupN vmdebootstrap-1.6/doc/conf.py vmdebootstrap-1.6.new/doc/conf.py
---- vmdebootstrap-1.6/doc/conf.py 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/doc/conf.py 2016-08-23 12:34:38.249608970 +0200
-@@ -55,7 +55,7 @@ copyright = '2015 Neil Williams'
- # built documents.
- #
- # The short X.Y version.
--version = subprocess.Popen(['python', 'setup.py', '-V'], cwd=r'..', stdout=subprocess.PIPE).stdout.read().rstrip()
-+version = subprocess.Popen(['python2', 'setup.py', '-V'], cwd=r'..', stdout=subprocess.PIPE).stdout.read().rstrip()
- # The full version, including alpha/beta/rc tags.
- release = version
-
-diff -rupN vmdebootstrap-1.6/examples/lava-submit.py vmdebootstrap-1.6.new/examples/lava-submit.py
---- vmdebootstrap-1.6/examples/lava-submit.py 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/examples/lava-submit.py 2016-08-23 12:34:14.232799577 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#! /usr/bin/python2
- # -*- coding: utf-8 -*-
- #
- # lava-submit.py
-diff -rupN vmdebootstrap-1.6/man/conf.py vmdebootstrap-1.6.new/man/conf.py
---- vmdebootstrap-1.6/man/conf.py 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/man/conf.py 2016-08-23 12:33:56.296026448 +0200
-@@ -49,7 +49,7 @@ copyright = u'2015, Neil Williams'
- # built documents.
- #
- # The short X.Y version.
--version = subprocess.Popen(['python', 'setup.py', '-V'], cwd=r'..', stdout=subprocess.PIPE).stdout.read()
-+version = subprocess.Popen(['python2', 'setup.py', '-V'], cwd=r'..', stdout=subprocess.PIPE).stdout.read()
- # The full version, including alpha/beta/rc tags.
- release = version
-
-diff -rupN vmdebootstrap-1.6/setup.py vmdebootstrap-1.6.new/setup.py
---- vmdebootstrap-1.6/setup.py 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/setup.py 2016-08-23 12:33:34.665898221 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- # -*- coding: utf-8 -*-
- #
- # setup.py
-diff -rupN vmdebootstrap-1.6/vmextract.py vmdebootstrap-1.6.new/vmextract.py
---- vmdebootstrap-1.6/vmextract.py 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/vmextract.py 2016-08-23 12:33:34.665898221 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#! /usr/bin/python2
- # -*- coding: utf-8 -*-
- #
- # Copyright 2015 Neil Williams <codehelp@debian.org>
-diff -rupN vmdebootstrap-1.6/vmsquashtar.py vmdebootstrap-1.6.new/vmsquashtar.py
---- vmdebootstrap-1.6/vmsquashtar.py 2016-08-11 23:13:45.000000000 +0200
-+++ vmdebootstrap-1.6.new/vmsquashtar.py 2016-08-23 12:33:34.665898221 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- # -*- coding: utf-8 -*-
- #
- # vmsquash-tar.py