summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba6beccaf30f..e6f8eb1a5997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = vmware-auto-unlocker
pkgdesc = Unlocker for VMWare macOS
- pkgver = 1.1
+ pkgver = 1.1.3
pkgrel = 1
url = https://github.com/paolo-projects/auto-unlocker/
arch = x86_64
license = GPL3
depends = curl
depends = libarchive
- source = https://github.com/paolo-projects/auto-unlocker/releases/download/v1.1/autounlocker_1.1.0_amd64.deb
- sha512sums = a42c12b63774f5b8317dd1ac350b1c1f3ae9f8b3b11e1238db41725a595a8ca29b54886dce8db98e8a4bd15798d0fec280fe44221b05430f7e733d2663c6a364
+ source = git+https://github.com/paolo-projects/auto-unlocker.git#tag=v1.1.3
+ sha512sums = SKIP
pkgname = vmware-auto-unlocker
-
diff --git a/PKGBUILD b/PKGBUILD
index 3263cf9ed327..e2f31fdbb2ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
-# Maintainer: mrAppleXZ <mr.applexz@gmail.com>
+# Miantainer : Yamada Hayao <hayao@fascode.net>
+# Contributer: mrAppleXZ <mr.applexz@gmail.com>
pkgname=vmware-auto-unlocker
-pkgver=1.1
+pkgver=1.1.3
pkgrel=1
pkgdesc="Unlocker for VMWare macOS"
arch=('x86_64')
url="https://github.com/paolo-projects/auto-unlocker/"
license=('GPL3')
depends=('curl' 'libarchive')
-source=("https://github.com/paolo-projects/auto-unlocker/releases/download/v${pkgver}/autounlocker_${pkgver}.0_amd64.deb")
-sha512sums=('a42c12b63774f5b8317dd1ac350b1c1f3ae9f8b3b11e1238db41725a595a8ca29b54886dce8db98e8a4bd15798d0fec280fe44221b05430f7e733d2663c6a364')
+source=("git+https://github.com/paolo-projects/auto-unlocker.git#tag=v${pkgver}")
+sha512sums=('SKIP')
+
+build(){
+ cd "${srcdir}/auto-unlocker"
+ make
+}
package() {
- msg2 "Extracting the data.tar.xz..."
- bsdtar -xf data.tar.xz -C "$pkgdir/"
+ cd "${srcdir}/auto-unlocker"
+ make PREFIX="${pkgdir}/usr" install
}