summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba6beccaf30f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vmware-auto-unlocker
+ pkgdesc = Unlocker for VMWare macOS
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/paolo-projects/auto-unlocker/
+ arch = x86_64
+ license = GPL3
+ depends = curl
+ depends = libarchive
+ source = https://github.com/paolo-projects/auto-unlocker/releases/download/v1.1/autounlocker_1.1.0_amd64.deb
+ sha512sums = a42c12b63774f5b8317dd1ac350b1c1f3ae9f8b3b11e1238db41725a595a8ca29b54886dce8db98e8a4bd15798d0fec280fe44221b05430f7e733d2663c6a364
+
+pkgname = vmware-auto-unlocker
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c9374ee2c96b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.deb
+*.pkg*
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3263cf9ed327
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: mrAppleXZ <mr.applexz@gmail.com>
+
+pkgname=vmware-auto-unlocker
+pkgver=1.1
+pkgrel=1
+pkgdesc="Unlocker for VMWare macOS"
+arch=('x86_64')
+url="https://github.com/paolo-projects/auto-unlocker/"
+license=('GPL3')
+depends=('curl' 'libarchive')
+source=("https://github.com/paolo-projects/auto-unlocker/releases/download/v${pkgver}/autounlocker_${pkgver}.0_amd64.deb")
+sha512sums=('a42c12b63774f5b8317dd1ac350b1c1f3ae9f8b3b11e1238db41725a595a8ca29b54886dce8db98e8a4bd15798d0fec280fe44221b05430f7e733d2663c6a364')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}