summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
-rw-r--r--vmware-horizon.svg65
3 files changed, 84 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf929762e4bd..d3539f858f14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = vmware-horizon-client
pkgdesc = VMware Horizon Client connect to VMware Horizon virtual desktop
pkgver = 5.3.0
- pkgrel = 1
+ pkgrel = 3
url = https://www.vmware.com/go/viewclients
arch = x86_64
license = custom
makedepends = libxslt
makedepends = patchelf
+ makedepends = librsvg
source = vmware-horizon-client-5.3.0-15208949-x86_64.bundle::https://download3.vmware.com/software/view/viewclients/CART20FQ4/VMware-Horizon-Client-5.3.0-15208949.x64.bundle
source = http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/vmware-bundle.eclass
source = vmware-horizon-usb
source = vmware-horizon-usb.service
source = vmware-horizon-virtual-printing.service
+ source = vmware-horizon.svg
sha256sums = 4f2a8d5f420d467233c28f59fd9c20f2e39abcac4983d9248d5c1515c53d3253
sha256sums = d8794c22229afdeb698dae5908b7b2b3880e075b19be38e0b296bb28f4555163
sha256sums = 008b60ebf45f7d1e033c8ad8ce1688d5e1c59fc0668493067fb89b563b1dc00f
sha256sums = a897c1b9e8928fc222880ebbfc7bb6aff940bff4acf4e4e0cd4002fff81c7226
sha256sums = e47e770a1e19ed321de7c2765b2d682f59ac466aef92b2e4ea5e65cacf56de36
+ sha256sums = cea92d3ed97b717c631fed5664c06fc71a6deac21ba32da78970c582ed48c747
pkgname = vmware-horizon-client
install = vmware-horizon-client.install
diff --git a/PKGBUILD b/PKGBUILD
index 23999dc4df7b..1e3175925240 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,22 +16,24 @@ _bundled_with_client=('vmware-horizon-pcoip'
pkgver=5.3.0
_build=15208949
_cart='CART20FQ4'
-pkgrel=1
+pkgrel=3
pkgdesc='VMware Horizon Client connect to VMware Horizon virtual desktop'
arch=('x86_64')
url='https://www.vmware.com/go/viewclients'
license=('custom')
-makedepends=('libxslt' 'patchelf')
+makedepends=('libxslt' 'patchelf' 'librsvg')
source=("${pkgbase}-${pkgver}-${_build}-x86_64.bundle::https://download3.vmware.com/software/view/viewclients/${_cart}/VMware-Horizon-Client-${pkgver}-${_build}.x64.bundle"
'http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/vmware-bundle.eclass'
'vmware-horizon-usb'
'vmware-horizon-usb.service'
- 'vmware-horizon-virtual-printing.service')
+ 'vmware-horizon-virtual-printing.service'
+ 'vmware-horizon.svg')
sha256sums=('4f2a8d5f420d467233c28f59fd9c20f2e39abcac4983d9248d5c1515c53d3253'
'd8794c22229afdeb698dae5908b7b2b3880e075b19be38e0b296bb28f4555163'
'008b60ebf45f7d1e033c8ad8ce1688d5e1c59fc0668493067fb89b563b1dc00f'
'a897c1b9e8928fc222880ebbfc7bb6aff940bff4acf4e4e0cd4002fff81c7226'
- 'e47e770a1e19ed321de7c2765b2d682f59ac466aef92b2e4ea5e65cacf56de36')
+ 'e47e770a1e19ed321de7c2765b2d682f59ac466aef92b2e4ea5e65cacf56de36'
+ 'cea92d3ed97b717c631fed5664c06fc71a6deac21ba32da78970c582ed48c747')
# We need these functions for the Gentoo eclass...
ebegin() {
@@ -91,8 +93,10 @@ build() {
# remove keymap files, depend on vmware-keymaps instead
rm -rf "${srcdir}"/extract/vmware-horizon-pcoip/pcoip/lib/vmware/xkeymap/
- sed -i -e '/Name=/a Comment=Connect to VMware Horizon View virtual machines' -e '/Icon=/s/.png$//' \
+ # remove png icon, we install svg and rendered pngs
+ sed -i -e '/Name=/a Comment=Connect to VMware Horizon View virtual machines' -e '/^Icon=/c Icon=vmware-horizon' \
"${srcdir}"/extract/vmware-horizon-client/share/applications/vmware-view.desktop
+ rm -r "${srcdir}"/extract/vmware-horizon-client/share/{icons,pixmaps}/
}
package_vmware-horizon-client() {
@@ -135,6 +139,12 @@ package_vmware-horizon-client() {
mkdir -p "${pkgdir}/usr/"
install -D -m0755 vmware-view "${pkgdir}/usr/lib/vmware/view/bin/vmware-view"
cp -a lib/ "${pkgdir}/usr/"
+
+ install -D -m0644 "${srcdir}/vmware-horizon.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/vmware-horizon.svg"
+ for SIZE in 16 24 32 48 64 96 128; do
+ install -d "${pkgdir}/usr/share/icons/hicolor/${SIZE}x${SIZE}/apps/"
+ rsvg-convert -w "${SIZE}" -h "${SIZE}" "${srcdir}/vmware-horizon.svg" > "${pkgdir}/usr/share/icons/hicolor/${SIZE}x${SIZE}/apps/vmware-horizon.png"
+ done
}
package_vmware-horizon-rtav() {
diff --git a/vmware-horizon.svg b/vmware-horizon.svg
new file mode 100644
index 000000000000..cc42c5399907
--- /dev/null
+++ b/vmware-horizon.svg
@@ -0,0 +1,65 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg width="36px" height="36px" viewBox="0 0 36 36" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
+ <!-- Generator: Sketch 52.4 (67378) - http://www.bohemiancoding.com/sketch -->
+ <title>icon</title>
+ <desc>Created with Sketch.</desc>
+ <defs>
+ <linearGradient x1="24.2890026%" y1="-20.0781533%" x2="54.4680307%" y2="44.7810498%" id="linearGradient-1">
+ <stop stop-color="#000F55" stop-opacity="0.94" offset="0%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0.72" offset="11%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0.33" offset="35%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0.09" offset="54%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0" offset="67%"></stop>
+ </linearGradient>
+ <linearGradient x1="13.1276145%" y1="-25.7413522%" x2="45.4866599%" y2="40.8614387%" id="linearGradient-2">
+ <stop stop-color="#000F55" stop-opacity="0.282495471" offset="0%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0" offset="100%"></stop>
+ </linearGradient>
+ <linearGradient x1="-52.304878%" y1="110.560102%" x2="43.9756098%" y2="57.398977%" id="linearGradient-3">
+ <stop stop-color="#266900" offset="0%"></stop>
+ <stop stop-color="#3E8514" offset="9%"></stop>
+ <stop stop-color="#549E26" offset="21%"></stop>
+ <stop stop-color="#66B335" offset="34%"></stop>
+ <stop stop-color="#73C13F" offset="48%"></stop>
+ <stop stop-color="#7AC945" offset="65%"></stop>
+ <stop stop-color="#7CCC47" offset="94%"></stop>
+ </linearGradient>
+ <linearGradient x1="35.8804688%" y1="28.9081886%" x2="72.9826828%" y2="58.1984225%" id="linearGradient-4">
+ <stop stop-color="#000F55" stop-opacity="0.295969203" offset="0%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0" offset="100%"></stop>
+ </linearGradient>
+ <linearGradient x1="54.9636981%" y1="25.5407996%" x2="78.9779999%" y2="70.1264376%" id="linearGradient-5">
+ <stop stop-color="#000F55" stop-opacity="0.413156703" offset="0%"></stop>
+ <stop stop-color="#000F55" stop-opacity="0" offset="100%"></stop>
+ </linearGradient>
+ <linearGradient x1="-10.9092299%" y1="-70.117454%" x2="71.6691915%" y2="113.882337%" id="linearGradient-6">
+ <stop stop-color="#266900" offset="0%"></stop>
+ <stop stop-color="#357A0C" offset="10%"></stop>
+ <stop stop-color="#539D26" offset="34%"></stop>
+ <stop stop-color="#6AB738" offset="57%"></stop>
+ <stop stop-color="#77C743" offset="78%"></stop>
+ <stop stop-color="#7CCC47" offset="94%"></stop>
+ </linearGradient>
+ <linearGradient x1="-94.8333333%" y1="106.074169%" x2="51.3205128%" y2="44.6930946%" id="linearGradient-7">
+ <stop stop-color="#266900" offset="0%"></stop>
+ <stop stop-color="#3E8514" offset="9%"></stop>
+ <stop stop-color="#549E26" offset="21%"></stop>
+ <stop stop-color="#66B335" offset="34%"></stop>
+ <stop stop-color="#73C13F" offset="48%"></stop>
+ <stop stop-color="#7AC945" offset="65%"></stop>
+ <stop stop-color="#7CCC47" offset="94%"></stop>
+ </linearGradient>
+ </defs>
+ <g id="icon" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
+ <g id="Horizon_Final" transform="translate(2.000000, 3.000000)">
+ <polygon id="Path" fill="url(#linearGradient-1)" opacity="0.5" points="31.9591837 22.8540323 16.9861224 22.9387097 0.0408163265 13.2830645 25.4326531 2.92016129 31.9591837 6.64112903"></polygon>
+ <polygon id="Path" fill="url(#linearGradient-2)" opacity="0.5" points="31.9591837 29.9766129 14.3657143 29.9766129 2.00489796 22.925 27.0204082 17.1540323 31.9591837 19.9701613"></polygon>
+ <path d="M13.2580645,-9.34628045 L22.6129032,-9.34628045 L22.6129032,22.5720869 L13.2580645,22.5720869 C11.1201881,22.5720869 9.38709677,20.8177741 9.38709677,18.6537196 L9.38709677,-5.4279131 C9.38709677,-7.59196763 11.1201881,-9.34628045 13.2580645,-9.34628045 Z" id="Path" fill="url(#linearGradient-3)" transform="translate(16.000000, 6.612903) rotate(90.000000) translate(-16.000000, -6.612903) "></path>
+ <path d="M28.9183673,22.6693548 L27.2432653,22.6927419 L8.76408163,12.1629032 L19.8367347,4.49274194 L31.9567347,11.4040323 L31.9567347,19.6225806 C31.9564804,21.2876097 30.6035928,22.6442406 28.9183673,22.6693548 Z" id="Path" fill="url(#linearGradient-4)" opacity="0.5"></path>
+ <path d="M28.9795918,22.6008065 L27.8114286,22.6137097 L9.5844898,12.2298387 L27.6620408,10.8330645 L31.9591837,13.2830645 L31.9591837,19.6225806 C31.9592956,21.2539616 30.6308369,22.5818112 28.9795918,22.6008065 Z" id="Path" fill="url(#linearGradient-5)" opacity="0.5"></path>
+ <path d="M24.4669388,20.8516129 C27.5453063,20.8516129 30.0408163,18.3862905 30.0408163,15.3451613 C30.0408163,12.304032 27.5453063,9.83870968 24.4669388,9.83870968 L24.4604082,9.83870968 C23.3813972,6.14828225 19.9617973,3.60772974 16.0734694,3.60772974 C12.1851415,3.60772974 8.76554157,6.14828225 7.68653061,9.83870968 L7.68081633,9.83870968 C4.60244876,9.83870968 2.10693878,12.304032 2.10693878,15.3451613 C2.10693878,18.3862905 4.60244876,20.8516129 7.68081633,20.8516129 L24.4669388,20.8516129 Z" id="Path" fill="#FFFFFF"></path>
+ <path d="M20.0236735,25.8870968 L11.957551,25.8870968 C11.6756696,25.8882632 11.4079584,26.009333 11.2228571,26.2193548 L9.30367347,28.3967742 C9.0517501,28.6826068 8.99190847,29.0874114 9.15056667,29.4324801 C9.30922487,29.7775488 9.65717805,29.9993634 10.0408163,30 L21.9591837,30 C22.3430288,29.9989673 22.6908955,29.7765569 22.84907,29.4310462 C23.0072444,29.0855356 22.946578,28.6805964 22.6938776,28.3951613 L20.7640816,26.2177419 C20.5773676,26.0068363 20.3072904,25.8862275 20.0236735,25.8870968 Z" id="Path" fill="url(#linearGradient-6)"></path>
+ <path d="M12.8548387,4.36339697 L15.2741935,4.36339697 C17.41207,4.36339697 19.1451613,6.11770979 19.1451613,8.28176432 L19.1451613,32.363397 C19.1451613,34.5274515 17.41207,36.2817643 15.2741935,36.2817643 L12.8548387,36.2817643 L12.8548387,4.36339697 Z" id="Path" fill="url(#linearGradient-7)" transform="translate(16.000000, 20.322581) rotate(90.000000) translate(-16.000000, -20.322581) "></path>
+ </g>
+ </g>
+</svg> \ No newline at end of file