summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--vmmon.patch12
3 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c10966f18d5c..d88ae2e86b63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 17.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -57,7 +57,7 @@ pkgbase = vmware-workstation
sha256sums = fe1b1be8297f4170406f97dd1f8b385d911faf45afe19cbc0c26b8092b3ddf8d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 56519232870055e6cacd62bc830127cbbdc30554c4ffffa381c8c108b50f739f
+ sha256sums = 2bd592c28c383264a14167ddca8686912ddbadb1ba16d40560d75b082d439ed7
sha256sums = 4332a189c79ce15fa4d59dc45cffc78f42f48cfbb059b5eeafbb43a9cac835ba
pkgname = vmware-workstation
diff --git a/PKGBUILD b/PKGBUILD
index 7b433385fda4..cb576b875d5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=vmware-workstation
pkgver=17.5.1
_buildver=23298084
_pkgver=${pkgver}_${_buildver}
-pkgrel=1
+pkgrel=2
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -92,7 +92,7 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '56519232870055e6cacd62bc830127cbbdc30554c4ffffa381c8c108b50f739f'
+ '2bd592c28c383264a14167ddca8686912ddbadb1ba16d40560d75b082d439ed7'
'4332a189c79ce15fa4d59dc45cffc78f42f48cfbb059b5eeafbb43a9cac835ba'
)
options=(!strip emptydirs !debug)
diff --git a/vmmon.patch b/vmmon.patch
index cb61e59db62e..9e1ac166c7fd 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -235,3 +235,15 @@ index 5d08f33a..c1e6c671 100644
HostIFStartTimer(Bool rateChanged, //IN: Did rate change?
unsigned int rate) //IN: current clock rate
{
+Fix from https://communities.vmware.com/t5/VMware-Workstation-Pro/Workstation-17-5-0-vmware-clk-spinning-on-CPU-when-Linux-VMs-are/m-p/2996282
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -3350,7 +3350,7 @@
+ * threads running in the monitor on all physical CPUs.
+ */
+
+- if (rate > MIN_RATE) {
++ if (false) {
+ if (!linuxState.fastClockThread) {
+ struct task_struct *rtcTask;
+