summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--vmblock.patch9
3 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54b390ca47b0..89f3b7c08347 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 12.5.7_5813279
- pkgrel = 6
+ pkgrel = 7
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -80,7 +80,7 @@ pkgbase = vmware-workstation
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 911a68af1c62f409e5e97c230ab67505ba2d1fe2e214d3ca4e0a11282d16efda
sha256sums = f03c329dff2cf9a2fdfad938c4ce4ac5502fad5de1ef76a951dbc365748d1698
- sha256sums = 0a5aa819ca73513407acaf67779d95745314f7222afbd3fc2eadc80f24054d47
+ sha256sums = 00be9dbef75266d882cbdc8cc0b8f78cd3b081d8ca9a3cbfa17cfc34b3f1a52f
sha256sums = 6b0edcccad66ee1f971b675de4af704749d4677a4fc75a5026e47dc11435902c
sha256sums = b04baffa8ee7b5be56aba3d49d9c06be5e34a31808a6f93b899408dbda9aef40
sha256sums = 4c960079fec78682000a1c2e82dcaae69a6e91858dea641b707cf60674f3799f
diff --git a/PKGBUILD b/PKGBUILD
index e20794a1442a..602df6a3eff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ _pkgver=${pkgver}
#pkgver=12.5.7
#_buildver=5813279
#_pkgver=${pkgver}_${_buildver}
-pkgrel=6
+pkgrel=7
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -116,7 +116,7 @@ sha256sums=(
'911a68af1c62f409e5e97c230ab67505ba2d1fe2e214d3ca4e0a11282d16efda'
'f03c329dff2cf9a2fdfad938c4ce4ac5502fad5de1ef76a951dbc365748d1698'
- '0a5aa819ca73513407acaf67779d95745314f7222afbd3fc2eadc80f24054d47'
+ '00be9dbef75266d882cbdc8cc0b8f78cd3b081d8ca9a3cbfa17cfc34b3f1a52f'
'6b0edcccad66ee1f971b675de4af704749d4677a4fc75a5026e47dc11435902c'
'b04baffa8ee7b5be56aba3d49d9c06be5e34a31808a6f93b899408dbda9aef40'
'4c960079fec78682000a1c2e82dcaae69a6e91858dea641b707cf60674f3799f'
diff --git a/vmblock.patch b/vmblock.patch
index b21329c6b5d0..5ed13d90e9e7 100644
--- a/vmblock.patch
+++ b/vmblock.patch
@@ -31,6 +31,15 @@ diff --git a/vmblock/linux/control.c b/vmblock/linux/control.c
index 79716bd..5b6acb2 100644
--- a/vmblock/linux/control.c
+++ b/vmblock/linux/control.c
+@@ -29,7 +29,7 @@
+ #include <linux/stat.h>
+ #include <linux/fs.h>
+
+-#include <asm/uaccess.h>
++#include <linux/uaccess.h>
+
+ #include "vmblockInt.h"
+ #include "block.h"
@@ -208,9 +208,17 @@ SetupProcDevice(void)
VMBlockSetProcEntryOwner(controlProcMountpoint);