summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--vmmon.patch96
3 files changed, 100 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c25720e7316..01c3a03dd955 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation14
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 14.1.7
- pkgrel = 10
+ pkgrel = 11
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -82,8 +82,7 @@ pkgbase = vmware-workstation14
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 75346130fe8e42bf087b0cdaee98a1bde1f418e7db757e05fb7ecc877aa5ec79
+ sha256sums = 078dc018bab0cb115e610a19ddd85778664cda6a0878bac8f65a4615d35db279
sha256sums = 2cb7e37a807db07cff3e0eb833c05e306f3d4a8c198ddddf8e3f7492750c10bd
pkgname = vmware-workstation14
-
diff --git a/PKGBUILD b/PKGBUILD
index 9b7753315a06..28ee32b9825b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation14
pkgver=14.1.7
_buildver=12989993
_pkgver=${pkgver}_${_buildver}
-pkgrel=10
+pkgrel=11
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -119,7 +119,7 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '75346130fe8e42bf087b0cdaee98a1bde1f418e7db757e05fb7ecc877aa5ec79'
+ '078dc018bab0cb115e610a19ddd85778664cda6a0878bac8f65a4615d35db279'
'2cb7e37a807db07cff3e0eb833c05e306f3d4a8c198ddddf8e3f7492750c10bd'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index 6c6c3580c31b..39ffa227bcc4 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -411,3 +411,99 @@
printk(KERN_ERR "%s: Couldn't verify write to uva 0x%p with size %"
FMTSZ"u\n", __func__, p, size);
+From 9fda02bce13527ce94a95df1a98fb6188dea22b8 Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Wed, 30 Jun 2021 11:05:16 +0200
+Subject: [PATCH] vmmon: fix task_struct::state access patterns
+
+Mainline commit 2f064a59a11f ("sched: Change task_struct::state") in
+5.14-rc1 finishes a series fixing racy access patterns to task state and
+renames task_struct::state to __state so that code old code acessing it
+directly fails to build.
+
+Two of these in HostIF_SemaphoreWait() can be rewritten into calls to
+set_current_state() unconditionally (second one may do with
+__set_current_state() but I don't feel confident enough about that).
+There are also two places where vmmon code reads task_struct::state;
+provide a compat accessor using READ_ONCE() and use it instead of
+a direct read. To avoid kernel version check, check presence of
+get_current_state() macro introduced in the same commit as state member
+rename.
+---
+ vmmon-only/include/compat_sched.h | 15 +++++++++++++++
+ vmmon-only/linux/hostif.c | 10 ++++++----
+ 2 files changed, 21 insertions(+), 4 deletions(-)
+
+diff --git a/vmmon-only/include/compat_sched.h b/vmmon-only/include/compat_sched.h
+index 3f3304b..72078e0 100644
+--- a/vmmon-only/include/compat_sched.h
++++ b/vmmon-only/include/compat_sched.h
+@@ -289,5 +289,20 @@ typedef struct pid * compat_pid;
+ #define compat_kill_pid(pid, sig, flag) kill_pid(pid, sig, flag)
+ #endif
+
++/*
++ * Since v5.14-rc1, task_struct::state hase been renamed to __state and is
++ * is longer supposed to be accessed without READ_ONCE/WRITE_ONCE.
++ */
++#ifdef get_current_state
++static inline int compat_get_task_state(const struct task_struct *t)
++{
++ return READ_ONCE(t->__state);
++}
++#else
++static inline int compat_get_task_state(const struct task_struct *t)
++{
++ return READ_ONCE(t->state);
++}
++#endif
+
+ #endif /* __COMPAT_SCHED_H__ */
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 137062c..6910f69 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -78,6 +78,8 @@
+ #include "pgtbl.h"
+ #include "versioned_atomic.h"
+
++#include "compat_sched.h"
++
+ #if !defined(CONFIG_HIGH_RES_TIMERS)
+ #error CONFIG_HIGH_RES_TIMERS required for acceptable performance
+ #endif
+@@ -445,7 +447,7 @@ HostIF_WakeUpYielders(VMDriver *vm, // IN:
+ while ((vcpuid = VCPUSet_FindFirst(&req)) != VCPUID_INVALID) {
+ struct task_struct *t = vm->vmhost->vcpuSemaTask[vcpuid];
+ VCPUSet_Remove(&req, vcpuid);
+- if (t && (t->state & TASK_INTERRUPTIBLE)) {
++ if (t && (compat_get_task_state(t) & TASK_INTERRUPTIBLE)) {
+ wake_up_process(t);
+ }
+ }
+@@ -2454,14 +2456,14 @@ HostIF_SemaphoreWait(VMDriver *vm, // IN:
+ unsigned int mask;
+
+ poll_initwait(&table);
+- current->state = TASK_INTERRUPTIBLE;
++ set_current_state(TASK_INTERRUPTIBLE);
+ mask = file->f_op->poll(file, &table.pt);
+ if (!(mask & (POLLIN | POLLERR | POLLHUP))) {
+ vm->vmhost->vcpuSemaTask[vcpuid] = current;
+ schedule_timeout(timeoutms * HZ / 1000); // convert to Hz
+ vm->vmhost->vcpuSemaTask[vcpuid] = NULL;
+ }
+- current->state = TASK_RUNNING;
++ set_current_state(TASK_RUNNING);
+ poll_freewait(&table);
+ }
+
+@@ -2535,7 +2537,7 @@ HostIF_SemaphoreForceWakeup(VMDriver *vm, // IN:
+ FOR_EACH_VCPU_IN_SET(vcs, vcpuid) {
+ struct task_struct *t = vm->vmhost->vcpuSemaTask[vcpuid];
+ vm->vmhost->vcpuSemaTask[vcpuid] = NULL;
+- if (t && (t->state & TASK_INTERRUPTIBLE)) {
++ if (t && (compat_get_task_state(t) & TASK_INTERRUPTIBLE)) {
+ wake_up_process(t);
+ }
+ } ROF_EACH_VCPU_IN_SET();