summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--vmmon.patch58
3 files changed, 60 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 929a292c6b81..ccc267613dce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -82,7 +82,7 @@ pkgbase = vmware-workstation14
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487
sha256sums = 6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d
- sha256sums = 0b9589875a1a29f75e1ff01aa01d3854ce5fec6fa2af75e9ad3e812c010272e6
+ sha256sums = b485e2cdbde0707f1d61ef4cc7ce16b38f18deb751358274ca5b0af81d12d75b
sha256sums = e712332335fde4e4846f18c3fa8c933f173336a44546f87ea02b1e1a53f15911
pkgname = vmware-workstation14
diff --git a/PKGBUILD b/PKGBUILD
index 63a7971cbde3..0945ab46a0cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -119,7 +119,7 @@ sha256sums=(
'05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487'
'6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d'
- '0b9589875a1a29f75e1ff01aa01d3854ce5fec6fa2af75e9ad3e812c010272e6'
+ 'b485e2cdbde0707f1d61ef4cc7ce16b38f18deb751358274ca5b0af81d12d75b'
'e712332335fde4e4846f18c3fa8c933f173336a44546f87ea02b1e1a53f15911'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index 1acbc54c0ac4..abf692ba1c01 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -319,3 +319,61 @@ index ec6856a..4a7afb1 100644
if (res == sizeof value) {
res = MX_WAITNORMAL;
+From 1c4c297ddd28f430037efc972b77639f8bdc3ff1 Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Sat, 8 Aug 2020 22:53:50 +0200
+Subject: [PATCH] vmmon: handle change of vmstat slab counters to bytes
+
+Mainline commit d42f3245c7e2 ("mm: memcg: convert vmstat slab counters to
+bytes") in kernel 5.9-rc1 changed vmstat accounting of slab to byte
+counters. Unfortunately there doesn't seem to be any obvious way to check
+for this change except version check.
+---
+ vmmon-only/linux/hostif.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 9b179a8..107e11f 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -1548,8 +1548,11 @@ HostIF_EstimateLockedPageLimit(const VMDriver* vm, // IN
+ #else
+ lockedPages += global_page_state(NR_PAGETABLE);
+ #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 9, 0)
++ /* NR_SLAB_* converted to byte counters in 5.9 */
++ lockedPages += global_node_page_state_pages(NR_SLAB_UNRECLAIMABLE_B);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 13, 0)
+ /* NR_SLAB_* moved from zone to node in 4.13. */
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 13, 0)
+ lockedPages += global_node_page_state(NR_SLAB_UNRECLAIMABLE);
+ #else
+ lockedPages += global_page_state(NR_SLAB_UNRECLAIMABLE);
+From 505c6b8967d2b14223e8ba482acffe020a93782f Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Thu, 20 Aug 2020 10:39:56 +0200
+Subject: [PATCH] vmmon: include <asm/irq_vectors.h> explicitly
+
+After mainline commit 13c01139b171 ("x86/headers: Remove APIC headers from
+<asm/smp.h>") in 5.9-rc1, APIC headers are no longer included via
+<asm/smp.h> so that linux/hostif.c will use incorrect fallback definitions
+of SPURIOUS_APIC_VECTOR, POSTED_INTR_VECTOR and ERROR_APIC_VECTOR even if
+built against kernel where these are defined.
+
+Include <asm/irq_vectors.h> in linux/hostif.c explicitly to avoid that.
+---
+ vmmon-only/linux/hostif.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 107e11f..a42a034 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -49,6 +49,7 @@
+ #include <asm/page.h>
+ #include <asm/tlbflush.h>
+ #include <asm/uaccess.h>
++#include <asm/irq_vectors.h>
+ #include <linux/capability.h>
+ #include <linux/kthread.h>
+ #include <linux/wait.h>