summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
2 files changed, 46 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4546ce0dd94..f9376724f85f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = vnote
pkgdesc = A Vim-inspired note-taking application, especially for Markdown.
- pkgver = 1.16
+ pkgver = 2.0
pkgrel = 1
url = https://tamlok.github.io/vnote/
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
+ makedepends = git
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
- source = https://github.com/tamlok/vnote/archive/v1.16.tar.gz
- source = hoedown.zip::https://github.com/tamlok/hoedown/archive/e63d2160a7d9895defc253d933b58a83ac54f81a.zip
- source = marked.zip::https://github.com/markedjs/marked/archive/38f1727ffee0820975677027b8968bc1954e6637.zip
- sha256sums = 664972656e28dbd3e0ca1f443d4f27917df1f8954b0b012c34850e836c6ea2eb
- sha256sums = 85d8c673ee4a3e8f595db3021b238642aede1727965afa13666a29a43a0eb846
- sha256sums = 602c2e7fa2ab48d3aefe33cafa08bfdebbc619f4a652fde1ebad40f19c34a886
+ source = git+https://github.com/tamlok/vnote#tag=v2.0
+ source = git+https://github.com/chjj/marked.git
+ source = git+https://github.com/tamlok/hoedown.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = vnote
diff --git a/PKGBUILD b/PKGBUILD
index d851faabda06..f5fa700b7135 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,41 @@
-# Maintainer: erk <v at erk dot io>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: erk <v at erk dot io>
+
pkgname=vnote
-pkgver=1.16
+pkgver=2.0
pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
-arch=('any')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='https://tamlok.github.io/vnote/'
-license=('MIT')
-depends=('qt5-base' 'qt5-webengine' 'qt5-svg')
+license=(MIT)
+depends=(qt5-base qt5-webengine qt5-svg)
+makedepends=(git)
+source=("git+https://github.com/tamlok/vnote#tag=v${pkgver}"
+ "git+https://github.com/chjj/marked.git"
+ "git+https://github.com/tamlok/hoedown.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
-_marked=38f1727ffee0820975677027b8968bc1954e6637
-_hoedown=e63d2160a7d9895defc253d933b58a83ac54f81a
+ git submodule init
+ git config 'submodule.src/utils/marked.url' "${srcdir}/marked"
+ git config 'submodule.hoedown.url' "${srcdir}/hoedown"
+ git submodule update
-source=("https://github.com/tamlok/vnote/archive/v$pkgver.tar.gz" hoedown.zip::"https://github.com/tamlok/hoedown/archive/$_hoedown.zip" marked.zip::"https://github.com/markedjs/marked/archive/$_marked.zip")
-sha256sums=(664972656e28dbd3e0ca1f443d4f27917df1f8954b0b012c34850e836c6ea2eb 85d8c673ee4a3e8f595db3021b238642aede1727965afa13666a29a43a0eb846 602c2e7fa2ab48d3aefe33cafa08bfdebbc619f4a652fde1ebad40f19c34a886)
+ install -d build
+}
+
+build() {
+ cd "$srcdir/$pkgname/build"
+ qmake-qt5 ../VNote.pro
+ make
+}
package() {
- mv $srcdir/hoedown-$_hoedown/* "$srcdir/$pkgname-$pkgver/hoedown/"
- mv $srcdir/marked-$_marked/* "$srcdir/$pkgname-$pkgver/src/utils/marked/"
- cd "$srcdir/$pkgname-$pkgver"
- mkdir build
- cd build
- qmake-qt5 ../VNote.pro
- make
- make INSTALL_ROOT="$pkgdir" install
+ cd "$srcdir/$pkgname/build"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}