summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4291f9d0ed61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = voirc-git
+ pkgdesc = Prototype implementation of basic voice chat over IRC text messages
+ pkgver = r5.be94145
+ pkgrel = 1
+ url = https://github.com/asiekierka/voirc
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = nim
+ depends = libsoundio
+ depends = codec2
+ source = voirc::git+https://github.com/asiekierka/voirc
+ source = https://raw.githubusercontent.com/nim-lang/irc/master/src/irc.nim
+ source = https://raw.githubusercontent.com/ul/soundio/master/src/soundio.nim
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = voirc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12666e3e00cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Leon Möller <jkhsjdhjs at totally dot rip>
+
+pkgname=voirc-git
+pkgver=r5.be94145
+pkgrel=1
+pkgdesc="Prototype implementation of basic voice chat over IRC text messages"
+arch=('any')
+url="https://github.com/asiekierka/voirc"
+license=('MIT')
+makedepends=('git' 'nim')
+depends=('libsoundio' 'codec2')
+source=(
+ "${pkgname%-git}::git+https://github.com/asiekierka/voirc"
+ "https://raw.githubusercontent.com/nim-lang/irc/master/src/irc.nim"
+ "https://raw.githubusercontent.com/ul/soundio/master/src/soundio.nim"
+)
+sha512sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir"
+ cp {irc,soundio}.nim "${pkgname%-git}/lib/"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 voirc "$pkgdir/usr/bin/voirc"
+}
+