summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD38
-rw-r--r--vokoscreen.install12
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf9b530f9a59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = vokoscreen
+ pkgdesc = Desktop Recorder, GUI ffmpeg based on Qt4 libriaries.
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = http://www.kohaupt-online.de/
+ install = vokoscreen.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = gcc
+ depends = qt4
+ depends = ffmpeg
+ depends = lame
+ depends = mkvtoolnix-cli
+ depends = opencv
+ optdepends = pulseaudio
+ optdepends = alsa-utils
+ source = https://github.com/vkohaupt/vokoscreen/archive/2.2.0.tar.gz
+ source = vokoscreen.install
+ md5sums = db3015b369c3f6531a887fc2b1492215
+ md5sums = 027efd4ee6f24da7af118f6f99ef5909
+
+pkgname = vokoscreen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c2b01436a8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributer: giacomogiorgianni@gmail.com
+
+pkgname=vokoscreen
+numver=201303021707
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="Desktop Recorder, GUI ffmpeg based on Qt4 libriaries."
+arch=('i686' 'x86_64')
+url="http://www.kohaupt-online.de/"
+depends=('qt4' 'ffmpeg' 'lame' 'mkvtoolnix-cli' 'opencv')
+makedepends=('cmake' 'automoc4' 'gcc')
+source=("https://github.com/vkohaupt/vokoscreen/archive/${pkgver}.tar.gz" $pkgname.install)
+#source=("http://ppa.launchpad.net/$pkgname-dev/$pkgname/ubuntu/pool/main/v/$pkgname/${pkgname}_${pkgver}-${pkgrel}#~precise1.tar.gz" $pkgname.install)
+optdepends=('pulseaudio' 'alsa-utils')
+#options=('!strip')
+license=('GPL2')
+install=${pkgname}.install
+md5sums=('db3015b369c3f6531a887fc2b1492215' '027efd4ee6f24da7af118f6f99ef5909')
+
+build() {
+# cd "${srcdir}/recipe-{debversion}"
+ cd $pkgname-$pkgver
+ qmake-qt4 $pkgname.pro -r -config release \
+ "CONFIG+=LINUX_INTEGRATED" \
+ "INSTALL_ROOT_PATH=$pkgdir/usr/" \
+ "LOWERED_APPNAME=$pkgname"
+ make
+}
+
+package() {
+ #cd "${srcdir}/recipe-{debversion}"
+ cd $pkgname-$pkgver
+ make INSTALL_ROOT=${pkgdir} install
+ #make DESTDIR="$pkgdir" install
+ chmod -R 755 ${pkgdir}/usr/share/man
+ chmod -R 755 ${pkgdir}/usr/share/man/man1
+ chmod -R 644 ${pkgdir}/usr/share/man/man1/$pkgname.1.gz
+}
diff --git a/vokoscreen.install b/vokoscreen.install
new file mode 100644
index 000000000000..e96af18d0274
--- /dev/null
+++ b/vokoscreen.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file