summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--QtPainterPath.patch12
3 files changed, 5 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f5f57ba4cf5..f4ba2ae383e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vokoscreen-git
pkgdesc = An easy to use screencast creator. Development version.
- pkgver = 3.0.9.r43.ga4e3f291
+ pkgver = 3.0.9.r45.gd1139926
pkgrel = 1
epoch = 1
url = http://linuxecke.volkoh.de/vokoscreen/vokoscreen.html
@@ -18,11 +18,9 @@ pkgbase = vokoscreen-git
depends = pulseaudio
optdepends = gst-plugins-ugly: for x264 video codec
optdepends = gst-plugins-bad: for faac
- provides = vokoscreen=3.0.9.r43.ga4e3f291
+ provides = vokoscreen=3.0.9.r45.gd1139926
conflicts = vokoscreen
source = git+https://github.com/vkohaupt/vokoscreenNG.git
- source = QtPainterPath.patch
sha256sums = SKIP
- sha256sums = e2088c1e461e86d96c77f3014ffa88ed1b2f90595d909248bb176da3efafb61f
pkgname = vokoscreen-git
diff --git a/PKGBUILD b/PKGBUILD
index bbf6db66716c..4ba9a25eb8d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=vokoscreenNG
pkgname=vokoscreen-git
-pkgver=3.0.9.r43.ga4e3f291
+pkgver=3.0.9.r45.gd1139926
pkgrel=1
epoch=1
pkgdesc='An easy to use screencast creator. Development version.'
@@ -19,20 +19,14 @@ optdepends=('gst-plugins-ugly: for x264 video codec'
'gst-plugins-bad: for faac')
provides=("${_pkgname%NG}=${pkgver}")
conflicts=("${_pkgname%NG}")
-source=("git+https://github.com/vkohaupt/${_pkgname}.git" QtPainterPath.patch)
-sha256sums=('SKIP'
- 'e2088c1e461e86d96c77f3014ffa88ed1b2f90595d909248bb176da3efafb61f')
+source=("git+https://github.com/vkohaupt/${_pkgname}.git")
+sha256sums=('SKIP')
pkgver() {
cd ${_pkgname}
git describe --long --tags 2>/dev/null | sed -r 's/-/.r/' | tr - .
}
-prepare() {
- cd ${_pkgname}
- git apply "$srcdir"/QtPainterPath.patch
-}
-
build() {
[[ -d "${srcdir}"/build ]] || mkdir -p "${srcdir}"/build
cd build
diff --git a/QtPainterPath.patch b/QtPainterPath.patch
deleted file mode 100644
index 2eb53d470cda..000000000000
--- a/QtPainterPath.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/spezialCheckBox/QvkSpezialCheckbox.h b/src/spezialCheckBox/QvkSpezialCheckbox.h
-index 51322246..389f4dd5 100644
---- a/src/spezialCheckBox/QvkSpezialCheckbox.h
-+++ b/src/spezialCheckBox/QvkSpezialCheckbox.h
-@@ -4,6 +4,7 @@
-
- #include <QWidget>
- #include <QPainter>
-+#include <QPainterPath>
-
- class QvkSpezialCheckbox : public QWidget
- {