summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--BUILDING2
-rw-r--r--PKGBUILD7
-rw-r--r--vscodium-insiders-uri-handler.desktop12
4 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c028bc7ada8..9683677dd469 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vscodium-insiders
pkgdesc = Binary releases of Code Insiders without branding/telemetry/licensing (git build from latest release)
pkgver = 1.72.0.22271
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/VSCodium/vscodium.git
arch = x86_64
arch = aarch64
@@ -33,8 +33,10 @@ pkgbase = vscodium-insiders
conflicts = vscodium-insiders-bin
conflicts = vscodium-insiders-git
source = vscodium-insiders.desktop
+ source = vscodium-insiders-uri-handler.desktop
source = https://github.com/VSCodium/vscodium-insiders/releases/download/1.72.0.22271-insider/VSCodium-1.72.0.22271-insider-src.tar.gz
sha256sums = 9d17eb0074bcd7b75ffd8c56718254c96108c01f857570f951d1e9a109269405
+ sha256sums = ca34047d62b5b433c2039151b9d55674a8aacdd1af57041d54387b76e44cd442
sha256sums = 564e40899642ebf527b38404242002cb826b205c70031da8fd588426e3173119
pkgname = vscodium-insiders
diff --git a/BUILDING b/BUILDING
index 10ae8de3c32d..952ddaee45cc 100644
--- a/BUILDING
+++ b/BUILDING
@@ -6,7 +6,7 @@ $ makepkg -sr
Wait for the build to complete, then install the package:
-$ pacman -U vscodium-insiders-${version}-${arch}.pkg.tar.zst
+$ pacman -U vscodium-insiders-*.pkg.tar.zst
If the package installed correctly, and VSCodium runs correctly, update the AUR with the new code:
diff --git a/PKGBUILD b/PKGBUILD
index b4202eb31342..2c76d815c195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=vscodium-insiders
pkgver=1.72.0.22271
-pkgrel=1
+pkgrel=2
pkgdesc="Binary releases of Code Insiders without branding/telemetry/licensing (git build from latest release)"
arch=('x86_64' 'aarch64' 'armv7h')
url='https://github.com/VSCodium/vscodium.git'
@@ -44,10 +44,10 @@ conflicts=(
)
source=(
"${pkgname}.desktop"
+ "${pkgname}-uri-handler.desktop"
"https://github.com/VSCodium/vscodium-insiders/releases/download/${pkgver}-insider/VSCodium-${pkgver}-insider-src.tar.gz"
)
-sha256sums=('9d17eb0074bcd7b75ffd8c56718254c96108c01f857570f951d1e9a109269405'
- '564e40899642ebf527b38404242002cb826b205c70031da8fd588426e3173119')
+sha256sums=('9d17eb0074bcd7b75ffd8c56718254c96108c01f857570f951d1e9a109269405' 'ca34047d62b5b433c2039151b9d55674a8aacdd1af57041d54387b76e44cd442' '564e40899642ebf527b38404242002cb826b205c70031da8fd588426e3173119')
###############################################################################
@@ -122,6 +122,7 @@ package() {
ln -s /usr/share/${pkgname}/bin/codium-insiders ${pkgdir}/usr/bin/codium-insiders
install -D -m644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -D -m644 ${pkgname}-uri-handler.desktop ${pkgdir}/usr/share/applications/${pkgname}-uri-handler.desktop
install -D -m644 ${srcdir}/VSCode-linux-${_vscode_arch}/resources/app/resources/linux/code.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
# Symlink shell completions
diff --git a/vscodium-insiders-uri-handler.desktop b/vscodium-insiders-uri-handler.desktop
new file mode 100644
index 000000000000..0c784ff9285a
--- /dev/null
+++ b/vscodium-insiders-uri-handler.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=VSCodium Insiders - URL Handler
+Comment=Code Editing. Redefined.
+GenericName=Text Editor
+Exec=/opt/vscodium-insiders/bin/codium-insiders --open-url %U
+Icon=vscodium-insiders
+Type=Application
+NoDisplay=true
+StartupNotify=true
+Categories=Utility;TextEditor;Development;IDE;
+MimeType=x-scheme-handler/vscodium-insiders;
+Keywords=vscode;