summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--BUILDING2
-rw-r--r--PKGBUILD8
-rw-r--r--vscodium-insiders-bin-uri-handler.desktop12
4 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73eb9dd3082e..1e7c2e976412 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vscodium-insiders-bin
pkgdesc = Binary releases of Code Insiders without branding/telemetry/licensing (binary release)
pkgver = 1.72.0.22271
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/VSCodium/vscodium.git
arch = x86_64
arch = aarch64
@@ -23,7 +23,9 @@ pkgbase = vscodium-insiders-bin
conflicts = vscodium-insiders
conflicts = vscodium-insiders-git
source = vscodium-insiders-bin.desktop
+ source = vscodium-insiders-bin-uri-handler.desktop
sha256sums = 99dbc0d75aec1dbda70655fe3d9769aa2728116ae885e8be20c4b4f13ae1e80e
+ sha256sums = ccd83957fc14eaeeffc56762e864a8d313f99fa480c105eaecd832fb29d075ab
source_x86_64 = https://github.com/VSCodium/vscodium-insiders/releases/download/1.72.0.22271-insider/VSCodium-linux-x64-1.72.0.22271-insider.tar.gz
sha256sums_x86_64 = 54a3222c4fdd0729a201f04356bc330cca3fa70fe3d6fd6fa134c4f825e8e27a
source_aarch64 = https://github.com/VSCodium/vscodium-insiders/releases/download/1.72.0.22271-insider/VSCodium-linux-arm64-1.72.0.22271-insider.tar.gz
diff --git a/BUILDING b/BUILDING
index 60d5cb1fd925..8f99e23bfe70 100644
--- a/BUILDING
+++ b/BUILDING
@@ -6,7 +6,7 @@ $ makepkg -sr
Wait for the build to complete, then install the package:
-$ pacman -U vscodium-insiders-bin-${version}-${arch}.pkg.tar.zst
+$ pacman -U vscodium-insiders-bin-*.pkg.tar.zst
If the package installed correctly, and VSCodium runs correctly, update the AUR with the new code:
diff --git a/PKGBUILD b/PKGBUILD
index cce7084f8b87..75dc290e5e47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=vscodium-insiders-bin
pkgver=1.72.0.22271
-pkgrel=1
+pkgrel=2
pkgdesc="Binary releases of Code Insiders without branding/telemetry/licensing (binary release)"
arch=('x86_64' 'aarch64' 'armv7h')
url='https://github.com/VSCodium/vscodium.git'
@@ -32,6 +32,7 @@ conflicts=(
)
source=(
"${pkgname}.desktop"
+ "${pkgname}-uri-handler.desktop"
)
source_x86_64=(
"https://github.com/VSCodium/vscodium-insiders/releases/download/${pkgver}-insider/VSCodium-linux-x64-${pkgver}-insider.tar.gz"
@@ -42,7 +43,7 @@ source_armv7h=(
source_aarch64=(
"https://github.com/VSCodium/vscodium-insiders/releases/download/${pkgver}-insider/VSCodium-linux-arm64-${pkgver}-insider.tar.gz"
)
-sha256sums=('99dbc0d75aec1dbda70655fe3d9769aa2728116ae885e8be20c4b4f13ae1e80e')
+sha256sums=('99dbc0d75aec1dbda70655fe3d9769aa2728116ae885e8be20c4b4f13ae1e80e' 'ccd83957fc14eaeeffc56762e864a8d313f99fa480c105eaecd832fb29d075ab')
sha256sums_x86_64=('54a3222c4fdd0729a201f04356bc330cca3fa70fe3d6fd6fa134c4f825e8e27a')
sha256sums_aarch64=('48427357de6cdb6831e655a9ef0db496ec638c03ce34aed95675cf6f36a6b5be')
sha256sums_armv7h=('a1ed1ad45d526e996f7ea96e9b2475f8c9f9de41a94e9630b5ca4650d76e3af0')
@@ -54,12 +55,13 @@ package() {
install -d -m755 ${pkgdir}/usr/share/{${pkgname},applications,pixmaps}
install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname}
- cp -r ${srcdir}/!(${pkgname}.desktop|VSCodium-*-${pkgver}-insider.tar.gz) ${pkgdir}/usr/share/${pkgname}
+ cp -r ${srcdir}/!(${pkgname}*.desktop|VSCodium-*-${pkgver}-insider.tar.gz) ${pkgdir}/usr/share/${pkgname}
cp -r ${srcdir}/resources/app/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}
ln -s /usr/share/${pkgname}/bin/codium-insiders ${pkgdir}/usr/bin/codium-insiders
install -D -m644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -D -m644 ${pkgname}-uri-handler.desktop ${pkgdir}/usr/share/applications/${pkgname}-uri-handler.desktop
install -D -m644 ${srcdir}/resources/app/resources/linux/code.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
# Symlink shell completions
diff --git a/vscodium-insiders-bin-uri-handler.desktop b/vscodium-insiders-bin-uri-handler.desktop
new file mode 100644
index 000000000000..9c03f5f413d2
--- /dev/null
+++ b/vscodium-insiders-bin-uri-handler.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=VSCodium Insiders - URL Handler
+Comment=Code Editing. Redefined.
+GenericName=Text Editor
+Exec=/opt/vscodium-insiders-bin/bin/codium-insiders --open-url %U
+Icon=vscodium-insiders-bin
+Type=Application
+NoDisplay=true
+StartupNotify=true
+Categories=Utility;TextEditor;Development;IDE;
+MimeType=x-scheme-handler/vscodium-insiders;
+Keywords=vscode;