summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0a981f12c79..e4a47e02407c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat May 20 07:43:31 UTC 2017
+# Sat Jun 3 03:43:01 UTC 2017
pkgbase = vsxu
pkgdesc = A free to use program that lets you create and perform real-time audio visual presets.
pkgver = 0.6.1
@@ -22,7 +22,21 @@ pkgbase = vsxu
optdepends = alsa-lib: ALSA support.
optdepends = jack: JACK support
optdepends = pulseaudio: PulseAudio support
- source = git+https://github.com/vovoid/vsxu#tag=v0.6.1
+ source = git+https://github.com/vovoid/vsxu#commit=b93ca2c4164bb4b60e865aebca88fa62c760ca0a
+ source = dependencies::git+https://github.com/vovoid/vsxu-dependencies.git
+ source = cal3d::git+https://github.com/vovoid/cal3d.git
+ source = freetype2::git+https://github.com/vovoid/freetype2.git
+ source = ftgl::git+https://github.com/vovoid/ftgl.git
+ source = lodepng::git+https://github.com/vovoid/lodepng.git
+ source = lzham-sdk::git+https://github.com/vovoid/lzham_codec.git
+ source = lzma-sdk::git+https://github.com/vovoid/LZMA-SDK.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = vsxu
diff --git a/PKGBUILD b/PKGBUILD
index 25e102ff306c..1f410db1387d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,13 +15,41 @@ optdepends=(
'jack: JACK support'
'pulseaudio: PulseAudio support'
)
-source=("git+https://github.com/vovoid/vsxu#tag=v${pkgver}")
-sha512sums=('SKIP')
+_commit=b93ca2c4164bb4b60e865aebca88fa62c760ca0a # tags/v0.6.1
+source=("git+https://github.com/vovoid/vsxu#commit=$_commit"
+ "dependencies::git+https://github.com/vovoid/vsxu-dependencies.git"
+ "cal3d::git+https://github.com/vovoid/cal3d.git"
+ "freetype2::git+https://github.com/vovoid/freetype2.git"
+ "ftgl::git+https://github.com/vovoid/ftgl.git"
+ "lodepng::git+https://github.com/vovoid/lodepng.git"
+ "lzham-sdk::git+https://github.com/vovoid/lzham_codec.git"
+ "lzma-sdk::git+https://github.com/vovoid/LZMA-SDK.git")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd "${pkgname}"
[[ -d build ]] || mkdir build
- git submodule update --init
+ git submodule init
+ git config submodule.dependencies.url "${srcdir}/dependencies"
+ git config submodule.lib/compression/thirdparty/lzma-sdk.url "${srcdir}/lzma-sdk"
+ git config submodule.lib/compression/thirdparty/lzham-sdk.url "${srcdir}/lzham-sdk"
+ git config submodule.lib/engine_graphics/thirdparty/freetype2.url "${srcdir}/freetype2"
+ git config submodule.lib/engine_graphics/thirdparty/ftgl.url "${srcdir}/ftgl"
+ git config submodule.lib/engine_graphics/thirdparty/lodepng.url "${srcdir}/lodepng"
+ git config submodule.plugins/src/mesh.importers/cal3d.url "${srcdir}/cal3d"
+ git submodule update dependencies lib/compression/thirdparty/lzham-sdk lib/compression/thirdparty/lzma-sdk lib/engine_graphics/thirdparty/freetype2 lib/engine_graphics/thirdparty/ftgl lib/engine_graphics/thirdparty/lodepng plugins/src/mesh.importers/cal3d
+}
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {