summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--fullwidth-emoji.patch29
3 files changed, 7 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7838d51a7d70..ea96ce58df1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vte3-ng-fullwidth-emoji
pkgdesc = Enhanced Virtual Terminal Emulator widget for use with GTK3 (patched with support for fullwidth emoji)
- pkgver = 0.46.1.a
+ pkgver = 0.48.2.a
pkgrel = 1
url = https://github.com/thestinger/vte-ng
arch = i686
@@ -15,8 +15,8 @@ pkgbase = vte3-ng-fullwidth-emoji
depends = gtk3
depends = vte-common
depends = pcre2
- provides = vte3=0.46.1
- provides = vte3-select-text=0.46.1
+ provides = vte3=0.48.2
+ provides = vte3-select-text=0.48.2
provides = vte3-ng
conflicts = vte3
conflicts = vte3-select-text
@@ -24,7 +24,7 @@ pkgbase = vte3-ng-fullwidth-emoji
replaces = vte3-select-text
replaces = vte3-ng
options = !emptydirs
- source = https://github.com/thestinger/vte-ng/archive/0.46.1.a.tar.gz
+ source = https://github.com/thestinger/vte-ng/archive/0.48.2.a.tar.gz
source = fullwidth-emoji.patch
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b7b65122913c..1a185e89f0fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ray Song <i@maskray.me>
pkgname=vte3-ng-fullwidth-emoji
-_basever=0.46.1
+_basever=0.48.2
pkgver=$_basever.a
pkgrel=1
pkgdesc="Enhanced Virtual Terminal Emulator widget for use with GTK3 (patched with support for fullwidth emoji)"
@@ -12,8 +12,8 @@ depends=('gtk3' 'vte-common' 'pcre2')
makedepends=('intltool' 'gobject-introspection' 'gtk3' 'vala' 'gtk-doc' 'gperf')
url="https://github.com/thestinger/vte-ng"
source=(https://github.com/thestinger/vte-ng/archive/$pkgver.tar.gz fullwidth-emoji.patch)
-sha256sums=('SKIP'
- 'SKIP')
+sha256sums=('54ad336ff87dc7b036bcfe78c9c27b34c4785de4d5af1fbbf67f27752fc30b54'
+ 'a7edd15ca7b1a1c20eb1f30968ab9501c2f3247b7b55ea17b94697a2f6090f98')
provides=(vte3=$_basever vte3-select-text=$_basever vte3-ng)
conflicts=(vte3 vte3-select-text vte3-ng)
replaces=(vte3-select-text vte3-ng)
diff --git a/fullwidth-emoji.patch b/fullwidth-emoji.patch
index a9a1a7aafe53..ae0e3f2840db 100644
--- a/fullwidth-emoji.patch
+++ b/fullwidth-emoji.patch
@@ -1,17 +1,3 @@
---- a/src/vte.cc 2016-03-21 19:49:00.390775386 +0800
-+++ b/src/vte.cc 2016-03-21 19:50:22.627904117 +0800
-@@ -206,6 +206,11 @@
- return 0;
- if (G_UNLIKELY (g_unichar_iswide (c)))
- return 2;
-+ if (G_UNLIKELY(0x25a0 <= c && c < 0x27c0 || // Geometric Shapes, Miscellaneous Symbols, Dingbats
-+ 0x2b00 <= c && c < 0x2c00 || // Miscellaneous Symbols and Arrows
-+ 0x1f300 <= c && c < 0x20000 || // Miscellaneous Symbols and Pictographs ... Supplemental Symbols and Pictographs
-+ 0))
-+ return 2;
- if (G_LIKELY (utf8_ambiguous_width == 1))
- return 1;
- if (G_UNLIKELY (g_unichar_iswide_cjk (c)))
--- a/src/vteseq.cc 2016-04-05 10:56:49.875097322 +0800
+++ b/src/vteseq.cc 2016-04-05 10:56:39.522122540 +0800
@@ -25,6 +25,7 @@
@@ -50,18 +36,3 @@
}
/* Cursor left N columns. */
-diff --git i/src/app.vala w/src/app.vala
-index 8104964..cc871d8 100644
---- i/src/app.vala
-+++ w/src/app.vala
-@@ -214,8 +214,8 @@ class Window : Gtk.ApplicationWindow
- private uint launch_idle_id;
-
- private string[] builtin_dingus = {
-- "(((gopher|news|telnet|nntp|file|http|ftp|https)://)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?",
-- "(((gopher|news|telnet|nntp|file|http|ftp|https)://)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?/[-A-Za-z0-9_\\$\\.\\+\\!\\*\\(\\),;:@&=\\?/~\\#\\%]*[^]'\\.}>\\) ,\\\"]"
-+ "((((filesystem|gopher|news|telnet|nntp|file|http|ftp|https):)+//)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?",
-+ "((((filesystem|gopher|news|telnet|nntp|file|http|ftp|https):)+//)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?/[-A-Za-z0-9_\\$\\.\\+\\!\\*\\(\\),;:@&=\\?/~\\#\\%]*[^]'\\.}>\\) ,\\\"]"
- };
-
- private const GLib.ActionEntry[] action_entries = {