summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD40
-rw-r--r--fullwidth-emoji.patch14
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06fdea5daaeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = vte3-ng-fullwidth-emoji
+ pkgdesc = Enhanced Virtual Terminal Emulator widget for use with GTK3 (patched with support for fullwidth emoji)
+ pkgver = 0.42.4.a
+ pkgrel = 1
+ url = https://github.com/thestinger/vte-ng
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = gobject-introspection
+ makedepends = gtk3
+ makedepends = vala
+ makedepends = gtk-doc
+ makedepends = gperf
+ depends = gtk3
+ depends = vte-common
+ provides = vte3=0.42.4
+ provides = vte3-select-text=0.42.4
+ provides = vte3-ng
+ conflicts = vte3
+ conflicts = vte3-select-text
+ conflicts = vte3-ng
+ replaces = vte3-select-text
+ replaces = vte3-ng
+ options = !emptydirs
+ source = https://github.com/thestinger/vte-ng/archive/0.42.4.a.tar.gz
+ source = fullwidth-emoji.patch
+ sha256sums = 97f1572b1080614b9dcf261a8abe4c7bfd840f7dc91e9bb29ffe310525b28443
+ sha256sums = 0a842a9a7a1a053c8c3ac107a42021fbcaf195a87996939717fc52400ae061d2
+
+pkgname = vte3-ng-fullwidth-emoji
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2289c44236e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 161489 2016-02-13 22:22:08Z jelle $
+# Maintainer: Ray Song <i@maskray.me>
+
+pkgname=vte3-ng-fullwidth-emoji
+_basever=0.42.4
+pkgver=$_basever.a
+pkgrel=1
+pkgdesc="Enhanced Virtual Terminal Emulator widget for use with GTK3 (patched with support for fullwidth emoji)"
+arch=('i686' 'x86_64')
+license=('LGPL')
+options=('!emptydirs')
+depends=('gtk3' 'vte-common')
+makedepends=('intltool' 'gobject-introspection' 'gtk3' 'vala' 'gtk-doc' 'gperf')
+url="https://github.com/thestinger/vte-ng"
+source=(https://github.com/thestinger/vte-ng/archive/$pkgver.tar.gz fullwidth-emoji.patch)
+sha256sums=('97f1572b1080614b9dcf261a8abe4c7bfd840f7dc91e9bb29ffe310525b28443'
+ '0a842a9a7a1a053c8c3ac107a42021fbcaf195a87996939717fc52400ae061d2')
+provides=(vte3=$_basever vte3-select-text=$_basever vte3-ng)
+conflicts=(vte3 vte3-select-text vte3-ng)
+replaces=(vte3-select-text vte3-ng)
+
+prepare() {
+ patch -p1 < ../fullwidth-emoji.patch
+}
+
+build() {
+ cd "vte-ng-$pkgver"
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/vte \
+ --localstatedir=/var --disable-static \
+ --enable-introspection
+ make
+}
+
+package() {
+ cd "vte-ng-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir/etc/profile.d/vte.sh"
+}
diff --git a/fullwidth-emoji.patch b/fullwidth-emoji.patch
new file mode 100644
index 000000000000..ebbbd6ac0fce
--- /dev/null
+++ b/fullwidth-emoji.patch
@@ -0,0 +1,14 @@
+--- a/vte-ng-0.42.4.a/src/vte.cc 2016-03-21 19:49:00.390775386 +0800
++++ b/vte-ng-0.42.4.a/src/vte.cc 2016-03-21 19:50:22.627904117 +0800
+@@ -206,6 +206,11 @@
+ return 0;
+ if (G_UNLIKELY (g_unichar_iswide (c)))
+ return 2;
++ if (G_UNLIKELY(0x25a0 <= c && c < 0x27c0 || // Geometric Shapes, Miscellaneous Symbols, Dingbats
++ 0x2b00 <= c && c < 0x2c00 || // Miscellaneous Symbols and Arrows
++ 0x1f300 <= c && c < 0x1f700 || // Miscellaneous Symbols and Pictographs ... Geometric Shapes Extended
++ 0))
++ return 2;
+ if (G_LIKELY (utf8_ambiguous_width == 1))
+ return 1;
+ if (G_UNLIKELY (g_unichar_iswide_cjk (c)))