summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
-rw-r--r--add_arm_targets.diff97
3 files changed, 71 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7496795d1310..d8190a4320fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Sun Jan 10 21:39:34 UTC 2016
+# Thu May 26 14:05:49 UTC 2016
pkgbase = vtuner.apps
pkgdesc = access DVB devices over the network
pkgver = 2.1_ec05cde3
- pkgrel = 1
+ pkgrel = 2
url = http://code.google.com/p/vtuner/
arch = x86_64
arch = i686
arch = arm
arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPL2
source = vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.tar.gz::https://github.com/lecotex/vtuner.apps/archive/ec05cde34dd77678933c912a6b4abab5d81b9a5b.tar.gz
source = add_arm_targets.diff
@@ -19,7 +20,7 @@ pkgbase = vtuner.apps
source = vtunerd
source = vtunerc-driver_kmod
sha256sums = 7a8d3d6e8fc2c97b9f80c1a2208faecfac92aeb3bed863b9b98f66e0a25b1a4b
- sha256sums = 86b861ddb581fe90bee4e16643289d4fec36f923f587205eda3da85b774fab22
+ sha256sums = f1662537ac1f6de48054bbf79e50a2c0e596e382fa466dca463c10c78cbfddf8
sha256sums = 870e48fb79b9065b5c98056df1aa6638c4dd3c5340331aed8a91af45f2162477
sha256sums = 9e4568a92caf05b5add190e792b788100aea3aac783ff1681c816a7ac87c631b
sha256sums = d886e2aa59c122a4feebdcacbadeef8022b597c369d527328c0aea571f66f7a0
diff --git a/PKGBUILD b/PKGBUILD
index 210dd10dc741..4b3981f06dfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@ pkgbase=vtuner.apps
pkgdesc="access DVB devices over the network"
pkgname=('vtuner-client' 'vtuner-server')
pkgver=2.1_ec05cde3
-pkgrel=1
+pkgrel=2
_gitver=ec05cde34dd77678933c912a6b4abab5d81b9a5b
-arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://code.google.com/p/vtuner/"
license=('GPL2')
source=("${pkgbase}-${_gitver}.tar.gz::https://github.com/lecotex/vtuner.apps/archive/${_gitver}.tar.gz"
@@ -16,7 +16,7 @@ source=("${pkgbase}-${_gitver}.tar.gz::https://github.com/lecotex/vtuner.apps/ar
'vtunerd'
'vtunerc-driver_kmod')
sha256sums=('7a8d3d6e8fc2c97b9f80c1a2208faecfac92aeb3bed863b9b98f66e0a25b1a4b'
- '86b861ddb581fe90bee4e16643289d4fec36f923f587205eda3da85b774fab22'
+ 'f1662537ac1f6de48054bbf79e50a2c0e596e382fa466dca463c10c78cbfddf8'
'870e48fb79b9065b5c98056df1aa6638c4dd3c5340331aed8a91af45f2162477'
'9e4568a92caf05b5add190e792b788100aea3aac783ff1681c816a7ac87c631b'
'd886e2aa59c122a4feebdcacbadeef8022b597c369d527328c0aea571f66f7a0'
@@ -24,12 +24,13 @@ sha256sums=('7a8d3d6e8fc2c97b9f80c1a2208faecfac92aeb3bed863b9b98f66e0a25b1a4b'
'75afc288f0cb1be62e7d719fe0d5c1fadd703f80d8b0850e9799b0f14be4a045')
prepare() {
- cd "${srcdir}/${pkgbase}-${_gitver}"
- patch -p1 -i "${srcdir}/add_arm_targets.diff"
+ cd ${srcdir}/${pkgbase}-${_gitver}
+ patch -p1 -i ${srcdir}/add_arm_targets.diff
+ cp Make.config.sample Make.config
}
build() {
- cd "${srcdir}/${pkgbase}-${_gitver}"
+ cd ${srcdir}/${pkgbase}-${_gitver}
make ${CARCH} LOCVER=${pkgver}
}
@@ -37,16 +38,16 @@ package_vtuner-client() {
pkgdesc="VTuner client for virtual DVB's"
depends=('vtuner-module')
backup=('etc/conf.d/vtunerc0')
- install -Dm744 "${srcdir}/${pkgbase}-${_gitver}/dist/${CARCH}/vtunerc.${CARCH}" "${pkgdir}/usr/bin/vtunerc"
- install -Dm644 "${srcdir}/vtunerc@.service" "${pkgdir}/usr/lib/systemd/system/vtunerc@.service"
- install -Dm744 "${srcdir}/vtunerc-driver_kmod" "${pkgdir}/usr/lib/systemd/scripts/vtunerc-driver_kmod"
- install -Dm644 "${srcdir}/vtunerc0" "${pkgdir}/etc/conf.d/vtunerc0"
+ install -Dm744 ${srcdir}/${pkgbase}-${_gitver}/dist/${CARCH}/vtunerc.${CARCH} ${pkgdir}/usr/bin/vtunerc
+ install -Dm644 ${srcdir}/vtunerc@.service ${pkgdir}/usr/lib/systemd/system/vtunerc@.service
+ install -Dm744 ${srcdir}/vtunerc-driver_kmod ${pkgdir}/usr/lib/systemd/scripts/vtunerc-driver_kmod
+ install -Dm644 ${srcdir}/vtunerc0 ${pkgdir}/etc/conf.d/vtunerc0
}
package_vtuner-server() {
pkgdesc="VTuner server for broadcasting local DVB devices in network"
backup=('etc/conf.d/vtunerd')
- install -Dm744 "${srcdir}/${pkgbase}-${_gitver}/dist/${CARCH}/vtunerd.${CARCH}" "${pkgdir}/usr/bin/vtunerd"
- install -Dm644 "${srcdir}/vtunerd.service" "${pkgdir}/usr/lib/systemd/system/vtunerd.service"
- install -Dm644 "${srcdir}/vtunerd" "${pkgdir}/etc/conf.d/vtunerd"
+ install -Dm744 ${srcdir}/${pkgbase}-${_gitver}/dist/${CARCH}/vtunerd.${CARCH} ${pkgdir}/usr/bin/vtunerd
+ install -Dm644 ${srcdir}/vtunerd.service ${pkgdir}/usr/lib/systemd/system/vtunerd.service
+ install -Dm644 ${srcdir}/vtunerd ${pkgdir}/etc/conf.d/vtunerd
}
diff --git a/add_arm_targets.diff b/add_arm_targets.diff
index 2f4a4386dc57..5b56c3eae0a9 100644
--- a/add_arm_targets.diff
+++ b/add_arm_targets.diff
@@ -1,6 +1,29 @@
-diff '--exclude=.hg' -uprN vtuner.apps/build/arm/Makefile vtuner.apps.arm/build/arm/Makefile
---- vtuner.apps/build/arm/Makefile 2014-11-03 13:01:25.904147000 +0100
-+++ vtuner.apps.arm/build/arm/Makefile 2014-11-03 12:58:28.079147000 +0100
+diff -uprN vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/aarch64/Makefile vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/aarch64/Makefile
+--- vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/aarch64/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/aarch64/Makefile 2016-05-26 15:45:27.317930930 +0200
+@@ -0,0 +1,19 @@
++ARCH=aarch64
++-include ../../Make.config
++
++CC=$(CC-$(ARCH))
++CXX=$(CXX-$(ARCH))
++CFLAGS=-fpic -DHAVE_DVB_API_VERSION=5
++LDFLAGS=-lpthread -lrt
++DRIVER=vtuner-dvb-3
++STRIP=$(STRIP-$(ARCH))
++
++all: ../../dist/$(ARCH)/vtunerd.$(ARCH) ../../dist/$(ARCH)/vtunerc.$(ARCH)
++ $(STRIP) ../../dist/$(ARCH)/vtunerd.$(ARCH)
++ $(STRIP) ../../dist/$(ARCH)/vtunerc.$(ARCH)
++
++-include ../../Make.rules
++
++vtuner-dvb-3.o: ../../vtuner-dvb-3.c ../../vtuner-dvb-3.h
++ $(CC) $(CFLAGS) -c -o vtuner-dvb-3.o ../../vtuner-dvb-3.c
++
+diff -uprN vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/arm/Makefile vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/arm/Makefile
+--- vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/arm/Makefile 2012-02-14 21:22:36.000000000 +0100
++++ vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/arm/Makefile 2016-05-23 13:26:26.481863242 +0200
@@ -8,8 +8,9 @@ LDFLAGS=-lpthread -lrt
DRIVER=vtuner-dvb-3
STRIP=$(STRIP-$(ARCH))
@@ -12,9 +35,9 @@ diff '--exclude=.hg' -uprN vtuner.apps/build/arm/Makefile vtuner.apps.arm/build/
-include ../../Make.rules
-diff '--exclude=.hg' -uprN vtuner.apps/build/armv6h/Makefile vtuner.apps.arm/build/armv6h/Makefile
---- vtuner.apps/build/armv6h/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ vtuner.apps.arm/build/armv6h/Makefile 2014-11-03 21:27:25.164147000 +0100
+diff -uprN vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/armv6h/Makefile vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/armv6h/Makefile
+--- vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/armv6h/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/armv6h/Makefile 2016-05-23 13:26:26.481863242 +0200
@@ -0,0 +1,19 @@
+ARCH=armv6h
+-include ../../Make.config
@@ -35,9 +58,9 @@ diff '--exclude=.hg' -uprN vtuner.apps/build/armv6h/Makefile vtuner.apps.arm/bui
+vtuner-dvb-3.o: ../../vtuner-dvb-3.c ../../vtuner-dvb-3.h
+ $(CC) $(CFLAGS) -c -o vtuner-dvb-3.o ../../vtuner-dvb-3.c
+
-diff '--exclude=.hg' -uprN vtuner.apps/build/armv7h/Makefile vtuner.apps.arm/build/armv7h/Makefile
---- vtuner.apps/build/armv7h/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ vtuner.apps.arm/build/armv7h/Makefile 2014-11-03 21:27:41.744147000 +0100
+diff -uprN vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/armv7h/Makefile vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/armv7h/Makefile
+--- vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/build/armv7h/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/build/armv7h/Makefile 2016-05-23 13:26:26.481863242 +0200
@@ -0,0 +1,19 @@
+ARCH=armv7h
+-include ../../Make.config
@@ -58,37 +81,15 @@ diff '--exclude=.hg' -uprN vtuner.apps/build/armv7h/Makefile vtuner.apps.arm/bui
+vtuner-dvb-3.o: ../../vtuner-dvb-3.c ../../vtuner-dvb-3.h
+ $(CC) $(CFLAGS) -c -o vtuner-dvb-3.o ../../vtuner-dvb-3.c
+
-diff '--exclude=.hg' -uprN vtuner.apps/Make.config vtuner.apps.arm/Make.config
---- vtuner.apps/Make.config 1970-01-01 01:00:00.000000000 +0100
-+++ vtuner.apps.arm/Make.config 2014-11-09 23:49:00.096577193 +0100
-@@ -0,0 +1,20 @@
-+# define the CC for target i686
-+CC-i686=gcc
-+INCLUDE-i686=
-+
-+# define the CC for target x86_64
-+CC-x86_64=gcc
-+INCLUDE-x86_64=
-+
-+# define the CC for target arm
-+CC-arm=gcc
-+STRIP-arm=strip
-+INCLUDE-arm=
-+
-+CC-armv6h=gcc
-+STRIP-armv6h=strip
-+INCLUDE-armv6h=
-+
-+CC-armv7h=gcc
-+STRIP-armv7h=strip
-+INCLUDE-armv7h=
-diff '--exclude=.hg' -uprN vtuner.apps/Make.config.sample vtuner.apps.arm/Make.config.sample
---- vtuner.apps/Make.config.sample 2014-11-03 13:01:25.899147000 +0100
-+++ vtuner.apps.arm/Make.config.sample 2014-11-09 23:48:07.225347164 +0100
-@@ -28,3 +28,11 @@ CC-sh4=/opt/STM/STLinux-2.3/devkit/sh4/b
+diff -uprN vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/Make.config.sample vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/Make.config.sample
+--- vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/Make.config.sample 2012-02-14 21:22:36.000000000 +0100
++++ vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/Make.config.sample 2016-05-26 15:44:06.091262975 +0200
+@@ -27,4 +27,16 @@ CC-sh4=/opt/STM/STLinux-2.3/devkit/sh4/b
+ # define the CC for target arm
CC-arm=arm-none-linux-gnueabi-gcc
STRIP-arm=arm-none-linux-gnueabi-strip
- INCLUDE-arm=-I/home/hop/nessie/2.6.22/include
+-INCLUDE-arm=-I/home/hop/nessie/2.6.22/include
++INCLUDE-arm=
+
+CC-armv6h=arm-none-linux-gnueabi-gcc
+STRIP-armv6h=arm-none-linux-gnueabi-strip
@@ -97,18 +98,22 @@ diff '--exclude=.hg' -uprN vtuner.apps/Make.config.sample vtuner.apps.arm/Make.c
+CC-armv7h=arm-none-linux-gnueabi-gcc
+STRIP-armv7h=arm-none-linux-gnueabi-strip
+INCLUDE-armv7h=
-diff '--exclude=.hg' -uprN vtuner.apps/Makefile vtuner.apps.arm/Makefile
---- vtuner.apps/Makefile 2014-11-03 13:01:25.904147000 +0100
-+++ vtuner.apps.arm/Makefile 2014-11-03 21:29:43.024147000 +0100
++
++CC-aarch64=arm-none-linux-gnueabi-gcc
++STRIP-aarch64=arm-none-linux-gnueabi-strip
++INCLUDE-aarch64=
+diff -uprN vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/Makefile vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/Makefile
+--- vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b.orig/Makefile 2012-02-14 21:22:36.000000000 +0100
++++ vtuner.apps-ec05cde34dd77678933c912a6b4abab5d81b9a5b/Makefile 2016-05-26 15:49:26.237934717 +0200
@@ -1,6 +1,6 @@
-include ../../Make.config
-all: i686 x86_64 mipsel ppc db2 sh4 mipsel15 ipkg
-+all: i686 x86_64 mipsel ppc db2 sh4 mipsel15 ipkg arm armv6h armv7h
++all: i686 x86_64 mipsel ppc db2 sh4 mipsel15 ipkg arm armv6h armv7h aarch64
i686:
$(MAKE) -C build/i686 all
-@@ -27,7 +27,13 @@ ipkg: mipsel
+@@ -27,7 +27,16 @@ ipkg: mipsel
$(MAKE) -C pkgs ipkg
arm:
@@ -120,12 +125,16 @@ diff '--exclude=.hg' -uprN vtuner.apps/Makefile vtuner.apps.arm/Makefile
+
+armv7h:
+ $(MAKE) -C build/armv7h all
++
++aarch64:
++ $(MAKE) -C build/aarch64 all
clean:
-@@ -40,3 +46,5 @@ clean:
+@@ -40,3 +49,6 @@ clean:
$(MAKE) -C build/mipsel15 clean
$(MAKE) -C pkgs clean
$(MAKE) -C build/arm clean
+ $(MAKE) -C build/armv6h clean
+ $(MAKE) -C build/armv7h clean
++ $(MAKE) -C build/aarch64 clean