summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
-rwxr-xr-xvue3
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29a7f00950c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 7 19:23:10 UTC 2016
+pkgbase = vue
+ pkgdesc = Visual Understanding Environment
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = https://github.com/VUE/VUE
+ arch = any
+ license = unknown
+ depends = java-environment
+ noextract = VUE.jar
+ source = https://github.com/VUE/VUE/releases/download/3.3.0/VUE.jar
+ source = vue
+ md5sums = 4ac36729f42d000ac163add1b6c7a351
+ md5sums = af196991a58733c5c0742aace0439639
+
+pkgname = vue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2b0d635feb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Romain Porte <microjoe@mailoo.org>
+
+pkgname=vue
+pkgver=3.3.0
+pkgrel=1
+pkgdesc="Visual Understanding Environment"
+arch=('any')
+url="https://github.com/VUE/VUE"
+license=('unknown')
+depends=('java-environment')
+source=(https://github.com/VUE/VUE/releases/download/$pkgver/VUE.jar vue)
+noextract=('VUE.jar')
+md5sums=('4ac36729f42d000ac163add1b6c7a351' 'af196991a58733c5c0742aace0439639')
+
+
+package() {
+ install -Dm755 VUE.jar $pkgdir/opt/$pkgname/VUE.jar
+ install -Dm755 vue $pkgdir/usr/bin/vue
+}
diff --git a/vue b/vue
new file mode 100755
index 000000000000..e35ea32e82cc
--- /dev/null
+++ b/vue
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec java -jar /opt/vue/VUE.jar