summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0c7dcebaa19..81fae8579d48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = vulkan-caps-viewer
arch = x86_64
license = GPL2
makedepends = qt5-base
+ makedepends = git
depends = vulkan-icd-loader
depends = qt5-base
depends = qt5-x11extras
diff --git a/PKGBUILD b/PKGBUILD
index 2fcf195ce9fa..2b02920a59c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,9 @@ sha1sums=('bd4edf5510968bd5c9c2bce0deb4c048b7ddf966')
makedepends=(qt5-base)
depends=(vulkan-icd-loader qt5-base qt5-x11extras)
+#HACK: github doesn't package submodules, so we need to manually fetch the vulkan headers
+makedepends+=(git)
+
prepare() {
if [ -d build ]
then
@@ -20,6 +23,14 @@ prepare() {
return
fi
+ #HACK: github doesn't package submodules...
+ git clone --depth 1 https://github.com/KhronosGroup/Vulkan-Headers \
+ VulkanCapsViewer-$pkgver/Vulkan-Headers
+
+ #HACK: the last commit of 2.02 explicitely breaks the build; probably wasn't intended to be pushed out
+ sed 's#"/Vulkan-Headers/include"#"./Vulkan-Headers/include"#' \
+ -i VulkanCapsViewer-$pkgver/vulkanCapsViewer.pro
+
mkdir build
cd build
export PREFIX="$pkgdir"