summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d00e1ef879e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vulkan-validation-layers-git
+ pkgdesc = vulkan extension layer build from source
+ pkgver = 1.2.140.2020.05.25
+ pkgrel = 1
+ url = https://github.com/KhronosGroup/Vulkan-ValidationLayers.git
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = git
+ makedepends = glslang-sparzz-git
+ provides = vulkan-validation-layers-git
+ conflicts = vulkan-validation-layers
+ replaces = vulkan-validation-layers
+ source = Vulkan-ValidationLayers::git+https://github.com/KhronosGroup/Vulkan-ValidationLayers.git
+ md5sums = SKIP
+
+pkgname = vulkan-validation-layers-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c07bf3af94e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: sparzz
+pkgname=vulkan-validation-layers-git
+pkgver=1.2.140.2020.05.25
+pkgrel=1
+epoch=
+pkgdesc="vulkan extension layer build from source"
+arch=(x86_64)
+url="https://github.com/KhronosGroup/Vulkan-ValidationLayers.git"
+license=('Apache')
+groups=()
+depends=()
+makedepends=("cmake"
+ "git"
+ "glslang-sparzz-git")
+checkdepends=()
+optdepends=()
+provides=(vulkan-validation-layers-git)
+conflicts=(vulkan-validation-layers)
+replaces=(vulkan-validation-layers)
+backup=()
+options=()
+install=
+changelog=
+source=("Vulkan-ValidationLayers::git+https://github.com/KhronosGroup/Vulkan-ValidationLayers.git")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+
+
+
+
+
+package() {
+ cmake -DGLSLANG_INSTALL_DIR=usr/local/bin/ Vulkan-ExtensionLayer
+ make DESTDIR="$pkgdir" install
+}