summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
-rw-r--r--vundle.install8
-rw-r--r--vundle.vimrc29
4 files changed, 18 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d77b456505f9..0c462edad1c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = vundle
pkgdesc = Plug-in manager for Vim
pkgver = 0.10.2
- pkgrel = 1
- url = https://github.com/gmarik/Vundle.vim
+ pkgrel = 2
+ url = https://github.com/VundleVim/Vundle.vim
install = vundle.install
arch = any
license = MIT
depends = vim>=7.0
source = vundle-0.10.2.tar.gz::https://github.com/gmarik/Vundle.vim/archive/v0.10.2.tar.gz
- source = vundle.vimrc
- sha512sums = SKIP
- sha512sums = 73329b4a1f302c684a6c203faac11ca040fd549ed4b4a5b09f4d94c53315748478e3b079bd4d2aed648e4eece2e62fd99d21ffcd34eb966e9e840ef73647c5fb
+ sha512sums = 4a06e6600956cccb4db2852812a100ae31f499b11fe1a4a0d524da84a51c5e1f267770fe8032d8a28b4fb3f6313a2b8f087e277a65fd4a4d507aa4e7d87a96ea
pkgname = vundle
diff --git a/PKGBUILD b/PKGBUILD
index a8357b2ddead..67b211ca4c0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
-# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgname=vundle
_gitname=Vundle.vim
pkgver=0.10.2
-pkgrel=1
-pkgdesc="Plug-in manager for Vim"
-url="https://github.com/gmarik/Vundle.vim"
+pkgrel=2
+pkgdesc='Plug-in manager for Vim'
+url='https://github.com/VundleVim/Vundle.vim'
arch=('any')
license=('MIT')
depends=('vim>=7.0')
install=vundle.install
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/gmarik/Vundle.vim/archive/v${pkgver}.tar.gz
- vundle.vimrc)
-sha512sums=('SKIP'
- '73329b4a1f302c684a6c203faac11ca040fd549ed4b4a5b09f4d94c53315748478e3b079bd4d2aed648e4eece2e62fd99d21ffcd34eb966e9e840ef73647c5fb')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/gmarik/Vundle.vim/archive/v${pkgver}.tar.gz)
+sha512sums=('4a06e6600956cccb4db2852812a100ae31f499b11fe1a4a0d524da84a51c5e1f267770fe8032d8a28b4fb3f6313a2b8f087e277a65fd4a4d507aa4e7d87a96ea')
+
+prepare() {
+ cd ${_gitname}-${pkgver}
+ sed -r 's|(set rtp)|" \1|' -i README.md
+}
package() {
cd ${_gitname}-${pkgver}
vimpath="${pkgdir}/usr/share/vim/vimfiles"
- mkdir -p ${vimpath}/doc
- cp -R doc ${vimpath}
- mkdir -p ${vimpath}/autoload
- cp -R autoload ${vimpath}
+ mkdir -p "${vimpath}/doc"
+ cp -R doc "${vimpath}"
+ mkdir -p "${vimpath}/autoload"
+ cp -R autoload "${vimpath}"
- install -Dm 644 "${srcdir}"/vundle.vimrc ${pkgdir}/usr/share/${pkgname}/vimrc.sample
install -Dm 644 LICENSE-MIT.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
install -Dm 644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README
}
diff --git a/vundle.install b/vundle.install
index 555151ccb28b..0824d966a4be 100644
--- a/vundle.install
+++ b/vundle.install
@@ -3,10 +3,6 @@ post_install() {
/usr/bin/vim --noplugins -u NONE -U NONE \
--cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
echo "done."
- echo "
- >>> To use vundle, please check the file /usr/share/vundle/vimrc.sample
- >>> and update your ~/.vimrc file, accordingly
- "
}
post_upgrade() {
@@ -18,10 +14,6 @@ post_remove() {
/usr/bin/vim --noplugins -u NONE -U NONE \
--cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
echo "done."
- echo "
- >>> Please remember to remove vundle bundles from your ~/.vimrc file
- >>> and from your ~/.vim directory!
- "
}
# vim: ts=2 sw=2 et:
diff --git a/vundle.vimrc b/vundle.vimrc
deleted file mode 100644
index 0e2e168e8f0b..000000000000
--- a/vundle.vimrc
+++ /dev/null
@@ -1,29 +0,0 @@
-set nocompatible " be iMproved
-filetype off " required!
-
-call vundle#rc()
-
-" My Bundles here:
-"
-" original repos on github
-" Bundle 'tpope/vim-fugitive'
-" Bundle 'Lokaltog/vim-easymotion'
-" Bundle 'rstacruz/sparkup', {'rtp': 'vim/'}
-" Bundle 'tpope/vim-rails.git'
-" vim-scripts repos
-" Bundle 'L9'
-" Bundle 'FuzzyFinder'
-" non github repos
-" Bundle 'git://git.wincent.com/command-t.git'
-" ...
-
-filetype plugin indent on " required!
-"
-" Brief help
-" :BundleList - list configured bundles
-" :BundleInstall(!) - install(update) bundles
-" :BundleSearch(!) foo - search(or refresh cache first) for foo
-" :BundleClean(!) - confirm(or auto-approve) removal of unused bundles
-"
-" see :h vundle for more details or wiki for FAQ
-" NOTE: comments after Bundle command are not allowed..