summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--vundle.install27
-rw-r--r--vundle.vimrc29
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d77b456505f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vundle
+ pkgdesc = Plug-in manager for Vim
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = https://github.com/gmarik/Vundle.vim
+ install = vundle.install
+ arch = any
+ license = MIT
+ depends = vim>=7.0
+ source = vundle-0.10.2.tar.gz::https://github.com/gmarik/Vundle.vim/archive/v0.10.2.tar.gz
+ source = vundle.vimrc
+ sha512sums = SKIP
+ sha512sums = 73329b4a1f302c684a6c203faac11ca040fd549ed4b4a5b09f4d94c53315748478e3b079bd4d2aed648e4eece2e62fd99d21ffcd34eb966e9e840ef73647c5fb
+
+pkgname = vundle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8357b2ddead
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+
+pkgname=vundle
+_gitname=Vundle.vim
+pkgver=0.10.2
+pkgrel=1
+pkgdesc="Plug-in manager for Vim"
+url="https://github.com/gmarik/Vundle.vim"
+arch=('any')
+license=('MIT')
+depends=('vim>=7.0')
+install=vundle.install
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/gmarik/Vundle.vim/archive/v${pkgver}.tar.gz
+ vundle.vimrc)
+sha512sums=('SKIP'
+ '73329b4a1f302c684a6c203faac11ca040fd549ed4b4a5b09f4d94c53315748478e3b079bd4d2aed648e4eece2e62fd99d21ffcd34eb966e9e840ef73647c5fb')
+
+package() {
+ cd ${_gitname}-${pkgver}
+
+ vimpath="${pkgdir}/usr/share/vim/vimfiles"
+ mkdir -p ${vimpath}/doc
+ cp -R doc ${vimpath}
+ mkdir -p ${vimpath}/autoload
+ cp -R autoload ${vimpath}
+
+ install -Dm 644 "${srcdir}"/vundle.vimrc ${pkgdir}/usr/share/${pkgname}/vimrc.sample
+ install -Dm 644 LICENSE-MIT.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm 644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/vundle.install b/vundle.install
new file mode 100644
index 000000000000..555151ccb28b
--- /dev/null
+++ b/vundle.install
@@ -0,0 +1,27 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+ echo "
+ >>> To use vundle, please check the file /usr/share/vundle/vimrc.sample
+ >>> and update your ~/.vimrc file, accordingly
+ "
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+ echo "
+ >>> Please remember to remove vundle bundles from your ~/.vimrc file
+ >>> and from your ~/.vim directory!
+ "
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/vundle.vimrc b/vundle.vimrc
new file mode 100644
index 000000000000..0e2e168e8f0b
--- /dev/null
+++ b/vundle.vimrc
@@ -0,0 +1,29 @@
+set nocompatible " be iMproved
+filetype off " required!
+
+call vundle#rc()
+
+" My Bundles here:
+"
+" original repos on github
+" Bundle 'tpope/vim-fugitive'
+" Bundle 'Lokaltog/vim-easymotion'
+" Bundle 'rstacruz/sparkup', {'rtp': 'vim/'}
+" Bundle 'tpope/vim-rails.git'
+" vim-scripts repos
+" Bundle 'L9'
+" Bundle 'FuzzyFinder'
+" non github repos
+" Bundle 'git://git.wincent.com/command-t.git'
+" ...
+
+filetype plugin indent on " required!
+"
+" Brief help
+" :BundleList - list configured bundles
+" :BundleInstall(!) - install(update) bundles
+" :BundleSearch(!) foo - search(or refresh cache first) for foo
+" :BundleClean(!) - confirm(or auto-approve) removal of unused bundles
+"
+" see :h vundle for more details or wiki for FAQ
+" NOTE: comments after Bundle command are not allowed..