summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xvxray-rules-dat-updater5
-rw-r--r--vxray-rules-dat-updater.service2
-rw-r--r--vxray-rules-dat-updater.sysusers2
5 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f64eb2a2e1ed..cd15f363cafd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vxray-rules-dat-git
pkgdesc = Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update. DO NOT flag out-dated.
- pkgver = r202108282209
+ pkgver = r202108281135
pkgrel = 1
url = https://github.com/Loyalsoldier/v2ray-rules-dat
install = vxray-rules-dat-git.install
@@ -27,10 +27,10 @@ pkgbase = vxray-rules-dat-git
source = vxray-rules-dat-updater.timer
sha256sums = SKIP
sha256sums = eb1d2175b8be7f9779639b2b24d8260f83116c9a743f1fb0052f056518ccfd11
- sha256sums = ef9498a1e5bd99cece2d43cb24e4ce7afcf274171e33159e90f210a31c064004
+ sha256sums = 1e3cc96020718f5c022b8b5b2cbb0b3b8236583817ce313cc35709b2d3cc1f99
sha256sums = c855bae9e8a9e3fb7b5be4271bf6e05ad441eacd8272d505ee55a407b6bd263e
sha256sums = 1c3c0b854bbfd96b0d84383bfff84eb70e69ac5193b7a535f75183ca28634fc2
- sha256sums = e282e023e2f4fbffabedc19a01c33e03cc5049c7cb2cd6e36398233a16bd2b84
+ sha256sums = 9742ad89797cdcba3d2f1068807a884e09f3797419c19d61125c7c93cec9212b
sha256sums = 5bd55042d53d3794f27483277056f06f5e55d0e7702b0093ec6f17d7da6d548c
pkgname = vxray-rules-dat-git
diff --git a/PKGBUILD b/PKGBUILD
index 28adc30bdc1a..e464ca191e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vxray-rules-dat-git
_pkgname=vxray-rules-dat
pkgdesc="Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update. DO NOT flag out-dated."
-pkgver=r202108282209
+pkgver=r202108281135
pkgrel=1
arch=('any')
url="https://github.com/Loyalsoldier/v2ray-rules-dat"
@@ -28,10 +28,10 @@ source=(
sha256sums=(
'SKIP'
'eb1d2175b8be7f9779639b2b24d8260f83116c9a743f1fb0052f056518ccfd11'
- 'ef9498a1e5bd99cece2d43cb24e4ce7afcf274171e33159e90f210a31c064004'
+ '1e3cc96020718f5c022b8b5b2cbb0b3b8236583817ce313cc35709b2d3cc1f99'
'c855bae9e8a9e3fb7b5be4271bf6e05ad441eacd8272d505ee55a407b6bd263e'
'1c3c0b854bbfd96b0d84383bfff84eb70e69ac5193b7a535f75183ca28634fc2'
- 'e282e023e2f4fbffabedc19a01c33e03cc5049c7cb2cd6e36398233a16bd2b84'
+ '9742ad89797cdcba3d2f1068807a884e09f3797419c19d61125c7c93cec9212b'
'5bd55042d53d3794f27483277056f06f5e55d0e7702b0093ec6f17d7da6d548c'
)
diff --git a/vxray-rules-dat-updater b/vxray-rules-dat-updater
index ccbca68a553e..be8427eaf1d3 100755
--- a/vxray-rules-dat-updater
+++ b/vxray-rules-dat-updater
@@ -3,8 +3,9 @@
set -e
FastGit="https://hub.fastgit.org/Loyalsoldier/v2ray-rules-dat/releases/latest/"
-GitHub="https://github.com/Loyalsoldier/v2ray-rules-dat/raw/releases"
+GitHub="https://github.com/Loyalsoldier/v2ray-rules-dat/releases/latest/download"
JsDelivr="https://cdn.jsdelivr.net/gh/Loyalsoldier/v2ray-rules-dat@release/"
+CfCDN="https://cfgit.cern.ga/Loyalsoldier/v2ray-rules-dat/releases/latest/download"
download_files() {
echo "Fetching geoip.dat"
@@ -27,6 +28,8 @@ case "${1}" in
"jsdelivr" | "js")
download_files $JsDelivr
;;
+"cfcdn" | "cf"
+ download_files $CfCDN
*)
download_files $GitHub
;;
diff --git a/vxray-rules-dat-updater.service b/vxray-rules-dat-updater.service
index 0332b3eb84ba..80dc1ce2c614 100644
--- a/vxray-rules-dat-updater.service
+++ b/vxray-rules-dat-updater.service
@@ -8,4 +8,4 @@ User = vxray-rules-dat
Group = vxray-rules-dat
WorkingDirectory = /var/lib/vxray-rules-dat
-ExecStart = /usr/bin/vxray-rules-dat-updater github
+ExecStart = /usr/bin/vxray-rules-dat-updater github && cp -f /var/lib/vxray-rules-dat/geoip.dat /usr/share/v2ray/geoip.dat && cp -f /var/lib/vxray-rules-dat/geoip.dat /usr/share/xray/geoip.dat && cp -f /var/lib/vxray-rules-dat/geoip.dat /usr/share/v2ray/geosite.dat && cp -f /var/lib/vxray-rules-dat/geoip.dat /usr/share/xray/geosite.dat
diff --git a/vxray-rules-dat-updater.sysusers b/vxray-rules-dat-updater.sysusers
index 17e2ad07fe50..ca666c261cf7 100644
--- a/vxray-rules-dat-updater.sysusers
+++ b/vxray-rules-dat-updater.sysusers
@@ -1 +1 @@
-u vxray-rules-dat - "account for vxray-rules-dat updater" /var/lib/vxray-rules-dat
+u vxray-rules-dat - "account for vxray-rules-dat updater" /var/lib/vxray-rules-dat /usr/share/v2ray /usr/share/xray