summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rwxr-xr-xvxray-rules-dat-updater6
3 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 370cc5a77d7d..a9885d2e2394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vxray-rules-dat-git
pkgdesc = Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update. DO NOT flag out-dated.
- pkgver = r202108212209
+ pkgver = r202108222209
pkgrel = 1
url = https://github.com/Loyalsoldier/v2ray-rules-dat
install = vxray-rules-dat-git.install
@@ -13,12 +13,11 @@ pkgbase = vxray-rules-dat-git
provides = v2ray-domain-list-community
provides = v2ray-geoip
provides = v2ray-rules-dat-git
- provides = v2ray-rules-dat-git-for-xray
conflicts = xray-domain-list-community
conflicts = xray-geoip
conflicts = v2ray-domain-list-community
conflicts = v2ray-geoip
- conflicts = v2ray-rules-dat-gitv2ray-rules-dat-git-for-xray
+ conflicts = v2ray-rules-dat-git
source = vxray-rules-dat-git::git+https://github.com/Loyalsoldier/v2ray-rules-dat.git
source = vxray-rules-dat-git.install
source = vxray-rules-dat-updater
@@ -28,7 +27,7 @@ pkgbase = vxray-rules-dat-git
source = vxray-rules-dat-updater.timer
sha256sums = SKIP
sha256sums = eb1d2175b8be7f9779639b2b24d8260f83116c9a743f1fb0052f056518ccfd11
- sha256sums = a9de745de1166a4011dabe23dc726658c28fab774fac90f9e4e2ef178171e0cc
+ sha256sums = 339962eedc9875a1533a67434cc240be8d728cb921be3f8ce82a8151c8e4c8ed
sha256sums = c855bae9e8a9e3fb7b5be4271bf6e05ad441eacd8272d505ee55a407b6bd263e
sha256sums = 1c3c0b854bbfd96b0d84383bfff84eb70e69ac5193b7a535f75183ca28634fc2
sha256sums = e282e023e2f4fbffabedc19a01c33e03cc5049c7cb2cd6e36398233a16bd2b84
diff --git a/PKGBUILD b/PKGBUILD
index 2bf692a7d9d0..206b20433234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=vxray-rules-dat-git
_pkgname=vxray-rules-dat
pkgdesc="Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update. DO NOT flag out-dated."
-pkgver=r202108212209
+pkgver=r202108222209
pkgrel=1
arch=('any')
url="https://github.com/Loyalsoldier/v2ray-rules-dat"
license=('GPL')
-provides=('xray-domain-list-community' 'xray-geoip' 'v2ray-domain-list-community' 'v2ray-geoip' 'v2ray-rules-dat-git' 'v2ray-rules-dat-git-for-xray')
-conflicts=('xray-domain-list-community' 'xray-geoip' 'v2ray-domain-list-community' 'v2ray-geoip' 'v2ray-rules-dat-git''v2ray-rules-dat-git-for-xray')
+provides=('xray-domain-list-community' 'xray-geoip' 'v2ray-domain-list-community' 'v2ray-geoip' 'v2ray-rules-dat-git')
+conflicts=('xray-domain-list-community' 'xray-geoip' 'v2ray-domain-list-community' 'v2ray-geoip' 'v2ray-rules-dat-git')
makedepends=('git')
depends=('curl')
@@ -28,7 +28,7 @@ source=(
sha256sums=(
'SKIP'
'eb1d2175b8be7f9779639b2b24d8260f83116c9a743f1fb0052f056518ccfd11'
- 'a9de745de1166a4011dabe23dc726658c28fab774fac90f9e4e2ef178171e0cc'
+ '339962eedc9875a1533a67434cc240be8d728cb921be3f8ce82a8151c8e4c8ed'
'c855bae9e8a9e3fb7b5be4271bf6e05ad441eacd8272d505ee55a407b6bd263e'
'1c3c0b854bbfd96b0d84383bfff84eb70e69ac5193b7a535f75183ca28634fc2'
'e282e023e2f4fbffabedc19a01c33e03cc5049c7cb2cd6e36398233a16bd2b84'
@@ -36,14 +36,15 @@ sha256sums=(
)
pkgver() {
- cd "${srcdir}/${pkgname}"
- git switch release >/dev/null 2>&1
- printf "r%s" "$(git log --pretty=\"format:%B\" HEAD | tr -dc '[:digit:]')"
+ cd "$pkgname"
+ git describe --long --tags | sed 's/([^-]*-g)/r\1/;s/-/./g'
}
package() {
pushd "${srcdir}/${pkgname}"
git switch release >/dev/null 2>&1
+ sha256sum --check "./geoip.dat.sha256sum"
+ sha256sum --check "./geosite.dat.sha256sum"
install -Dm644 "./geoip.dat" "${pkgdir}/usr/share/xray/geoip.dat"
install -Dm644 "./geoip.dat" "${pkgdir}/usr/share/v2ray/geoip.dat"
install -Dm644 "./geosite.dat" "${pkgdir}/usr/share/xray/geosite.dat"
diff --git a/vxray-rules-dat-updater b/vxray-rules-dat-updater
index 6a245de27f91..3ba6736d4550 100755
--- a/vxray-rules-dat-updater
+++ b/vxray-rules-dat-updater
@@ -9,9 +9,15 @@ JsDelivr="https://cdn.jsdelivr.net/gh/Loyalsoldier/v2ray-rules-dat@release/"
download_files() {
echo "Fetching geoip.dat"
curl -LO "${1}/geoip.dat"
+ curl -LO "${1}/geoip.dat.sha256sum"
+ sha256sum --check "geoip.dat.sha256sum"
echo "Fetching geosite.dat"
curl -LO "${1}/geosite.dat"
+ curl -LO "${1}/geosite.dat.sha256sum"
+ sha256sum --check "geosite.dat.sha256sum"
+
+ rm -v "geosite.dat.sha256sum" "geoip.dat.sha256sum"
}
case "${1}" in