summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--vxray-rules-dat-git.install2
-rwxr-xr-xvxray-rules-dat-updater8
-rw-r--r--vxray-rules-dat-updater.sysusers1
-rw-r--r--vxray-rules-dat-updater.timer6
6 files changed, 12 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28c587d6e457..fbad6cd8dd4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vxray-rules-dat-git
- pkgdesc = Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update. DO NOT flag out-dated.
- pkgver = r202110222209
+ pkgdesc = Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update by using crontab. DO NOT flag out-dated.
+ pkgver = r202201010556
pkgrel = 1
url = https://github.com/Loyalsoldier/v2ray-rules-dat
install = vxray-rules-dat-git.install
@@ -21,16 +21,12 @@ pkgbase = vxray-rules-dat-git
source = vxray-rules-dat-git::git+https://github.com/Loyalsoldier/v2ray-rules-dat.git
source = vxray-rules-dat-git.install
source = vxray-rules-dat-updater
- source = vxray-rules-dat-updater.sysusers
source = vxray-rules-dat-updater.tmpfiles
source = vxray-rules-dat-updater.service
- source = vxray-rules-dat-updater.timer
sha256sums = SKIP
- sha256sums = eb1d2175b8be7f9779639b2b24d8260f83116c9a743f1fb0052f056518ccfd11
- sha256sums = b3ab75e92fe5a3285be9298093b069bb41fb0b6160fc3ba583e07fa6ddaedd71
- sha256sums = be8a1aa0fcb3a20387ebfc00e03466867d647de2b154c1606856e887cd8d7cf5
+ sha256sums = c30723eb0702e2e72dacb9b987f6c94afdf3235bc0f7d4fd6cc89c098f9e000d
+ sha256sums = b57de5f1ea5c80b8b8d11d99691206f0a7db1c8543ba17432919aa9dd7acff55
sha256sums = 1c3c0b854bbfd96b0d84383bfff84eb70e69ac5193b7a535f75183ca28634fc2
sha256sums = 62377bc329477f85639eacf634fe32c1ff735cd5a636f949addc1ec036f59607
- sha256sums = 5bd55042d53d3794f27483277056f06f5e55d0e7702b0093ec6f17d7da6d548c
pkgname = vxray-rules-dat-git
diff --git a/PKGBUILD b/PKGBUILD
index c05640638e17..1ddb916b3e06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: llxray <c60@outlook.de>
pkgname=vxray-rules-dat-git
_pkgname=vxray-rules-dat
-pkgdesc="Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update. DO NOT flag out-dated."
-pkgver=r202110222209
+pkgdesc="Enhanced edition of V2Ray and Xray rules dat files, compatible with Trojan-Go. Automaitcally update by using crontab. DO NOT flag out-dated."
+pkgver=r202201010556
pkgrel=1
arch=('any')
url="https://github.com/Loyalsoldier/v2ray-rules-dat"
@@ -20,19 +20,15 @@ source=(
"$pkgname::git+$url.git"
vxray-rules-dat-git.install
vxray-rules-dat-updater
- vxray-rules-dat-updater.sysusers
vxray-rules-dat-updater.tmpfiles
vxray-rules-dat-updater.service
- vxray-rules-dat-updater.timer
)
sha256sums=(
'SKIP'
- 'eb1d2175b8be7f9779639b2b24d8260f83116c9a743f1fb0052f056518ccfd11'
- 'b3ab75e92fe5a3285be9298093b069bb41fb0b6160fc3ba583e07fa6ddaedd71'
- 'be8a1aa0fcb3a20387ebfc00e03466867d647de2b154c1606856e887cd8d7cf5'
+ 'c30723eb0702e2e72dacb9b987f6c94afdf3235bc0f7d4fd6cc89c098f9e000d'
+ 'b57de5f1ea5c80b8b8d11d99691206f0a7db1c8543ba17432919aa9dd7acff55'
'1c3c0b854bbfd96b0d84383bfff84eb70e69ac5193b7a535f75183ca28634fc2'
'62377bc329477f85639eacf634fe32c1ff735cd5a636f949addc1ec036f59607'
- '5bd55042d53d3794f27483277056f06f5e55d0e7702b0093ec6f17d7da6d548c'
)
pkgver() {
@@ -53,8 +49,6 @@ package() {
popd
install -Dm755 "./${_pkgname}-updater" "${pkgdir}/usr/bin/${_pkgname}-updater"
- install -Dm644 "./${_pkgname}-updater.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_pkgname}-updater.conf"
install -Dm644 "./${_pkgname}-updater.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${_pkgname}-updater.conf"
install -Dm644 "./${_pkgname}-updater.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}-updater.service"
- install -Dm644 "./${_pkgname}-updater.timer" "${pkgdir}/usr/lib/systemd/system/${_pkgname}-updater.timer"
}
diff --git a/vxray-rules-dat-git.install b/vxray-rules-dat-git.install
index 569c41593e47..688a003eac14 100644
--- a/vxray-rules-dat-git.install
+++ b/vxray-rules-dat-git.install
@@ -1,4 +1,4 @@
post_install() {
- printf $(tput bold)'Enable vxray-rules-dat-updater.timer to update rules automatically everyday.\n'
+ printf $(tput bold)'Use (sudo) crontab -e and add "@reboot /usr/bin/sudo systemctl start vxray-rules-dat-updater.service" to update automatically at reboot.\n'
printf 'The most up-to-date geoip.dat and geosite.dat can be found under /var/lib/vxray-rules-dat'$(tput sgr0)'\n'
}
diff --git a/vxray-rules-dat-updater b/vxray-rules-dat-updater
index d55ed8754aa4..e718fcbe5245 100755
--- a/vxray-rules-dat-updater
+++ b/vxray-rules-dat-updater
@@ -5,7 +5,7 @@ set -e
FastGit="https://hub.fastgit.org/Loyalsoldier/v2ray-rules-dat/releases/latest/"
GitHub="https://github.com/Loyalsoldier/v2ray-rules-dat/releases/latest/download"
JsDelivr="https://cdn.jsdelivr.net/gh/Loyalsoldier/v2ray-rules-dat@release/"
-CfCDN="https://cfgit.cern.ga/Loyalsoldier/v2ray-rules-dat/releases/latest/download"
+GHProxy="https://ghproxy.com/https://github.com/Loyalsoldier/v2ray-rules-dat/releases/latest/download"
download_files() {
echo "Fetching geoip.dat"
@@ -20,8 +20,6 @@ download_files() {
rm -v "geosite.dat.sha256sum" "geoip.dat.sha256sum"
cp -f /var/lib/vxray-rules-dat/geoip.dat /usr/share/xray/geoip.dat && cp -f /var/lib/vxray-rules-dat/geoip.dat /usr/share/v2ray/geoip.dat && cp -f /var/lib/vxray-rules-dat/geosite.dat /usr/share/xray/geosite.dat && cp -f /var/lib/vxray-rules-dat/geosite.dat /usr/share/v2ray/geosite.dat
- ##support for QV2Ray3.0
- #cp -f /usr/bin/xray /usr/bin/v2ray
}
case "${1}" in
@@ -31,8 +29,8 @@ case "${1}" in
"jsdelivr" | "js")
download_files $JsDelivr
;;
-"cfcdn" | "cf")
- download_files $CfCDN
+"ghproxy" | "gh")
+ download_files $GHProxy
;;
*)
download_files $GitHub
diff --git a/vxray-rules-dat-updater.sysusers b/vxray-rules-dat-updater.sysusers
deleted file mode 100644
index ca666c261cf7..000000000000
--- a/vxray-rules-dat-updater.sysusers
+++ /dev/null
@@ -1 +0,0 @@
-u vxray-rules-dat - "account for vxray-rules-dat updater" /var/lib/vxray-rules-dat /usr/share/v2ray /usr/share/xray
diff --git a/vxray-rules-dat-updater.timer b/vxray-rules-dat-updater.timer
deleted file mode 100644
index 3cc2d16e4e0e..000000000000
--- a/vxray-rules-dat-updater.timer
+++ /dev/null
@@ -1,6 +0,0 @@
-[Timer]
-OnCalendar = daily
-Persistent = true
-
-[Install]
-WantedBy = timers.target