summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8f8bc62e3f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vyper
+ pkgdesc = Pythonic Smart Contract Language for the EVM
+ pkgver = 0.1.0_beta.4
+ pkgrel = 1
+ url = https://github.com/ethereum/vyper
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/ethereum/vyper/archive/v0.1.0-beta.4.tar.gz
+ md5sums = d74171e4ed78a1482320f3a8158e5eaa
+
+pkgname = vyper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea62dfe5226b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Travis Jacobs <traviswjacobs@gmail.com>
+pkgname=vyper
+pkgver=0.1.0_beta.4
+_vername=0.1.0-beta.4
+pkgrel=1
+pkgdesc="Pythonic Smart Contract Language for the EVM"
+arch=('x86_64')
+url="https://github.com/ethereum/vyper"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/ethereum/$pkgname/archive/v$_vername.tar.gz")
+md5sums=('d74171e4ed78a1482320f3a8158e5eaa')
+
+package() {
+ cd "$pkgname-$_vername"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}