summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bba578728c3b..b5b2b2400119 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wacom-utility-git
pkgdesc = Graphical tablet configuration utility
- pkgver = 20150614
- pkgrel = 2
+ pkgver = r20.d9735e0
+ pkgrel = 1
url = http://github.com/lubosz/wacom-utility.git
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = wacom-utility-git
depends = gksu
conflicts = wacom-utility
replaces = wacom-utility
+ source = wacom-utility-git::git+http://github.com/lubosz/wacom-utility.git
source = wacom-utility.desktop
+ md5sums = SKIP
md5sums = 1d44b3571fd5e48b80b2dec5209fcf47
pkgname = wacom-utility-git
diff --git a/PKGBUILD b/PKGBUILD
index 42b8af10aaff..3097d9b2f81b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
+# Maintainer: orumin <dev@orum.in>
+
pkgname=wacom-utility-git
-pkgver=20150614
-pkgver() {
- cd "${pkgname}"
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
-}
-pkgrel=2
+pkgver=r20.d9735e0
+pkgrel=1
pkgdesc="Graphical tablet configuration utility"
arch=('i686' 'x86_64')
url="http://github.com/lubosz/wacom-utility.git"
@@ -12,17 +10,19 @@ license=('GPL')
depends=('gtk2' 'python2' 'xf86-input-wacom' 'gksu')
conflicts=('wacom-utility')
replaces=('wacom-utility')
-source=(wacom-utility.desktop)
-md5sums=('1d44b3571fd5e48b80b2dec5209fcf47')
+source=("${pkgname}::git+${url}"
+ 'wacom-utility.desktop')
+md5sums=('SKIP'
+ '1d44b3571fd5e48b80b2dec5209fcf47')
-_gitname="wacom-utility"
-_gitroot="http://github.com/lubosz/$_gitname"
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- cd ${srcdir}/
- git clone ${_gitroot}
+ cd "${srcdir}/${pkgname}"
- cd ${_gitname}
mkdir -p "${pkgdir}"/usr/share/wacom-utility
mkdir -p "${pkgdir}"/usr/share/applications
cp -a ./* "${pkgdir}"/usr/share/wacom-utility