summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be9a7433266c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wake
+ pkgdesc = The SiFive wake build tool
+ pkgver = 0.16.0
+ pkgrel = 1
+ url = https://github.com/sifive/wake
+ arch = x86_64
+ license = custom
+ depends = dash
+ depends = sqlite
+ depends = gmp
+ depends = fuse-common
+ depends = re2
+ depends = ncurses5-compat-libs
+ optdepends = re2c
+ optdepends = utf8proc
+ source = https://github.com/sifive/wake/releases/download/v0.16.0/wake_0.16.0.tar.xz
+ md5sums = 7be63bd44668a6ca252a3ac53c5a1e4e
+
+pkgname = wake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16b4649f2457
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jiuyang Liu <liujiuyang1994@gmail.com>
+
+pkgname=wake
+pkgver=0.16.0
+pkgrel=1
+pkgdesc="The SiFive wake build tool"
+arch=('x86_64')
+url="https://github.com/sifive/wake"
+license=('custom')
+depends=('dash' 'sqlite' 'gmp' 'fuse-common' 're2' 'ncurses5-compat-libs')
+optdepends=('re2c'
+ 'utf8proc')
+source=("https://github.com/sifive/wake/releases/download/v0.16.0/wake_$pkgver.tar.xz")
+md5sums=('7be63bd44668a6ca252a3ac53c5a1e4e')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ ./bin/wake 'install "'$pkgdir'/usr"'
+ mkdir -p $pkgdir/usr/share/licenses/wake
+ install -Dm644 $srcdir/$pkgname-$pkgver/LICENSE* $pkgdir/usr/share/licenses/wake
+}