summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9c67f83b81d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Apr 21 23:07:31 UTC 2017
+pkgbase = wal-git
+ pkgdesc = Generate and change colorschemes on the fly.
+ pkgver = r194.7e9917a
+ pkgrel = 1
+ url = https://github.com/dylanaraps/wal
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = bash
+ depends = imagemagick
+ optdepends = bgs: Set wallpaper.
+ optdepends = feh: Set wallpaper.
+ optdepends = habak: Set wallpaper.
+ optdepends = hsetroot: Set wallpaper.
+ optdepends = nitrogen: Set wallpaper.
+ optdepends = xorg-xprop: Used to detect which DE Wallpaper setter to use.
+ provides = wal
+ conflicts = wal
+ source = wal-git::git+https://github.com/dylanaraps/wal.git
+ md5sums = SKIP
+
+pkgname = wal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a421ef9901b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dylan Araps <dyl@tfwno.gf>
+pkgname=wal-git
+_pkgname=wal
+pkgver=r194.7e9917a
+pkgrel=1
+pkgdesc="Generate and change colorschemes on the fly."
+arch=('any')
+url="https://github.com/dylanaraps/wal"
+license=('MIT')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=(
+ 'bash'
+ 'imagemagick'
+)
+optdepends=(
+ 'bgs: Set wallpaper.'
+ 'feh: Set wallpaper.'
+ 'habak: Set wallpaper.'
+ 'hsetroot: Set wallpaper.'
+ 'nitrogen: Set wallpaper.'
+ 'xorg-xprop: Used to detect which DE Wallpaper setter to use.'
+)
+makedepends=('git')
+source=("$pkgname::git+https://github.com/dylanaraps/wal.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -D -m755 ./wal "${pkgdir}/usr/bin/$_pkgname"
+}