summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d40379dd09e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wallo
+ pkgdesc = Wallpaper organizer
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://gitlab.com/oktopod11/wallo
+ arch = any
+ license = GPL
+ depends = bash
+ depends = file
+ depends = coreutils
+ depends = gawk
+ depends = sed
+ depends = imagemagick
+ provides = wallo
+ source = https://gitlab.com/oktopod11/wallo/raw/master/archive/wallo-0.6.tar.gz
+ sha256sums = 1084671ea3a1243a14e7132755b6627784a4040b86923e60dfe4d7ee28567d67
+
+pkgname = wallo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4e3550446df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Nikola Hadžić <nikola@firemail.cc>
+pkgname=wallo
+pkgver=0.6
+pkgrel=1
+epoch=
+pkgdesc="Wallpaper organizer"
+arch=("any")
+url="https://gitlab.com/oktopod11/wallo"
+license=("GPL")
+groups=()
+depends=("bash" "file" "coreutils" "gawk" "sed" "imagemagick")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=("wallo")
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=("https://gitlab.com/oktopod11/$pkgname/raw/master/archive/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=("1084671ea3a1243a14e7132755b6627784a4040b86923e60dfe4d7ee28567d67")
+
+prepare() {
+ tar -xvf "$pkgname-$pkgver.tar.gz"
+}
+
+package() {
+ mkdir -vp "$pkgdir/usr/bin/"
+ mkdir -vp "$pkgdir/usr/share/man/man1/"
+ cp -v "$pkgname-$pkgver/wallo.sh" "$pkgdir/usr/bin/wallo"
+ cp -v "$pkgname-$pkgver/wallo.man" "$pkgdir/usr/share/man/man1/wallo.1"
+ gzip -v "$pkgdir/usr/share/man/man1/wallo.1"
+}