summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a0d5e22186..373063efce9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Aug 5 09:09:00 UTC 2016
+# Sun Sep 11 02:18:41 UTC 2016
pkgbase = warmux
pkgdesc = Clone of turn-based artillery games like Scorched Earth or Worms (formerly known as Wormux)
pkgver = 11.04.1
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 8442b29c8d40..45d8f61fb71e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Zamarin Arthur <arthurzam@gmail.com>
+# Maintainer: Michael DeGuzis <mdeguzis@gmail.com>
# Contributor: carstene1ns <url/mail: arch carsten-teibes de>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: pukyxd
@@ -28,25 +28,30 @@ sha256sums=('789c4f353e4c5ce0a2aba2e82861d3fd0e5218bc76d8da1a332f2c7b1b27e4ee'
'de232b7f2264f9d576ba77f43f79dc698f6ba987d059468f5b2bb5f40cf644d3')
prepare() {
+
cd "$pkgname-${pkgver/.1/}"
# libpng fix
patch -Np1 < ../include-zlib.patch
+
# compilation fixes
patch -Np1 < ../gcc-fix.patch
patch -Np0 < ../return-null.patch
patch -Np1 < ../curl-ptr.patch
+
}
build() {
- cd "$pkgname-${pkgver/.1/}"
+ cd "$pkgname-${pkgver/.1/}"
./configure --prefix=/usr
make
+
}
package() {
- cd "$pkgname-${pkgver/.1/}"
+ cd "$pkgname-${pkgver/.1/}"
make DESTDIR="$pkgdir" install
+
}