summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea279af5ce82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = warpd-git
+ pkgdesc = A small X program which facilitates recursively warping the pointer to different quadrants on the screen. The program was inspired by the mousekeys feature of Kaleidoscope, the firmware for the Keyboardio
+ pkgver = 0.9a
+ pkgrel = 1
+ url = https://github.com/rvaiya/warpd
+ arch = x86_64
+ license = GPLV3
+ makedepends = git
+ makedepends = make
+ makedepends = libxinerama
+ makedepends = libxft
+ makedepends = libxfixes
+ makedepends = libxtst
+ makedepends = libx11
+ provides = warpd
+ source = git+https://github.com/rvaiya/warpd
+ md5sums = SKIP
+
+pkgname = warpd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e568893402cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer mattf <matheusfillipeag@gmail.com>
+
+pkgbase=warpd-git
+pkgname=warpd-git
+pkgver=0.9a
+pkgrel=1
+pkgdesc="A small X program which facilitates recursively warping the pointer to different quadrants on the screen. The program was inspired by the mousekeys feature of Kaleidoscope, the firmware for the Keyboardio"
+url="https://github.com/rvaiya/warpd"
+license=('GPLV3')
+arch=('x86_64')
+md5sums=('SKIP')
+depends=()
+conflicts=()
+makedepends=(git make libxinerama libxft libxfixes libxtst libx11)
+provides=(warpd)
+source=("git+$url")
+
+package() {
+ cd warp
+ make
+}
+
+
+
+#vim: syntax=sh