summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d214d10b6b1..d6b4664dd1fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = warpinator-git
pkgdesc = Share files across the LAN
- pkgver = 1.2.2.r0.gc066c5f
- pkgrel = 1
+ pkgver = 1.2.4.r0.g3a524da
+ pkgrel = 2
url = https://github.com/linuxmint/warpinator
arch = any
license = GPL3
@@ -18,6 +18,7 @@ pkgbase = warpinator-git
depends = python-protobuf
depends = python-pynacl
depends = python-setproctitle
+ depends = python-setuptools
depends = python-zeroconf
depends = python-xapp
depends = xapps
diff --git a/PKGBUILD b/PKGBUILD
index 9614bde375a3..0be96365ad96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Kyle Laker <kyle@laker.email>
pkgname=warpinator-git
-pkgver=1.2.2.r0.gc066c5f
-pkgrel=1
+pkgver=1.2.4.r0.g3a524da
+pkgrel=2
pkgdesc="Share files across the LAN"
arch=('any')
url="https://github.com/linuxmint/warpinator"
license=('GPL3')
depends=('gtk3' 'libnm' 'python-cryptography' 'python-gobject' 'python-grpcio'
'python-netaddr' 'python-netifaces' 'python-protobuf' 'python-pynacl'
- 'python-setproctitle' 'python-zeroconf' 'python-xapp' 'xapps')
+ 'python-setproctitle' 'python-setuptools' 'python-zeroconf' 'python-xapp' 'xapps')
makedepends=('git' 'meson' 'polkit')
optdepends=('ufw: Configure firewall rules')
provides=("${pkgname%-git}")
@@ -18,31 +18,31 @@ source=('git+https://github.com/linuxmint/warpinator.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
- # Fix hard-coded libexec dir
- sed -i 's/libexec/lib/g' \
- "bin/${pkgname%-git}.in" \
- "data/org.x.${pkgname%-git}.policy.in.in" \
- install-scripts/download_zeroconf.py
- sed -i 's/@libexecdir@/@libdir@/g' src/config.py.in
+ # Fix hard-coded libexec dir
+ sed -i 's/libexec/lib/g' \
+ "bin/${pkgname%-git}.in" \
+ "data/org.x.${pkgname%-git}.policy.in.in" \
+ install-scripts/download_zeroconf.py
+ sed -i 's/@libexecdir@/@libdir@/g' src/config.py.in
}
build() {
- arch-meson "${pkgname%-git}" build -Dbundle-zeroconf=false
- meson compile -C build
+ arch-meson "${pkgname%-git}" build -Dbundle-zeroconf=false
+ meson compile -C build
}
# No tests defined
#check() {
-# meson test -C build --print-errorlogs
+# meson test -C build --print-errorlogs
#}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}