summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE.md21
-rw-r--r--PKGBUILD6
3 files changed, 28 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cd20d29a624..86c265cf3141 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,13 @@ pkgbase = wasabi-wallet-bin
source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.0.5/WasabiLinux-1.0.5.tar.gz.asc
source = wasabi.desktop
source = wasabi.png
+ source = LICENSE.md
validpgpkeys = 21D7CA45565DBCCEBE45115DB4B72266C47E075E
sha256sums = c1d3ef22541a4565a9cc790daa90e550041d767cb9771abaea6399bb9a5d2f0c
sha256sums = SKIP
sha256sums = 4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee
sha256sums = 861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3
+ sha256sums = 986ee8b1139dbe8405801baf1081d075b53728fd5c57dd31885cf4ddbe5d8f68
pkgname = wasabi-wallet-bin
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..f6c12289ade3
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 zkSNACKs
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 8ebbc19789af..3104009b5ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,13 @@ source=(
"https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz.asc"
"wasabi.desktop"
"wasabi.png"
+ "LICENSE.md"
)
sha256sums=('c1d3ef22541a4565a9cc790daa90e550041d767cb9771abaea6399bb9a5d2f0c'
'SKIP'
'4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee'
- '861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3')
+ '861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3'
+ '986ee8b1139dbe8405801baf1081d075b53728fd5c57dd31885cf4ddbe5d8f68')
# Run gpg --keyserver pool.sks-keyservers.net --recv-keys B4B72266C47E075E
validpgpkeys=('21D7CA45565DBCCEBE45115DB4B72266C47E075E')
@@ -33,4 +35,6 @@ package() {
# Install desktop launcher.
install -Dm644 wasabi.desktop "${pkgdir}/usr/share/applications/wasabi.desktop"
install -Dm644 wasabi.png "${pkgdir}/usr/share/pixmaps/wasabi.png"
+
+ install -Dm644 "${srcdir}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}