summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD61
-rw-r--r--RELEASE_NOTES.md136
3 files changed, 175 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 751d40b27cc5..3b7c96ef363e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wasm-micro-runtime
pkgdesc = Standalone WebAssembly (WASM) runtime with small footprint
- pkgver = 1.2.2
+ pkgver = 1.2.3
pkgrel = 1
url = https://github.com/bytecodealliance/wasm-micro-runtime
changelog = RELEASE_NOTES.md
@@ -8,11 +8,12 @@ pkgbase = wasm-micro-runtime
license = Apache
makedepends = cmake
makedepends = llvm
+ makedepends = ninja
depends = glibc
depends = llvm-libs
provides = wasm-micro-runtime
conflicts = wasm-micro-runtime-git
- source = wasm-micro-runtime-1.2.2.tar.gz::https://github.com/bytecodealliance/wasm-micro-runtime/archive/WAMR-1.2.2.tar.gz
- sha512sums = 13b995ccca0ebc183df943a5fa47a8aa25361cca4081e8fa5316732979e89e4e289a6ff43955617f5fb271f31a3a9e511dec0815c53dd7c058eed958d0a2ac7d
+ source = https://github.com/bytecodealliance/wasm-micro-runtime/archive/WAMR-1.2.3.tar.gz
+ sha512sums = f2dc39c4a17ca2cb983086f1a63220c52d0b7cca23b7e4e5910b72cba8d827e877c98653504f9fc5bc05b6a23ec86ada39b18a998478779c127d2c1886927165
pkgname = wasm-micro-runtime
diff --git a/PKGBUILD b/PKGBUILD
index 1c4d7ac7fd0f..cb9e9b2587c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,39 @@
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=wasm-micro-runtime
-pkgver=1.2.2
+pkgver=1.2.3
pkgrel=1
pkgdesc="Standalone WebAssembly (WASM) runtime with small footprint"
arch=('x86_64')
url="https://github.com/bytecodealliance/wasm-micro-runtime"
license=('Apache')
depends=('glibc' 'llvm-libs')
-makedepends=('cmake' 'llvm')
+makedepends=('cmake' 'llvm' 'ninja')
provides=("wasm-micro-runtime")
conflicts=("wasm-micro-runtime-git")
changelog="RELEASE_NOTES.md"
-source=("$pkgname-$pkgver.tar.gz::$url/archive/WAMR-$pkgver.tar.gz")
-sha512sums=('13b995ccca0ebc183df943a5fa47a8aa25361cca4081e8fa5316732979e89e4e289a6ff43955617f5fb271f31a3a9e511dec0815c53dd7c058eed958d0a2ac7d')
+source=("$url/archive/WAMR-$pkgver.tar.gz")
+sha512sums=("f2dc39c4a17ca2cb983086f1a63220c52d0b7cca23b7e4e5910b72cba8d827e877c98653504f9fc5bc05b6a23ec86ada39b18a998478779c127d2c1886927165")
+
+prepare() {
+ sed -i 's/${LLVM_AVAILABLE_LIBS}/LLVM/g' "$pkgname-WAMR-$pkgver/product-mini/platforms/linux/CMakeLists.txt"
+}
build() {
- cmake \
- -B build \
- -S "$pkgname-WAMR-$pkgver/product-mini/platforms/linux" \
+ configure_arguments=" \
+ -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DLLVM_DIR=/usr/lib/cmake/llvm \
+ -DWAMR_BUILD_PLATFORM=linux \
+ -DWAMR_BUILD_TARGET=X86_64 \
+ -DWAMR_BUILD_INTERP=1 \
+ -DWAMR_BUILD_FAST_INTERP=1 \
+ -DWAMR_BUILD_AOT=1 \
+ -DWAMR_BUILD_JIT=1 \
+ -DWAMR_BUILD_FAST_JIT=1 \
+ -DWAMR_BUILD_LIBC_BUILTIN=1 \
+ -DWAMR_BUILD_LIBC_WASI=1 \
-DWAMR_BUILD_MULTI_MODULE=1 \
-DWAMR_BUILD_SHARED_MEMORY=1 \
-DWAMR_BUILD_BULK_MEMORY=1 \
@@ -33,33 +46,29 @@ build() {
-DWAMR_BUILD_TAIL_CALL=1 \
-DWAMR_BUILD_SIMD=1 \
-DWAMR_BUILD_REF_TYPES=1 \
- -Wno-dev
+ "
+
+ cmake \
+ -B build \
+ -S "$pkgname-WAMR-$pkgver/product-mini/platforms/linux" \
+ $configure_arguments
+
cmake \
-B build-lib \
-S "$pkgname-WAMR-$pkgver" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DWAMR_BUILD_MULTI_MODULE=1 \
- -DWAMR_BUILD_SHARED_MEMORY=1 \
- -DWAMR_BUILD_BULK_MEMORY=1 \
- -DWAMR_BUILD_THREAD_MGR=1 \
- -DWAMR_BUILD_LIB_PTHREAD=1 \
- -DWAMR_BUILD_LIB_PTHREAD_SEMAPHORE=1 \
- -DWAMR_BUILD_LIB_WASI_THREADS=1 \
- -DWAMR_BUILD_TAIL_CALL=1 \
- -DWAMR_BUILD_SIMD=1 \
- -DWAMR_BUILD_REF_TYPES=1 \
- -Wno-dev
+ $configure_arguments
+
cmake \
-B build-compiler \
-S "$pkgname-WAMR-$pkgver/wamr-compiler" \
+ -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DWAMR_BUILD_WITH_CUSTOM_LLVM=1 \
- -Wno-dev
- cmake --build build -j8
- cmake --build build-lib -j8
- cmake --build build-compiler -j8
+ -DWAMR_BUILD_WITH_CUSTOM_LLVM=1
+
+ cmake --build build
+ cmake --build build-lib
+ cmake --build build-compiler
}
package() {
diff --git a/RELEASE_NOTES.md b/RELEASE_NOTES.md
index d6308ce671ec..5c7f598daba2 100644
--- a/RELEASE_NOTES.md
+++ b/RELEASE_NOTES.md
@@ -1,3 +1,139 @@
+## WAMR-1.2.3
+
+### Breaking Changes
+- Increase default native stack size (#2332)
+
+### New Features
+- Implement the segue optimization for LLVM AOT/JIT (#2230)
+- Implement AOT static PGO (#2243)
+- Enable static PGO for Linux SGX (#2270)
+- Add Rust Formatters to Debugger (Vector, Map etc.) (#2219)
+
+### Bug Fixes
+- The Python language-binding needs python>=3.9 (#2228)
+- aot_compile_op_call: Remove a wrong optimization (#2233)
+- Fix typo in samples/ref-types (#2236)
+- Update thread proposal ignore cases (#2246)
+- Disable writting GS register on linux-sgx platform (#2255)
+- Fix compile error of wamrc with llvm-13/llvm-14 (#2261)
+- aot/jit: Set module layout (#2260)
+- Fix build error with LLVM 16 (#2259)
+- spec-test-script: Disable conversions.wast on i386 (#2269)
+- Fix a heap corruption bug in ems realloc (#2279)
+- Fix fast-interp issue of LAST_OP_OUTPUT_I32/64 check (#2295)
+- Fix wamrc build issues with LLVM 13 and LLVM 16 (#2313)
+- aot: Move stack_sizes table to a dedicated section (#2317)
+- product-mini/platforms/linux: Mark vmlib POSITION_INDEPENDENT_CODE (#2323)
+- aot: Avoid possible relocations around "stack_sizes" for XIP mode (#2322)
+- Avoid switch lowering to lookup tables for XIP (#2339)
+- Fix typo in zephyr's Dockerfile.old (#2354)
+- Fix typo (dwarf) in the codebase (#2367)
+- Implement suspend flags as atomic variable (#2361)
+- Fix llvm jit failed to lookup aot_stack_sizes symbol issue (#2384)
+- Fix some check issues on table operations (#2392)
+- Fix ExpandMemoryOpPass doesn't work properly (#2399)
+- Fix non-builtin BH_ATOMIC_32_FETCH_OR and BH_ATOMIC_32_FETCH_AND (#2400)
+- Fix wasi-sockets tests (#2389)
+- Fix result arity check on select_t opcode (#2406)
+- Re-organize intrinsics in aot_reloc_riscv.c to fix some FPU issues (#2414)
+- Fix lib-pthread issues (#2410)
+- Fix typo in test_wamr.sh (#2421)
+- Fix memory sharing (#2415)
+- wasm_export.h: Fix struct wasm_val_t (#2435)
+- Fix typos in wamrc print_help() (#2442)
+- iwasm: Fix native lib cleanup after error occurs (#2443)
+- Correct --heap-size option in messages (#2458)
+- wasm_instantiate: Fix a potential integer overflow issue (#2459)
+- Fix windows link error and clear windows warnings (#2463)
+- aot: Disable musttail for mips (#2457)
+- Fix opcode overwrite issue in fast interp (#2476)
+- wamrc: Fix windows relocation to `aot_func_internal#n` (#2474)
+- Fix windows AOT hw bound check (#2475)
+- Fix typo in aot_emit_aot_file.c (#2478)
+
+### Enhancements
+- A few changes related to WAMRC_LLC_COMPILER (#2218)
+- Enhance linux-sgx CI (#2102)
+- Add asan and ubsan to WAMR CI (#2161)
+- Update doc on WAMR_DISABLE_HW_BOUND_CHECK 32-bit (#2262)
+- wamrc: Add an incompatibility note in the help message (#2276)
+- Add cmake variable to disable writing gs register (#2284)
+- Make hmu_tree_node 4 byte aligned to reduce compiler warning (#2268)
+- Appease unused warning on min_uint64 (#2277)
+- Fix format warning by PRIu32 in [wasm|aot] dump call stack (#2251)
+- Fix a compile warning due to missing include (#2293)
+- Fix dockerfile linter warnings (#2291)
+- Enable windows x86-32 AOT relocations (#2285)
+- wamr-ide: Add vscode extension tests (#2292)
+- AOT/JIT native stack bound check improvement (#2244)
+- Add retries to flaky step in nightly run CI (#2306)
+- Use system libuv if available (#1861)
+- wasi-nn: Simplify cmake and headers' location (#2308)
+- wasi-nn: Improve tests paths for local dev (#2309)
+- aot: Implement a few more relocation types for riscv (#2318)
+- wasi-nn: Add support of wasi-nn as shared lib (#2310)
+- Add a few more assertions on structures to which aot abi is sensitive (#2326)
+- Fix sanitizer errors in posix socket (#2331)
+- Add "--xip" option for wamrc (#2336)
+- Add "--enable-llvm-passes=<passes>" option to wamrc (#2335)
+- Make memory access boundary check behavior configurable (#2289)
+- Migrate ExpandMemoryOpPass to llvm new pass manager (#2334)
+- Allow defining hints without exact socket type or address family (#2337)
+- wamrc: Warn on text relocations for XIP (#2340)
+- Add scripts to validate lldb source debugger (#2150)
+- Add docker file to fix Zephy ESP32 linking issue (#2314)
+- Add "--native-lib=<lib>" option to wamrc (#2342)
+- Fix unused warnings on disable_bounds_checks (#2347)
+- Add "--enable-builtin-intrinsics=<flags>" option to wamrc (#2341)
+- nuttx: Add a kconfig for wasi-threads (#2343)
+- iwasm: Disable app heap by default if wasi is enabled (#2346)
+- Fix some static scan issues (#2362)
+- Bring up WAMR on esp32-s3 device (#2348)
+- ESP-IDF platform supports to load AOT to PSRAM and run it (#2385)
+- Add hadolint CI for Dockerfile linting (#2387)
+- Move generic parts of wasm_suspend_flags.h to bh_atomic.h (#2393)
+- bh_atomic.h: Add comments (#2398)
+- bh_atomic.h: Add BH_ATOMIC_32_FETCH_ADD/BH_ATOMIC_32_FETCH_SUB (#2408)
+- Update libuv version to v1.46.0 (#2405)
+- Remove a few unused functions (#2409)
+- Add initial stress test (#2364)
+- Move wasm_runtime_destroy_wasi and wasi_nn_destroy calls together (#2418)
+- embed_wamr.md: Improvements about threads (#2420)
+- Add runtime inited checks in Enclave command handlings to improve security (#2416)
+- Add some relocation symbols for xtensa target (#2422)
+- Remove unnecessary and extra zero length check in mem functions' macro (#2428)
+- Introduce WASMModuleInstanceExtraCommon (#2429)
+- Strip static and shared libraries of iwasm to reduce the binary size (#2431)
+- Auto-check wrgsbase in cmake script (#2437)
+- iwasm: call native lib init/deinit if exists (#2439)
+- wasi-nn: Support uint8 quantized networks (#2433)
+- Implement `wasm_externref_objdel` and `wasm_externref_set_cleanup` (#2455)
+- wasi-nn: Improve TPU support (#2447)
+- wamr-python: Enable debugging WASM and grant dir access (#2449)
+- Build wasi-libc from source in WAMR CI (#2465)
+- wamrc: More friendly to print help info (#2451)
+- Add another wamr test (#2411)
+- Fix issues reported by Coverity and clear windows warnings (#2467)
+- Clone the input binary during wasm_module_validate (#2483)
+
+### Others
+- Nuttx CI: Ignore the expired certificate for riscv gcc toolchain (#2222)
+- core/iwasm/compilation: constify a bit (#2223)
+- Bump requests from 2.28.2 to 2.31.0 in /build-scripts (#2229)
+- dwarf_extractor: Constify a bit (#2278)
+- AOTFuncContext: Remove a stale comment (#2283)
+- Add performance tunning document (#2286)
+- Reduce CI jobs number (#2296)
+- CI: Update used node version to 16 (#2303)
+- Update Docker image for latest version of external libraries & tools (#2374)
+- Upgrade cJSON version to v1.7.16 (#2404)
+- Upgrade XNNPACK workload (#2394)
+- Build more benchmarks in workload XNNPACK (#2417)
+- Upgrade SGX-RA integration for 0.1.2 and Ubuntu 20.04 (#2454)
+- Add sample pre-commit hook (#2470)
+
+---
+
## WAMR-1.2.2
### Breaking Changes