summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2721c5bd65d2..2672a93626c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,15 +2,15 @@ pkgbase = wasmtime
pkgdesc = Standalone JIT-style runtime for WebAssembly, using Cranelift
pkgver = 0.8.0
pkgrel = 1
- url = https://github.com/CraneStation/wasmtime
+ url = https://github.com/bytecodealliance/wasmtime
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
license = APACHE2
makedepends = cargo
- source = https://github.com/CraneStation/wasmtime/archive/v0.8.0.tar.gz
- sha384sums = 89005894df1d1a43a75636ed50637c8a5b9d22b17f67e4a3d9c26188d32fd76d7e10fbc3af7826648c5306318b670810
+ source = wasmtime-0.8.0::git+https://github.com/bytecodealliance/wasmtime.git#tag=v0.8.0
+ sha384sums = SKIP
pkgname = wasmtime
diff --git a/PKGBUILD b/PKGBUILD
index c70fd106c8ba..30cc9c665705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@ pkgver=0.8.0
pkgrel=1
pkgdesc="Standalone JIT-style runtime for WebAssembly, using Cranelift"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/CraneStation/wasmtime"
+url="https://github.com/bytecodealliance/wasmtime"
license=('APACHE2')
depends=()
makedepends=('cargo')
options=()
-source=("https://github.com/CraneStation/wasmtime/archive/v${pkgver}.tar.gz")
-sha384sums=('89005894df1d1a43a75636ed50637c8a5b9d22b17f67e4a3d9c26188d32fd76d7e10fbc3af7826648c5306318b670810')
+source=("${pkgname}-${pkgver}::git+https://github.com/bytecodealliance/wasmtime.git#tag=v${pkgver}")
+sha384sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ git submodule update --init --recursive
+}
build() {
cd "$srcdir/$pkgname-$pkgver"