summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD9
-rw-r--r--watchghost.install5
2 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68095ce3d6ac..d843b43d3283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
name=watchghost
pkgname=$name-git
-pkgver=0.1.0.git_99.0005a9e
+pkgver=0.1.0.git_110.600f606
pkgrel=1
+epoch=1
pkgdesc="Your invisible but loud monitoring pet"
arch=('any')
url='https://gitlab.com/localg-host/watchghost/'
@@ -13,6 +14,12 @@ makedepends=('python-setuptools')
source=('git+https://gitlab.com/localg-host/watchghost.git')
sha256sums=('SKIP')
install=watchghost.install
+backup=(
+ 'etc/watchghost/watchers'
+ 'etc/watchghost/loggers'
+ 'etc/watchghost/servers'
+ 'etc/watchghost/groups'
+)
pkgver(){
cd $srcdir/$name
diff --git a/watchghost.install b/watchghost.install
index f03d211ce3d3..fce554dae603 100644
--- a/watchghost.install
+++ b/watchghost.install
@@ -6,6 +6,11 @@ post_install() {
post_upgrade() {
systemd-sysusers watchghost.conf
systemctl daemon-reload
+ systemctl is-active watchghost
+ active=$?
+ if [ $active -eq 0 ] ; then
+ systemctl restart watchghost
+ fi
}
pre_remove() {