summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d66d74db9362
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = watchghost-git
+ pkgdesc = Your invisible but loud monitoring pet
+ pkgver = 0.1.0.git_99.0005a9e
+ pkgrel = 1
+ url = https://gitlab.com/localg-host/watchghost/
+ arch = any
+ license = AGPLv3
+ makedepends = python-setuptools
+ depends = python-tornado
+ depends = python-aioftp
+ source = git+https://gitlab.com/localg-host/watchghost.git
+ sha256sums = SKIP
+
+pkgname = watchghost-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87b64657ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e80d92258ec5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Arthur Vuillard <arthur@hashbang.fr>
+
+name=watchghost
+pkgname=$name-git
+pkgver=0.1.0.git_99.0005a9e
+pkgrel=1
+pkgdesc="Your invisible but loud monitoring pet"
+arch=('any')
+url='https://gitlab.com/localg-host/watchghost/'
+license=('AGPLv3')
+depends=('python-tornado' 'python-aioftp')
+makedepends=('python-setuptools')
+source=('git+https://gitlab.com/localg-host/watchghost.git')
+
+pkgver(){
+ cd $srcdir/$name
+
+ echo 0.1.0.git_$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/$name"
+ python3 setup.py build
+ python3 setup.py install --prefix=/usr --root="${pkgdir}"
+}
+
+sha256sums=('SKIP')
+