summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e22c0154456b..6e7664ef7928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Mon Nov 14 10:11:43 UTC 2016
+# Sun Jul 9 15:13:48 UTC 2017
pkgbase = watchman
pkgdesc = An inotify-based file watching and job triggering command line utility
pkgver = 4.7.0
- pkgrel = 0
+ pkgrel = 1
url = https://facebook.github.io/watchman/
install = watchman.install
- arch = x86_64
arch = i686
+ arch = x86_64
license = Apache
makedepends = glibc
depends = pcre
diff --git a/PKGBUILD b/PKGBUILD
index de29bcdda98a..0adf169049fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,35 @@
-# Maintainer: José Luis Lafuente <jl@lafuente.me>
-# Original maintainer: Michael Louis Thaler <michael.louis.thaler@gmail.com>
+# Maintainer: Jean Lucas <jean@4ray.co>
+# Contributor: José Luis Lafuente <jl@lafuente.me>
+# Contributor: Michael Louis Thaler <michael.louis.thaler@gmail.com>
+
pkgname=watchman
pkgver=4.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="An inotify-based file watching and job triggering command line utility"
url="https://facebook.github.io/watchman/"
-arch=('x86_64' 'i686')
+arch=('i686' 'x86_64')
license=('Apache')
depends=('pcre')
-optdepends=()
makedepends=('glibc')
-conflicts=()
-replaces=()
-backup=()
install=$pkgname.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebook/watchman/archive/v${pkgver}.tar.gz"
- "${pkgname}.tmpfiles")
-
+source=("$pkgname-$pkgver.tar.gz::https://github.com/facebook/watchman/archive/v$pkgver.tar.gz"
+ "$pkgname.tmpfiles")
sha256sums=('77c7174c59d6be5e17382e414db4907a298ca187747c7fcb2ceb44da3962c6bf'
'2b061865e10578a0477b9c7991a00594bc839c846b98896e93c75743dbf6a379')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $srcdir/$pkgname-$pkgver
./autogen.sh
- ./configure --prefix= --exec-prefix=/usr --localstatedir=/run/${pkgname} --without-python
+ ./configure --prefix= --exec-prefix=/usr --localstatedir=/run/$pkgname --without-python --enable-lenient
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # Docs only online, see https://github.com/facebook/watchman/issues/30
- make DESTDIR="${pkgdir}" install-binPROGRAMS
- install -dm 755 "${pkgdir}"/usr/lib/tmpfiles.d
- install -m 644 "../${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ cd $srcdir/$pkgname-$pkgver
+ # Docs available online only; see https://github.com/facebook/watchman/issues/30
+ make DESTDIR=$pkgdir install-binPROGRAMS
+
+ install -Dm 644 ../$pkgname.tmpfiles $pkgdir/usr/lib/tmpfiles.d/$pkgname.conf
}
# vim:set ts=2 sw=2 et: