summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
-rw-r--r--mozconfig2
3 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 169d69fe635a..543a4ba0ddc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waterfox-classic-git
pkgdesc = 64-Bit optimized Firefox fork, no data collection, allows unsigned extensions
- pkgver = 56.5+4b21280e2030
+ pkgver = 2021.04.2.r23.g04a796c8254f
pkgrel = 1
url = https://www.waterfoxproject.org/
install = waterfox-classic.install
@@ -39,7 +39,7 @@ pkgbase = waterfox-classic-git
depends = hunspell
depends = sqlite
depends = ttf-font
- provides = waterfox=56.5+4b21280e2030
+ provides = waterfox=2021.04.2.r23.g04a796c8254f
conflicts = waterfox
conflicts = waterfox-bin
conflicts = waterfox-git
@@ -51,7 +51,7 @@ pkgbase = waterfox-classic-git
source = waterfox-classic.desktop
source = vendor.js
sha512sums = SKIP
- sha512sums = e2c5eb295022284e7b1193e6057e0125bf010fc34076e7641da4566b2209160f5cb3585dd0424cbc0417093c3e544d47777ed58b1894eb4dc61267bd3807ae6c
+ sha512sums = 52a6a7106a12aa3d3e4b250922605bfa5ac1c3774ed97816e656266483be7d09901278fc372c172f0ab961bfece3d9bf71e3ce444e0e6804eb9f36cf36d54578
sha512sums = de2ae1fa6d515da03026277ff30ee23935922ed26baa296334fbc088da9e924f0755dd123150c26a3b272f03198d0b283371852e0e1b9f3f6ff80cbbf1846dee
sha512sums = d927e5e882115c780aa0d45034cb1652eaa191d95c15013639f9172ae734245caae070018465d73fdf86a01601d08c9e65f28468621422d799fe8451e6175cb7
diff --git a/PKGBUILD b/PKGBUILD
index eaf1da212f62..1c06336af72b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: <jnbek1972 at gmail dot com>
# Contributor: <raku at rakutiki.tv>
pkgname=waterfox-classic-git
-pkgver=56.5+4b21280e2030
+pkgver=2021.04.2.r23.g04a796c8254f
pkgrel=1
pkgdesc="64-Bit optimized Firefox fork, no data collection, allows unsigned extensions"
arch=('i686' 'x86_64')
@@ -22,36 +22,30 @@ source=(git://github.com/MrAlex94/Waterfox#branch=classic
mozconfig
waterfox-classic.desktop
vendor.js)
-sha512sums=('SKIP'
- 'e2c5eb295022284e7b1193e6057e0125bf010fc34076e7641da4566b2209160f5cb3585dd0424cbc0417093c3e544d47777ed58b1894eb4dc61267bd3807ae6c'
- 'de2ae1fa6d515da03026277ff30ee23935922ed26baa296334fbc088da9e924f0755dd123150c26a3b272f03198d0b283371852e0e1b9f3f6ff80cbbf1846dee'
- 'd927e5e882115c780aa0d45034cb1652eaa191d95c15013639f9172ae734245caae070018465d73fdf86a01601d08c9e65f28468621422d799fe8451e6175cb7')
+sha512sums=('SKIP' '52a6a7106a12aa3d3e4b250922605bfa5ac1c3774ed97816e656266483be7d09901278fc372c172f0ab961bfece3d9bf71e3ce444e0e6804eb9f36cf36d54578'
+'de2ae1fa6d515da03026277ff30ee23935922ed26baa296334fbc088da9e924f0755dd123150c26a3b272f03198d0b283371852e0e1b9f3f6ff80cbbf1846dee'
+'d927e5e882115c780aa0d45034cb1652eaa191d95c15013639f9172ae734245caae070018465d73fdf86a01601d08c9e65f28468621422d799fe8451e6175cb7')
# don't compress the package - we're just going to uncompress during install in a moment
PKGEXT='.pkg.tar'
pkgver() {
cd Waterfox
- echo $(cat browser/config/version.txt)"+"$(git rev-parse --short HEAD)
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd Waterfox
-
cp ../mozconfig .mozconfig
-
# lcrmf breaks stuff
sed -i 's/ \-lcrmf//g' "${srcdir}/Waterfox/old-configure.in"
-
mkdir -p "$srcdir/path"
}
build() {
cd Waterfox
-
export PATH="$srcdir/path:$PATH"
export PYTHON="/usr/bin/python2"
-
make -j -f client.mk build
}
@@ -59,14 +53,11 @@ package() {
cd Waterfox
mkdir -p "$pkgdir"
DESTDIR="$pkgdir" make -f client.mk install
-
install -Dm644 ../vendor.js "$pkgdir/opt/waterfox-classic/browser/defaults/preferences/vendor.js"
-
for i in 16 32 48; do
install -Dm644 "$srcdir/Waterfox/obj-x86_64-pc-linux-gnu/dist/waterfox-classic/browser/chrome/icons/default/default$i.png" \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/waterfox-classic.png"
done
-
install -Dm644 "$srcdir/Waterfox/obj-x86_64-pc-linux-gnu/dist/waterfox-classic/browser/chrome/icons/default/default128.png" \
"$pkgdir/usr/share/icons/hicolor/64x64/apps/waterfox-classic.png"
install -Dm644 "$srcdir/Waterfox/obj-x86_64-pc-linux-gnu/dist/waterfox-classic/browser/chrome/icons/default/default128.png" \
@@ -75,7 +66,6 @@ package() {
"$pkgdir/usr/share/icons/hicolor/192x192/apps/waterfox-classic.png"
install -Dm644 browser/branding/unofficial/content/about-logo@2x.png \
"$pkgdir/usr/share/icons/hicolor/384x384/apps/waterfox-classic.png"
-
install -Dm644 ../waterfox-classic.desktop \
"$pkgdir/usr/share/applications/waterfox-classic.desktop"
diff --git a/mozconfig b/mozconfig
index 5f761d4e7df8..0209d7328a89 100644
--- a/mozconfig
+++ b/mozconfig
@@ -11,7 +11,7 @@ export CFLAGS=""
# a bit of extra hardening and optimization, edit to your tastes
export LDFLAGS="-Wl,-O3,--no-omagic,--sort-common,--as-needed,--relax,-z,norelro,-z,combreloc,-z,global,-z,noexecstack,-z,now"
-ac_add_options --enable-optimize="-O3 -march=native -mtune=native -fcolor-diagnostics -w -fstack-protector-strong -fcf-protection=full -Wp,-D_GLIBCXX_ASSERTIONS -fno-plt"
+ac_add_options --enable-optimize
ac_add_options --target=x86_64-pc-linux-gnu
mk_add_options AUTOCLOBBER=1