summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0b179afb4f5..4ed15fa31644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = waterfox-kde
pkgdesc = Free, open and private browser with openSUSE's patches for better integration with KDE
pkgver = 56.2.11
- pkgrel = 2
+ pkgrel = 3
url = https://www.waterfox.net/
arch = x86_64
license = MPL
@@ -60,6 +60,8 @@ pkgbase = waterfox-kde
source = dont-statically-link-libstdc++.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/dont-statically-link-libstdc%2B%2B.patch
source = pgo_fix_missing_kdejs.patch
source = UnsortedError.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/UnsortedError.patch
+ source = rust-simd.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/rust-simd.patch
+ source = app_units.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/app_units.patch
sha256sums = SKIP
sha256sums = 6e9ec5f9c6fc5b191f9dec85b82d58eb2a51577b989bc7852e6b254d56ff13e8
sha256sums = d86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd
@@ -72,6 +74,8 @@ pkgbase = waterfox-kde
sha256sums = 877bc1f0e768d96118bb739725e590467773dd897c31263099e52b8d7aaaa4c8
sha256sums = bf6743660623b7c9a43b94edc8acbcade07aa222ff2102a2808809df333ebe8e
sha256sums = 3b20230c42ac68cdb751c3bd7758a1a45006e00aec8558c33c96d8c4bebbd47f
+ sha256sums = b0623cffd2d51347b7955e0daef62f1c74955f6a31630eedbfb10c601c87d34b
+ sha256sums = 03130373536a86b1d623a28eb99c9506643eb0bd7c2b7dfe2e38abe0abfb4732
pkgname = waterfox-kde
diff --git a/PKGBUILD b/PKGBUILD
index bce6c1de6267..8e98ed08dbf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=waterfox-kde
pkgver=56.2.11
-pkgrel=2
+pkgrel=3
pkgdesc="Free, open and private browser with openSUSE's patches for better integration with KDE"
arch=('x86_64')
license=('MPL')
@@ -36,7 +36,9 @@ source=("git+https://github.com/MrAlex94/Waterfox.git#commit=$_commit"
"waterfox-kde-56.2.10.1.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/waterfox-kde-56.2.10.1.patch"
"dont-statically-link-libstdc++.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/dont-statically-link-libstdc%2B%2B.patch"
pgo_fix_missing_kdejs.patch
- "UnsortedError.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/UnsortedError.patch")
+ "UnsortedError.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/UnsortedError.patch"
+ "rust-simd.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/rust-simd.patch"
+ "app_units.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/app_units.patch")
sha256sums=('SKIP'
'6e9ec5f9c6fc5b191f9dec85b82d58eb2a51577b989bc7852e6b254d56ff13e8'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
@@ -48,7 +50,9 @@ sha256sums=('SKIP'
'b55833542edf8cad2b73cf36dac6c667e588dcf79a99b570c5eca645698b80f7'
'877bc1f0e768d96118bb739725e590467773dd897c31263099e52b8d7aaaa4c8'
'bf6743660623b7c9a43b94edc8acbcade07aa222ff2102a2808809df333ebe8e'
- '3b20230c42ac68cdb751c3bd7758a1a45006e00aec8558c33c96d8c4bebbd47f')
+ '3b20230c42ac68cdb751c3bd7758a1a45006e00aec8558c33c96d8c4bebbd47f'
+ 'b0623cffd2d51347b7955e0daef62f1c74955f6a31630eedbfb10c601c87d34b'
+ '03130373536a86b1d623a28eb99c9506643eb0bd7c2b7dfe2e38abe0abfb4732')
prepare() {
mkdir path
@@ -71,6 +75,12 @@ prepare() {
patch -Np1 -i ../UnsortedError.patch
+ # Make rust-simd compatible with Rust 1.32+
+ patch -Np1 -i ../rust-simd.patch
+
+ # Make app_units crate compatible with Rust 1.35
+ patch -Np1 -i ../app_units.patch
+
cat >.mozconfig <<END
export CC=clang
export CXX=clang++
@@ -141,16 +151,16 @@ ac_add_options --disable-webrtc
# If you want to have gamepad support, comment this line:
ac_add_options --disable-gamepad
-ac_add_options --disable-stylo
+#ac_add_options --disable-stylo
# Enable wanted features
ac_add_options --enable-jemalloc
-#ac_add_options --enable-stylo=build
+ac_add_options --enable-stylo=build
ac_add_options --with-pthreads
ac_add_options --enable-strip
ac_add_options --enable-startup-notification
ac_add_options --enable-release
-#ac_add_options --enable-rust-simd
+ac_add_options --enable-rust-simd
ac_add_options --enable-application=browser
ac_add_options --enable-eme=widevine