summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96681a6f4183..8be7fea2e79e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 2 20:14:20 UTC 2017
+# Mon Jan 2 22:09:33 UTC 2017
pkgbase = way-cooler-git
pkgdesc = Customizeable Wayland compositor written in Rust
pkgver = v0.4.1.r3.gb08b575
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/Immington-Industries/way-cooler
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a89a946aa41f..c5e9549af623 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
pkgname=way-cooler-git
pkgver=v0.4.1.r3.gb08b575
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Customizeable Wayland compositor written in Rust"
arch=('i686' 'x86_64')
@@ -23,6 +23,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ rm Cargo.lock
+}
+
build() {
cd "$srcdir/$pkgname"
cargo build --release