summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--way-displays-1_1_0.install32
-rw-r--r--way-displays-1_2.install (renamed from way-displays-1_2_0.install)18
4 files changed, 18 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fc158482d53..fafb406935c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = way-displays
pkgdesc = way-displays: Auto Manage Your Wayland Displays
- pkgver = 1.2.0
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/alex-courtis/way-displays
- install = way-displays-1_2_0.install
+ install = way-displays-1_2.install
arch = x86_64
license = MIT
makedepends = git
@@ -13,7 +13,7 @@ pkgbase = way-displays
depends = wlroots
depends = libinput
depends = yaml-cpp
- source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.2.0.tar.gz
- sha256sums = f1d651c1e26de288594dd19e81f09318fec0aedc5b9d04e31cec6251b8692804
+ source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.2.1.tar.gz
+ sha256sums = a6416e2207a5e5ddf747cc4cfef6c4b37ebe37aa6684ef6e47ef1d274e747949
pkgname = way-displays
diff --git a/PKGBUILD b/PKGBUILD
index 98991a3f2c3d..75c910ebbed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Courtis <alex@courtis.org>
pkgname=way-displays
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=1
pkgdesc="way-displays: Auto Manage Your Wayland Displays"
arch=('x86_64')
@@ -8,9 +8,9 @@ url="https://github.com/alex-courtis/way-displays"
license=('MIT')
depends=('wayland' 'wlroots' 'libinput' 'yaml-cpp')
makedepends=('git' 'make' 'gcc')
-source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.2.0.tar.gz")
-sha256sums=('f1d651c1e26de288594dd19e81f09318fec0aedc5b9d04e31cec6251b8692804')
-install=way-displays-1_2_0.install
+source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.2.1.tar.gz")
+sha256sums=('a6416e2207a5e5ddf747cc4cfef6c4b37ebe37aa6684ef6e47ef1d274e747949')
+install=way-displays-1_2.install
build() {
cd "$pkgname-$pkgver"
diff --git a/way-displays-1_1_0.install b/way-displays-1_1_0.install
deleted file mode 100644
index da9b16cac8d9..000000000000
--- a/way-displays-1_1_0.install
+++ /dev/null
@@ -1,32 +0,0 @@
-# Colored makepkg-like functions
-msg_blue() {
- printf "${blue}==>${bold} $1${all_off}\n"
-}
-
-note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-red="${bold}$(tput setaf 1)"
-blue="${bold}$(tput setaf 4)"
-yellow="${bold}$(tput setaf 3)"
-
-post_install() {
- note "1.1.0 New Feature: arrange and align displays."
- note ""
- note "Optional cfg.yaml additions:"
- note "${all_off}# Arrange displays in a ROW (default, left to right) or a COLUMN (top to bottom)"
- note "${red}ARRANGE${all_off}: ${bold}ROW"
- note "${all_off}# Align ROWs at the TOP (default), MIDDLE or BOTTOM"
- note "${all_off}# Align COLUMNs at the LEFT (default), MIDDLE or RIGHT"
- note "${red}ALIGN${all_off}: ${bold}TOP"
- note ""
- note "For full details see https://github.com/alex-courtis/way-displays and /etc/way-displays/cfg.yaml"
-}
-
-post_upgrade() {
- post_install
-}
-
diff --git a/way-displays-1_2_0.install b/way-displays-1_2.install
index 1623fafca2c2..55ee458c4321 100644
--- a/way-displays-1_2_0.install
+++ b/way-displays-1_2.install
@@ -1,10 +1,6 @@
# Colored makepkg-like functions
-msg_blue() {
- printf "${blue}==>${bold} $1${all_off}\n"
-}
-
note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+ printf "${blue}==>${yellow} NOTE:${all_off} ${1}\n"
}
all_off="$(tput sgr0)"
@@ -15,16 +11,22 @@ yellow="${bold}$(tput setaf 3)"
blue="${bold}$(tput setaf 4)"
post_install() {
- note "1.2.0 New Feature #10 Maximum Preferred Refresh"
+ note ""
+ note "${yellow}1.2.0 New Feature #10 Maximum Preferred Refresh${all_off}"
note ""
note "Optional cfg.yaml additions:"
note ""
- note "${all_off}# Use the maximum refresh rate for resolution of the preferred mode."
- note "${all_off}# Warning: this may result in an unusable display."
+ note "# Use the maximum refresh rate for resolution of the preferred mode."
+ note "# Warning: this may result in an unusable display."
note "${red}MAX_PREFERRED_REFRESH${all_off}:"
note "${yellow} - ${green}'HDMI-1'${all_off}"
note ""
note "For full details see https://github.com/alex-courtis/way-displays and /etc/way-displays/cfg.yaml"
+ note ""
+ note "${yellow}1.2.1${all_off}"
+ note "- Bug #12 handle rotated displays"
+ note "- Bug #11 allow retries after config update during a change"
+ note ""
}
post_upgrade() {