summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD72
-rw-r--r--meson.build.patch13
3 files changed, 78 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fe7197785bc..52c0b6061786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,45 @@
pkgbase = waybar-git
pkgdesc = Highly customizable Wayland bar for Sway and Wlroots based compositors (GIT)
- pkgver = r636.67593b8
+ pkgver = r2429.09142fa3
pkgrel = 1
url = https://github.com/Alexays/Waybar/
arch = x86_64
license = MIT
- makedepends = meson
makedepends = git
+ makedepends = cmake
+ makedepends = catch2
+ makedepends = meson
+ makedepends = scdoc
+ makedepends = wayland-protocols
depends = gtkmm3
+ depends = libjsoncpp.so
+ depends = libsigc++
depends = fmt
- depends = jsoncpp
- depends = libinput
- depends = libnl>=3.0
- depends = libsigc++>=2.0
+ depends = jack
+ depends = libjack.so
depends = wayland
- depends = libdbusmenu-gtk3
- depends = libappindicator-gtk3
+ depends = libdate-tz.so
+ depends = libspdlog.so
+ depends = gtk-layer-shell
+ depends = libupower-glib.so
+ depends = upower
+ depends = libevdev
+ depends = libinput
depends = libpulse
- optdepends = sway: Sway modules support
- optdepends = libmpdclient: Mpd module support
+ depends = libnl
+ depends = libappindicator-gtk3
+ depends = libdbusmenu-gtk3
+ depends = libmpdclient
+ depends = libsndio.so
+ depends = libxkbcommon
+ depends = libwireplumber
+ depends = playerctl
optdepends = otf-font-awesome: Icons in the default configuration
provides = waybar
conflicts = waybar
- source = waybar-git::git://github.com/Alexays/Waybar
- source = meson.build.patch
+ backup = etc/xdg/waybar/config
+ backup = etc/xdg/waybar/style.css
+ source = waybar-git::git+https://github.com/Alexays/Waybar
sha1sums = SKIP
- sha1sums = f4984a4a4044bd04bebee584d5e5801d0ae31760
pkgname = waybar-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d0530e3b8e5a..1e23fceb97b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexis Rouillard <contact@arouillard.fr>
pkgname=waybar-git
-pkgver=r636.67593b8
+pkgver=r2429.09142fa3
pkgrel=1
pkgdesc='Highly customizable Wayland bar for Sway and Wlroots based compositors (GIT)'
arch=('x86_64')
@@ -9,27 +9,49 @@ url='https://github.com/Alexays/Waybar/'
license=('MIT')
provides=('waybar')
conflicts=('waybar')
-depends=('gtkmm3'
- 'fmt'
- 'jsoncpp'
- 'libinput'
- 'libnl>=3.0'
- 'libsigc++>=2.0'
- 'wayland'
- 'libdbusmenu-gtk3'
- 'libappindicator-gtk3'
- 'libpulse')
-makedepends=('meson'
- 'git')
-optdepends=('sway: Sway modules support'
- 'libmpdclient: Mpd module support'
- 'otf-font-awesome: Icons in the default configuration')
+depends=(
+ 'gtkmm3'
+ 'libjsoncpp.so'
+ 'libsigc++'
+ 'fmt'
+ 'jack' 'libjack.so'
+ 'wayland'
+ 'libdate-tz.so'
+ 'libspdlog.so'
+ 'gtk-layer-shell'
+ 'libupower-glib.so'
+ 'upower'
+ 'libevdev'
+ 'libinput'
+ 'libpulse'
+ 'libnl'
+ 'libappindicator-gtk3'
+ 'libdbusmenu-gtk3'
+ 'libmpdclient'
+ 'libsndio.so'
+ 'libxkbcommon'
+ 'libwireplumber'
+ 'playerctl'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'catch2'
+ 'meson'
+ 'scdoc' # For generating manpages
+ 'wayland-protocols'
+)
+backup=(
+ etc/xdg/waybar/config
+ etc/xdg/waybar/style.css
+)
+optdepends=(
+ 'otf-font-awesome: Icons in the default configuration'
+)
-source=("${pkgname}::git://github.com/Alexays/Waybar"
- 'meson.build.patch')
+source=("${pkgname}::git+https://github.com/Alexays/Waybar")
-sha1sums=('SKIP'
- 'f4984a4a4044bd04bebee584d5e5801d0ae31760')
+sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -38,16 +60,22 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- patch meson.build "${srcdir}/meson.build.patch"
}
build() {
cd "${srcdir}/${pkgname}"
rm -rf "${srcdir}/build"
- meson --wrap-mode=nofallback --prefix=/usr "${srcdir}/build"
+ meson --prefix=/usr \
+ --buildtype=plain \
+ --auto-features=enabled \
+ -Dexperimental=true \
+ -Dcava=disabled \
+ -Dtests=disabled \
+ "${srcdir}/build"
ninja -C "${srcdir}/build"
}
package() {
DESTDIR="$pkgdir" ninja -C "${srcdir}/build" install
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/meson.build.patch b/meson.build.patch
deleted file mode 100644
index 16821be7881e..000000000000
--- a/meson.build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- meson.build 2019-05-20 12:36:35.043814353 +0200
-+++ meson.build.patch 2019-05-20 12:36:33.353814279 +0200
-@@ -47,8 +47,8 @@
-
- thread_dep = dependency('threads')
- libinput = dependency('libinput')
--fmt = dependency('fmt', version : ['>=5.3.0'], fallback : ['fmt', 'fmt_dep'])
--spdlog = dependency('spdlog', version : ['>=1.3.1'], fallback : ['spdlog', 'spdlog_dep'])
-+fmt = subproject('fmt').get_variable('fmt_dep')
-+spdlog = subproject('spdlog').get_variable('spdlog_dep')
- wayland_client = dependency('wayland-client')
- wayland_cursor = dependency('wayland-cursor')
- wayland_protos = dependency('wayland-protocols')