summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
-rwxr-xr-xbuild19
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dc64bc136e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = waypoint-bin
+ pkgdesc = Consistent developer workflow tool
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://www.waypointproject.io/
+ arch = x86_64
+ license = MPL2
+ makedepends = unzip
+ provides = waypoint=0.1.0
+ options = !strip
+ source_x86_64 = waypoint-0.1.0.zip::https://releases.hashicorp.com/waypoint/0.1.0/waypoint_0.1.0_linux_amd64.zip
+ sha256sums_x86_64 = ce8ca2323a95f7497d6e6ca0b338191c55c13e05ed8337de0c19fe9cd8a0d015
+
+pkgname = waypoint-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e7528b1515da
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+waypoint-*.zip
+waypoint-*.pkg.tar.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a1a1f147652
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jonathan Wright <jon@than.io>
+
+pkgname=waypoint-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Consistent developer workflow tool"
+arch=('x86_64')
+url="https://www.waypointproject.io/"
+license=('MPL2')
+makedepends=('unzip')
+provides=("waypoint=${pkgver}")
+
+source_x86_64=("waypoint-${pkgver}.zip::https://releases.hashicorp.com/waypoint/${pkgver}/waypoint_${pkgver}_linux_amd64.zip")
+sha256sums_x86_64=('ce8ca2323a95f7497d6e6ca0b338191c55c13e05ed8337de0c19fe9cd8a0d015')
+options=("!strip")
+
+package() {
+ install -D -g root -m 0755 -o root "$srcdir/waypoint" "$pkgdir/usr/bin/waypoint"
+}
diff --git a/build b/build
new file mode 100755
index 000000000000..a39eeba8d8c5
--- /dev/null
+++ b/build
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+make_srcinfo () {
+ makepkg --printsrcinfo > .SRCINFO
+}
+
+build () {
+ updpkgsums && makepkg -s "${@}"
+}
+
+clean () {
+ rm -rf *.pkg.tar.xz *.pkg.tar.zst *.zip ; rm -rf ./pkg ./src ; true
+}
+
+main () {
+ clean && build "${@}" && make_srcinfo
+}
+
+main "$@"